Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Odd Gameplay Issues in Modded Siege of Dragonspear

hetreshetres Member Posts: 29
Hello!

I just recently started playing through another full run through of all the Baldur's Gate games. I have gone through BG1 and am about 3/4 of the way through SoD at the moment. I have installed mods, but I tried to triple check that they were compatible with BG1 and SoD before I started. I also have not had any problems up until now.

But suddenly...
  • Corwin will always just stop whenever given a command. Ex: walk over there...nah I'll just stop right here. Attack that goblin...I'll take a few steps then take a rest. I have tried turning on and off the scripts/AI but it doesn't seem to help.
  • Whenever I try to quick save I get a "Cannot save while in dialogue mode" message. I have to sit through 20-30 of these messages until I can finally save. I can't find anyone who is trying to talk and I have tried to get all my characters to force talk, but nothing has helped.
  • The game has started running slow, especially in battles. I have a Razer with an i7 and a GTX1060 so I don't think it's my hardware.
  • When I click on chests and boxes, the item selection pops up at the bottom, but within a second my dialogue box pops up on top of it. I have to pause the game to collect things from chests.
My feeling is that Corwin is trying to initiate some quest/RP dialogue but my game has gotten stuck in some sort of odd loop. This would explain to me Corwin's stopping, the "dialogue mode" save errors, and the dialogue box coming to the top all of the times. But, I don't know how to verify this or change it.

I'm trying to do a more heavy RP good party so I have:

Main Char: F Wizard
Created Char: M Fighter (started multiplayer game and switched save to single player)
Corwin
Dynaheir
Minsc
Safana

Let me know if you have any thoughts or suggestions and thanks in advance.

Comments

  • PaulaMigratePaulaMigrate Member Posts: 1,201
    edited May 2017
    The symptoms you describe are clearly a loop in Corwin's script trying to initiate a dialogue. You can easily verify it by kicking her out or CTRL+Y on her - the problem should be gone.
    In order to find the source of the problem, you need to find the script block that repeats - the most common reasons are that the dialogue that is expected does not exist or that Corwin does not have the correct dialogue file for it assigned to her creature file.
    Since I do not know which tools you are familiar with and which mods you have installed, it is hard to give you detailed advice.
    I would
    1. use stutterbug or LS-tool to identify the script code block in question
    2. use near infinity to see if the script itself is erroneous - if not it will point to the dialogue behind it.
    3. find out if that dialogue exists, is correct AND is associated with current Corwin creature file

    Somewhere along that analysis path the error should become visible.

    EDIT - as a minimum it would be required to do above step 1. Without solving the problem it would allow you at least to advance the respective global, thus the dialogue would be lost but the game can continue.

  • hetreshetres Member Posts: 29
    Thanks a ton!

    I'll try some of this out tonight.

  • hetreshetres Member Posts: 29
    I don't have too much experience with near infinity, but I will try some of these things.

    From browsing around this forum it looks like I probably screwed up one of Corwin's romance talks because I was "ctrl-j"ing around maps. I wonder if I can just set the global romance variables to all 2 to make it go away!?

  • hetreshetres Member Posts: 29
    No luck yet and I can't seem to find out how to get/use stutterbug or LS-tool. Or even what they are.

  • PaulaMigratePaulaMigrate Member Posts: 1,201
    edited June 2017
    It is very hard to diagnose those issues from remote (you need a savegame AND the scripts exactly as they are in your game).
    Here is a very old link but the things are still valid and useful even in EE in 2017.
    http://www.shsforums.net/topic/33937-how-to-gather-clues-when-debugging-stuttering/

    And the jumping around may very well be the source here as the romance talks in SoD are triggered from area *traps*.
    You could check those with console
    C:GetGlobal("bd_CorwinRomance6","GLOBAL")
    C:GetGlobal("bd_CorwinRomance5","GLOBAL")
    C:GetGlobal("bd_CorwinRomance4","GLOBAL") and so forth
    If you found one that is stuck at 1 just set it back to 0, see if that helps.

  • Gate70Gate70 Member, Developer Posts: 3,664
    If you are at a point in the game where you can travel to the castle exterior and return, please try that.

    JuliusBorisov
  • hetreshetres Member Posts: 29
    I keep getting errors:

    Global: BD_CORWINROMANCE6 GLOBALDoes note exist

    For any of these numbers

  • hetreshetres Member Posts: 29
    Holy chips.

    Gate70 I think you solved it for me. It was some dialogue about Skie!

    JuliusBorisov
  • PaulaMigratePaulaMigrate Member Posts: 1,201
    hetres said:

    I keep getting errors:

    Global: BD_CORWINROMANCE6 GLOBALDoes note exist

    For any of these numbers

    This is no error, it just means that Corwin's lovetalk 6 or 5 or whatever was not yet due (Does Not Exist = 0)

Sign In or Register to comment.