Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

newbie with a problem

Hello, I am a Mac user of NWN 1.
I have installed what I thought was patch 1.72 - my screen says it's 1.72, yet when I load a module, it states I still need to upgrade Neverwinter.

Where/what did I miss here?

Thanks. :)

JuliusBorisov

Comments

Sign In or Register to comment.