Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

CLUA Console problems with SoD - lua file always over ridden

My PC imploded recently and I have had to reload everything. I am having increasing memory problems, and I couldn't remember how to install my BG Series games via steam etc - so I just brought the lot again from Good Old Games.

I have installed BGEE SoD (GoG version) no probs.

I want to enable the CLUA Console, but have had hassles. I've located the Baldur.lua file in the my documents - BGEE directory, and succesfully added this line using WordPad
SetPrivateProfileString('Program Options','Debug Mode','1')
However, every time I open the game a new copy of the original Baldur.lua file appears next to the altered version, and the console won't work. Trying to access it using Ctrl-Space just pauses the game, without opening the console. I am not opening "options" - all I need to do is open the game.

I am running Bg2-tweaks v16, and bg1npc-v22

Character creation and prologue run fine. I've also had no hassles adding custom portraits, and EE Keeper works as well.

btw I have read this thread - Clua Console No Longer Work? https://forums.beamdog.com/discussion/49822/clua-console-no-longer-work - but decided to open a new one as it's been a while since the last post there.

Comments

  • GusindaGusinda Member Posts: 620
    @kiwidoc, when you say that you have 2 x baldur.lua, are they both just called baldur.lua? If so, have you tried looking at their properties at all? One might be baldur.lua.doc or .rtf (with the .doc/rtf hidden). Wordpad's default is to save as .doc (or .rtf) and add a bunch of hidden metadata inside the file.

    You would be better off using a third party program to edit, like Notepad++ (its free), or at a pinch use Windows Notepad. Wordpad isn't the best tool for editing text files. If one of the files is .doc. or .rft, open it with notepad and have a look.

    BTW for info, BG2-Tweaks v16 is now decommissioned; Tweaks Anthology has taken it's place, and BG1NPC is currently at version 23.3.


    Gus

    JuliusBorisovGrond0
  • joluvjoluv Member Posts: 1,938
    Are you quitting BGEE before editing the LUA file?

  • kiwidockiwidoc Member Posts: 1,275
    @Gusinda many thanks for the advice. I finally managed to get the lua file to open using Windows Notepad (memory problems are a major bugger!) and saved it as a pure lua file, not a text document. This solved the problem completely YAY

    I'm going to do a re-install at some more sane hour of the morning, using the newest versions of the mods.

    GusindaJuliusBorisovGrond0
Sign In or Register to comment.