Skip to content

Rhino Beetle in Forest of Wyrms not spawning

HarpagornisHarpagornis Member Posts: 1,657
Hello! I am playing a solo Cavalier at LoB difficulty at the moment and read about the Rhino Beetle Armor.

Problem is: The Rhino Beetle isnt spawning in the Spider Cave. I moved (and waited) over the given coordinates endless times but nothing happens. What am i doing wrong? Or is it just a bug?

The spiders are all dead, i collected all loot, triggered the trap and even tried it with a full party. Still not working!

Thanks for your help! :)
[Deleted User]

Comments

  • HarpagornisHarpagornis Member Posts: 1,657
    I started a new game with another solo char. Same problem. This bug is a bug! ;)
  • FrancoisFrancois Member Posts: 452
    I know it didn't spawn in all my games either. I'm not sure, but I think you need to have the spider eggs in your inventory. Do you have them?
  • HarpagornisHarpagornis Member Posts: 1,657
    edited December 2016
    Yes i have all of them.... hmhmmm.... but i put them into a bag... will have to try it again!

    EDIT: Okay, put one egg into my inventory - but its still not working. Damn!
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 22,496
    edited December 2016
    Have just tried it - it works for me, no problem.

    Entered the cave, killed all spiders, took all spider eggs (5 of them), the beetle has spawned.

    The trigger for the rhino beetle spawn is around x=230, y=720 (westernmost spider nest, just south of a proximity trap). Walk over it to make the bugs appear.

    I can't reproduce the issue.
    Post edited by JuliusBorisov on
  • HarpagornisHarpagornis Member Posts: 1,657
    Thanks for your reply @JuliusBorisov!

    I did everything like you mentioned: Killed all spiders, looted all eggs, moved to the trigger area: Still no spawn! :(
  • HarpagornisHarpagornis Member Posts: 1,657
    Okay i tried it again:

    1. Killed all Spiders
    2. Looted everything including the Eggs
    3. Moved to the Trigger Area
    4. Rhino Beetle spawned

    It worked this time - dont ask me why... :D
    JuliusBorisovGallowglassGrond0Aerakar
  • HarpagornisHarpagornis Member Posts: 1,657
    edited December 2016
    Okay... there is definitely a bug!!!

    I did it again like above - this time the Rhino Bug did NOT spawn!!!

    Then i reloaded WITHOUT taking any loot - this time it spawned!!!!

    Please - there is something wrong with this bug! :D
    [Deleted User]
  • GallowglassGallowglass Member Posts: 3,356
    Of course there are some things in the game which have a random factor, but I doubt this is meant to be one of them. So yes, the bug is probably bugged.

    However, since the workaround is simply to try again until it works, I doubt this will get maximum priority. With luck, they'll fix it in the next patch, but that probably won't be for a few months.
  • TomCTomC Member Posts: 1
    I'm having the same problem as the other commenters. The variable "Sprite_is_deadBDGiantSpid1" is set to 1 and none of my party is hasted, but no matter how many times I walk over the trigger nothing happens. I'm happy to submit my save through your new bug reporting system if that would help.
    [Deleted User]
  • Gate70Gate70 Member, Developer Posts: 3,837
    Yes please do that. If you have a save from before entering the cave could you also attach that.
    Thanks
    JuliusBorisov
  • StarhowlStarhowl Member Posts: 39
    I have the same issue with the latest 2.5 patch; got all 4 spider silks and 5 spider eggs as well as the giant spider leg with the variable set to '1', but still the giant beetle doesn't appear.

    Is there a way on triggering the event via console?
  • Gate70Gate70 Member, Developer Posts: 3,837
    edited March 2018
    Hello
    Please revert your game to v2.3 if you have Siege of Dragonspear installed. Only BG:EE has been updated to v2.5 on desktop at this time and if you try to run that with v2.3 add-on you are likely to encounter various other issues.

    This console command should work, from memory. If it isn't, please attach a save.
    C:SetGlobal("Sprite_is_deadBDGiantSpid1","GLOBAL",1)
    JuliusBorisov
  • StarhowlStarhowl Member Posts: 39
    edited March 2018
    I already tried the suggested command and it's not working with v2.5.10, but it's supposed to be fixed with v2.5.3.

    Update: It's fixed now - someone went through my SAV-file and did the trick for me! ^_^
    Post edited by Starhowl on
  • Gate70Gate70 Member, Developer Posts: 3,837
    Yes I edited the save. Your SoD component is still at v2.3 so any 2.5 fixes specific to SoD will not be available and you may run into other issues mixing 2.3 and 2.5.
    JuliusBorisovStarhowlelminster
Sign In or Register to comment.