Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Axis & Allies 1942 Online is now available in Early Access! Buy it on Steam. The FAQ is available.
New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[Ranger Stronghold Quest 2] Delon never showed up to warn me and now the townspeople hate me.

DeadaliousDeadalious Member Posts: 1
edited March 2014 in BGII:EE Bugs (v1.2.2030)
As the title says, I never got the warning that they were being attacked and now they aren't interested in talking to me,

Any way I can work around this? I've got EE Keeper and some people were talking about editing the global variable ORGONASSAULT, deleting that, editing OGRON Attack to 1 and RANGERPROTECTOR to 1.

This lets me to talk to the townsfolk and even go to the cave to see Delon, however now Ogrons show up and the quest gets frozen.

Any help would be great.

Post edited by Jalily on
«1

Comments

  • CrevsDaakCrevsDaak Member Posts: 7,135
    I have very poor knowledge one this, but I'll ask for a saved game to see what is wrong.
    Please upload a save game before editing the variables with EEkeeper (and no 7Z plz).

  • oznikoozniko Member Posts: 9
    I had the same problem.. Ugh locked out? basically I reverted to a save point right after the last mission I did for the town. Which should be The quest with the mithral. I read that the next quest is around 4 days so I kept resting and coming back to the minister until he gave me the quest.

  • IllydthIllydth Member, Developer Posts: 1,641
    @Deadalious, @CrevsDaak, @Gate70: Moving to Not an Issue. Looks like the messenger was simply missed. I seem to remember seeing the same thing with my game when I was testing this quest. He does show up, but it's pretty easy to miss him.

    CrevsDaak
  • VakarianVakarian Member Posts: 94
    edited March 2014
    @Illydth‌, @CrevsDaak, @Gate70
    Not sure that I would call this "Not an issue" - been playing around with this one a bit in my current game. It seems that if you rest outside at the appropriate time, Delon shows up and talks to you. However, if the time comes and you are traveling between areas, he shows up, but doesn't approach you (he says he has an offer for you, but then walks away). If you click on him to talk within a second or so, you can get the quest as normal. If you don't talk to him quickly enough, you get the message that Delon is busy - you can't talk to him, he disappears and you don't get the quest.

    Post edited by Vakarian on
  • VakarianVakarian Member Posts: 94
    Save attached from a few hours before Delon is scheduled to show up. He will appear on resting or traveling (to any location that I've tried).

  • VakarianVakarian Member Posts: 94
    @Troodon80
    Can we move this thread back to the active bug reports or at least have someone look at it? It doesn't seem to be getting any attention here.

  • VakarianVakarian Member Posts: 94
    edited March 2014
    @Gate70‌
    No mods installed, and I have the current version of the game (v1.2.2030)

    Just repeated the process with that save by travelling to Trademeet, Umar Hills, and Waukeen's Promenade. Delon appears and says that he has an offer for you (you don't go into a conversation window, though.) If you talk to him quickly enough, you can get into a conversation and get the quest properly. If you take more than a second or two, he starts to walk away, and if you try to talk to him you get the message: "You cannot initiate dialogue. Delon appears busy" He then disappears after walking for a few seconds.

    No problem when he appears after resting.

    Also occasionally ran into that bugged line from Anomen, but that seems to happen after resting, not when travelling.

  • VakarianVakarian Member Posts: 94
    @Gate70
    I bought the game through Steam, so I don't have the Beamdog launcher. My computer does have 2 cores; if you can point me to where I can change the CPU affinity, I can try that.

    By the way, here is what happens when I travel to Umar Hills.image

  • VakarianVakarian Member Posts: 94
    edited March 2014
    Yep, spoke to him in the center of the government district to get the initial Umar Hills quest. (Don't think I've seen Umar appear on the map without talking to him...)

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    Huh. Most of the time he spawns for me and initiates dialogue as he should. Occasionally, however, he spawns, says "I have an offer for you if you wish to hear it," then walks off. It certainly sounds like a variable. I'll investigate further tomorrow unless @Gate70 gets there first.

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    @Gate70, this appears to be in Delon's script, or at least his script overriding what should be happening via the BALDUR script. Most of the checks in his own script appear to be for exiting the area after speaking to Minsc or completing the main quest in Umar Hills. I would assume a new variable would solve this issue. I'll get it reported.

  • AstafasAstafas Member Posts: 419
    Any solution to this, using EEKeeper? I ran into the same problem. :-(

  • CrevsDaakCrevsDaak Member Posts: 7,135
    edited April 2014
    @Astafas‌, @Gate70‌ found a fix but his posts were removed accidentally.
    @Troodon80‌ which is the issue on the scripts? (so I can fix it *and* know what is going on).

    @Astafas‌ could you please zip/rar your saved game and upload it to the forums so I can take a look at it?

    Astafas
  • Troodon80Troodon80 Member, Developer Posts: 4,110
    @CrevsDaak, the issue is basically Delon's entire script, or at least the portions that don't deal with the threats to the village. What should happen is Delon spawns, he then initiates dialogue, then afterwards he leaves. What is happening in this case is Delon spawns via the BALDUR script, then his own script overrides the BALDUR script and tells him to leave the area; because this is the 'clean-up' script for the Government District and other places where he spawns after a certain length of time.

    You would need to add an extra variable to every part of his script that is causing him to leave prematurely (you can use something similar to the stutter tool technique to figure out which portions are being a nuisance), then set it via his dialogue so that he will only leave after he has spoken to the player.

    I think the de'Arnise Keep messenger uses something along those lines, so you could probably copy similar portions and change the variables.

    CrevsDaak
  • thespacethespace Member Posts: 1,039
    Yup, the ranger quests are definitely buggy along these lines. I've had this happen on several playthroughs. No Delon (after the initial Delon chat and 1st ranger quest done), and the next thing I know I show up and the mayor tells me I've let them down blah blah blah. On one of the run throughs Delon showed up upon resting but just walked off. I wasn't able to talk with him. When I tried it gave me the "Delon is busy" spiel.

  • CrevsDaakCrevsDaak Member Posts: 7,135
    @Astafas‌, first, thank you for your patience :) and second, I created a fix for this, download the ZIP and drop the 7CFIXER.BS in your Scripts folder, that should be in the same directory as the CHITIN.KEY (make a search in your computer and you'll find it), and in the same directory create an override if there isn't one already. If the ZIP isn't showing, you can get it here.
    Open the game and select one of your characters, go to Record Screen->Customize->Script-> Select CUSTOM (7CFIXER), go back to the Game Screen and press the letter F only ONCE. Delon will spawn and give you the Ogre Invasion quest. If you press f again, Delon will spawn again to tell you that about Umar's Invasion. I hope this fixes your issues and everyone else's.
    Also, if you press D your character will turn into a Drow (it won't set variables so it's useless as a disguise in the Underdark, it is just for cosmetic use and it won't trigger twice on the same character, unless that character dies and gets revived), so don't press D ;)

    @Troodon80‌ I added a new variable, 7Cdelon7C, and used it for my script to block the BALDUR.BCS from spawning Delon for that particular quest, so you only have to use the script once to fix this issue.

    VakarianTroodon80M0tanthisisnotanexit
  • CrevsDaakCrevsDaak Member Posts: 7,135
    @Astafas‌ / @Troodon80‌ I forgot one file, DELON.DLG.
    Now this fix should work if you drop DELON.BCS and DELON.DLG in you override folder.
    And if you don't want to wait for the BALDUR.BCS to trigger him to spawn (probably he *won't* span if this bug is happening) use the 7CFIXER.BS.

    Troodon80Gate70AstafasVakarian
  • Gate70Gate70 Member, Developer Posts: 3,595
  • AstafasAstafas Member Posts: 419
  • GentblueGentblue Member Posts: 34
    IIRC this bug only occurs when you have Anomen in the party. A workaround fix for those not romancing him is to simply kick him out to allow Delon to chat.

  • gcharmagcharma Member Posts: 6
    Hi all, @CrevsDaak‌ - these files seem to be MIA and I've run into this issue myself now... anyplace else I can grab them from? Thanks!

  • Gate70Gate70 Member, Developer Posts: 3,595
    Trying to remember the "fix" I suggested. It was something to do with NumTimesTalkedTo(0) so that must be a variable held somewhere in the save - probably Delon as an out of party character via EE Keeper?

  • CrevsDaakCrevsDaak Member Posts: 7,135
    @gcharma‌ I could download them myself well, but anyway I re-uploaded them here and here.
    Gate70 said:

    Trying to remember the "fix" I suggested. It was something to do with NumTimesTalkedTo(0) so that must be a variable held somewhere in the save - probably Delon as an out of party character via EE Keeper?

    it has to do with:
    -Nusmtalkedto not checked
    -no variables check in the BALDUR.BCS
    -no check of why he was spawned for
    -dialog variable checks does not go according to the checks in Delon's script
    -timer not checked until expiration

    So yeah, that causes one little part of this problem ;)

  • gcharmagcharma Member Posts: 6
    @CrevsDaak‌ - Got 'em - thank you very much!

  • gcharmagcharma Member Posts: 6
    @CrevsDaak‌ - sorry, but no dice with this. I'm using the Steam edition, if that matters:

    - 7CFIXER.BS is in the "scripts" folder: C:\Program Files (x86)\Steam\SteamApps\common\Baldur's Gate II Enhanced Edition\scripts
    - DELON.BCS and DELON.DLG are in the "override" folder: C:\Program Files (x86)\Steam\SteamApps\common\Baldur's Gate II Enhanced Edition\override

    I replace the CUSTOM (DEFAULT) script on one of my followers (I've used Hexxat and Aerie as well as my main character), return to the game screen, press K, nothing happens. For the heck of it I also tried D, and no drow for me. :) I also tried spawning Delon manually, but he just walks away.

    Any thoughts? This isn't a deal breaker for me, but heck - if I can get it working, that would be fantastic. Thanks!

  • Gate70Gate70 Member, Developer Posts: 3,595
    Can you zip & attach a save @gcharma‌ please.
    Thanks

  • CrevsDaakCrevsDaak Member Posts: 7,135
    edited July 2014
    @gcharma‌ you placed the stuff in the wrong location—the scripts should be located in C:\Program Files (x86)\Steam\SteamApps\common\Baldur's Gate II Enhanced Edition\Data\[number-named folder]\Resources\Scripts. Be sure that the Scripts folder is in the same directory as the CHITIN.KEY. The override folder should be in the same directory, but you might have to create it by yourself (the scripts folder will be present in the same directory as the CHITIN.KEY.

  • gcharmagcharma Member Posts: 6
    Hi again,

    To both @CrevsDaak‌ and @Gate70‌, I should add that I'm using the multistronghold mod - if this script isn't compatible, then no worries and my sincere apologies for wasting your time.

    @CrevsDaak‌ - your structure is very different from mine... my CHITIN.KEY is at C:\Program Files (x86)\Steam\SteamApps\common\Baldur's Gate II Enhanced Edition (which is why I dumped files into the "scripts" directory also at this level). There was already an override folder here so I used it. This is a straight download from Steam, I didn't change the install directory or anything. Weird. The "data" folder exists, but has no subfolders (just a bunch of .bif files).

    @Gate7o‌ - I attached my latest quicksave - lemme know if you need anything else.

    Thanks again all!

  • Gate70Gate70 Member, Developer Posts: 3,595
    OK, this looks complicated. If you can remember exactly what has happened it might be fixable.

    I think this is the situation.
    - You have killed the Shade Lord.
    - Madulf has agreed to protect the village.
    - You stopped Lord Tombelthen one way or another.
    - You missed the call to Umar about ogrons.
    - When you then turned up at Umar Madulf and the ogrons have gone.

    Is that correct or is it slightly different?

Sign In or Register to comment.