Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[How to] Install mods on Android

11112131517

Comments

  • GusindaGusinda Member Posts: 1,588
    Hi @Novakor, and welcome to the forum. I haven't used Big World at all so can't comment on it. For SCS, I have been using the v32 RC7 for installs which haven't been a problem (use to get an error with v31). This might just fix your issue. You post is quite convientent... I am currently making a modfile for BG2EE and in searching tor the SCS link, I notice that SCS v32 RC8 is now out. Thanks. One thing to note is that it is a RC and therefore may have some bugs but it still be an improvement on v31...

    If this doesn't fix your mod installs, then could you describe your problem a little more. Do you have PC versions as well and are you using these to create your modfiles with or just the Android version? What order are you installing the mods etc...

    I am guessing here that you are only modding BG1EE. If you also intend on modding BGSOD and BG2EE, then some things may change with modfile itself but this can be covered later.

    Glad to help out where ever I can.
    Gus

  • NovakorNovakor Member Posts: 26
    @Gusinda
    Wow, thanks for the fast reply!
    I had also been using SCS v31, because that seemed to be the latest version on the website for it.

    Basically, what I want to do is install a handful of popular and recommend mods for bg1ee, the latest version, I do not have the pc version, nor any experience with modding anything. I have read through your guide to modding on Android (though it was unfinished?) So turned to an older one on the forum here https://forums.beamdog.com/discussion/43990/how-to-install-mods-on-android/p1
    I've been following it through, but have gotten myself completely confused when assembling the module (I'm happy with my install order, I did my research)
    Do I have to find every last file that was edited upon installing my mods (and if so, how) and put them in the modfile, or do I just take all of the directories and put them in it?

    I have assumed the latter, but this file is now 3GB, which feels wrong (not had the chance to test it yet, I've been struggling over it all evening)

    The mods I've used are:
    SCS (the part that works with v31)
    Unfinished Business
    Romantic encounters
    Tweaks
    NPC project
    Portraits portraits everywhere
    Mini quests

    (Not in that order)

    Order of installation was
    PPE
    UB
    Mini quests
    RE
    NPC project
    Tweaks
    SCS

    In short, I'm hopelessly lost, and while I'm keen to learn how to mod this game, I've spent so much time fruitlessly that at this point I'd really, really appreciate it if someone could either help me out, or make a mod file with those mods in for me

  • GusindaGusinda Member Posts: 1,588
    @Novakor, yeah, the modfile sounds way too big. I did a similar modfile and the size was about 100 MB (compressed down to about 60). It sounds like you might be including all of the /lang folder (and some others).

    Sorry for the wall of text!

    The guide written was for the betas; some of the document is not required (such as having to edit the .obb files to get the mods working) but most is still relevant. I was going to wait for the 2.6 release before updating it but will have a look sooner.

    I will give an outline of the proceedure I use. If any part of it is 'glossed' over and you need more info, let me know and I will expand.

    I will start from scratch, so suggest you do the same. Give yourself a clean start so to speak...

    1. Create the modding area with your Android version of the game on your PC. There is no change to the procedure outline in this document for the Preparation Section.  Wasn't sure which doco you had so I thought I had better link it. Of course, rename the folders to represent your game and version.

    2. Once that is done, you are ready to start modding the game. Skip Section 2 of the doco.

    3. I am guessing here that you have added mods (maybe orig BG series) before. You seemed to have that under control. Your order seems good although I always put PPE last due to running it on PC but not on Android. I only have a Note4 so screen realestate is precious.

    4. Creating Modfile:
    (Assumption - you are using en_US as the language. If not, then you need to use the appropriate language folder)
    a. Section 3 is still relevant here, so use it as the basic reading.
    Note the line:
    - Copy 'E:\BD Android\BG2EE 2.5.16.6\lang\en_US\dialog.tlk' to 'E:\BD Android\BG2EE 2.5.16.6 Modfile\lang\en_US'.
    This means that you only copy dialog.tlk from within the lang\en_US folder to the modfile\lang\en_US folder. The rest of the folder of most likey not required. The only reason you would need any of it is if there were any voice files copied to the folder. It is unlikely to occur as most mods place their NPC voice files into the 'override' folder. If you are adding your own, then you would use a different folder (\sounds which would be a folder you create under \Files on your device - noted in the document)

    b. New step not in document. For en_US, in your 'E:\BD Android\BG2EE 2.5.16.6 Modfile\lang\en_US' folder, create a copy of dialog.tlk and rename it to dialogf.tlk.
    This is being used to fix some of the INVALID statements that could show up depending on what mods are used. I have found some, so now use it on all modfiles.

    c. Copy 'E:\BD Android\BG1EE 2.5.17.0\override' (or whatever you named it) folder to 'E:\BD Android\BG1EE 2.5.17.0 Modfile' giving you 'E:\BD Android\BG1EE 2.5.17.0 Modfile\override'.
    This means only the 'override' folder. No other folders required.

    In the folder 'E:\BD Android\BG1EE 2.5.17.0 Modfile', you should now have the following:
    E:\BD Android\BG1EE 2.5.17.0 Modfile\lang\en_US\dialog.tlk
    E:\BD Android\BG1EE 2.5.17.0 Modfile\lang\en_US\dialogf.tlk
    E:\BD Android\BG1EE 2.5.17.0 Modfile\override (and all its contents)
    E:\BD Android\BG1EE 2.5.17.0 Modfile\centralfix.exe

    d. We are now ready to create the modfile to transfer to your device. I use WinRAR to do my compression but both WinZIP and 7Zip are just as capable.
    When making the lang-en_US.zip, the compression method used to package the file together needs to be STORE. This means that there is no compression of the files. If you have a look at the size of the dialog.tlk and double it (due to dialogf.tlk), you will get an idea of what the size of the lang-en_US.zip is supposed to be.

    Right Click on 'E:\BD Android\BG1EE 2.5.17.0 Modfile\lang' folder and select Create Archive from the context menu. Name the file lang-en_US.zip and make sure the compression method is set to STORE. Hit OK and the file should be created.

    e. Centralfix the language file. This is done to allow the game to read the contents of the lang-en_US.zip file. If it isn;t done, the game will ignore your modded version and use the vanilla version giving you a bunch of INVADLIDs in the game or even crashing the game on startup.
    If you are familiar with the Command Prompt, then no probs in using it with the commands below. If you are unfamiliar, then in the same folder with  create a document called 'centfixlang.bat' and place the following lines in it and save/close:

    centralfix lang-en_US.zip
    pause

    Run it and it will fix the index of lang-en_US.zip file showing results and waiting for a key to be hit before closing. You can just drag lang-en_US.zip onto centralfix.exe but you wont be able to see any results.
    If you mistakenly compressed the lang-en_US.zip and didn't notice, centralfix will still fix the index but the game wont be able to read the contents defaulting to vanilla dialog.

    f. With the most important file treated right, the rest should be easy. Select lang-en_US.zip and the 'override' folder and create the modfile.zip file. This can be at maximum compression. I have used both .zip and .rar formats with no problems. You can name the modfile whatever you want. In the name, I include the game and the version number as well as some identifier. eg: BG1EE.2.5.17.0_Novakor1.zip. The modfile will only be relevant for this version of the game as the dialog.tlk will change for the next. I also keep the WeiDU.log (and rename it to the same name) so that I can rebuild the mod if needed later.

    5. Transfering to device and uppacking the file.
    You are now ready to transfer the file to your device and unpack. Section 3 is still relevant. Things to note here are that you need to make sure that the game only has access to the lang-en_US.zip and no other .zip. Having 2 .zips in the root of \Files will confuse the game and it will crash on start.
    Test the game for the correct dialog.tlk. Because you have no additional kits (my usual check), I think the first indicator is after leaving Candlekeep and recruiting Imoen. When you have her in your party, initiate a talk with her and you should see some NPC Project dialog start. If it is text as expected and not INVALID statement, then all should be good.

    I will stop now and let you digest all this. If you feel that you have indigestion coming on, ask Qs and I will atempt to answer...

    Whilst reading the modding document, I see that it had some gaps... These will be fixed in the next release.

    If you want, Section 4 is also relevant to allow you to edit your saved game or create your own content/modify game content. It doesn't take much to setup and it is worth it.

    If you would like to use the Console Prompt in your game for those situations where you need it (ie: move along a romance or quest etc), there is an easy way to access it as well.

    I have only talked about modding BG1EE, if BGSOD and/or BG2EE are going to be modded, then we can talk about that later. There are some 'tricks' that you might need to clear the INVALIDs but I haven't yet needed them in BG1EE.

    Good Luck
    Gus




  • NovakorNovakor Member Posts: 26
    @Gusinda
    Thank you very much for taking the time to write all of that out, but I am still left with a few problems/questions
    Firstly, SCS still isn't working for me, I have now tried both versions you mentioned yesterday, and in both cases it failed to 'initialise AI components'
    The error message was:
    ERROR: [stratagems/ssl/libdata.txt] -> [stratagems/ssl] Patching Failed (COPY) (Failure("resource [splstate.ids] not found for 'COPY' "))
    This was for the v32 RC7 which you mentioned working
    Next, for these particular mods I'd like to use, is the override folder and lang enough, or did they also change files in the movies, music, scripts, etc. Folders and I've got to do something with that?

  • NovakorNovakor Member Posts: 26
    I should also mention that I'm using the NPC project music pack too

  • NovakorNovakor Member Posts: 26
    @Gusinda
    Ok, an update. I decided to leave SCS for now and focus on the other mods, and it all went pretty smoothly, though for some reason the tweaks mod wouldn't let me install unlimited stacks, but never mind. (I hope trying to install this hasn't broken anything...)
    I've had a look at the date modified of files in the movies, music, scripts, and data folders, and found that while the movies folder itself was last modified, the files inside are all completely untouched (it's saying the folder was last modified at 10:44, the files inside say 16:17 the previous day) so I assume I can ignore this?
    On the other hand, there are two files, blank.mus in the music file, and 0ikmorph.bs in the scripts file that have been modified/created since installing my mods,so do these go inside my modfile?
    Also, for the thousands of new files contained in folders created by extracting the mods, are these all dealt with now that the mods are installed, or do some of these need finding and putting in the modfile too?

    Thanks again for the help you've been giving me!

  • NovakorNovakor Member Posts: 26
    Another update bearing difficulty: 'centralfix' is not recognised as an internal or external command, operable program or batch file.
    Is what my command prompt gives me when I try to run the .bat file you mentioned

  • NovakorNovakor Member Posts: 26
    That, or it cannot find the file specified when I also put the centralfix.exe in the same folder as the .bat and lang-en_US.zip

  • NovakorNovakor Member Posts: 26
    edited February 2019
    @Gusinda
    Yet another update... I got centralfix working, after some digging on the forums I found it wouldn't work with the default command prompt on windows 10 that I was using, I needed to open command line by typing cmd into file explorer. Have assembled a modfile with all mods bar SCS, and I included the 2 new files in music and script directories in the modfile too.
    After very briefly testing it, the portraits mod and NPC project are definitely functioning. Also, the game seems a bit laggy, but is still playable. SCS still isn't working for me though, and I'd appreciate any advice you might have concerning that, but either way, thank you very much for the help you've given me, thanks to you I've successfully installed my first mods!

    Gusinda
  • GusindaGusinda Member Posts: 1,588
    @Novakor, you have been busy overnight (well my overnight). It is good to see progress.

    For the NPC Project Music - I think there were a couple of files blank.mus in the root of \Music as well as a folder called \Music\Blank. In your modfile folder, create another folder called \music and copy those across. For the script, create a folder called \scripts and copy the .bs across. You can also include any of the customs ones available. The should show up when you select the scripts for your chars.

    I wouldn't expect any extra Movies in those mods but if there were, you can do the same, create a \movies  folder and copy the new content in. The other override folder that you might want to use is \sounds. You can place any stand alone voice packs (no WeiDU installer) in this. When you use the installer, most of the time you get the subtitles as well, with the stad alone version, you don't get the subtitles but you do get the voice sounds.
    The rest of the files should be in \override.
    Other folders of interest you can create on your device (or in the modfile creation area that can be included in your mod) are:
    \portraits (to place your custom portrats)
    \characters (to put in your .chr [exported charater files] files)
    These will unpack into your \Files folder and be available in game.

    In summary, these folders can be created in you modfile area and included with the mod when packaging:
    \character
    \movies
    \music
    \portraits
    \sounds
    \scripts


    Good to see you have centralfix working. Not sure what is happening with the .bat file but a quick look will give some insight.

    Lets have a look at SCS.

    Would you be able to upload the following (all will need to be renamed to .txt for the upload):
    centralfixlang.bat 
    WeiDU.log
    setup-stratagems.debug

    Not sure why the game may be lagging. What device are you using?

    Good job in working the modfile!
    Gus

  • NovakorNovakor Member Posts: 26
    edited February 2019
    @Gusinda I had to install SCS again, but it stopped at a different point this time, at ease of use party AI. Here are the files you wanted anyway.

  • NovakorNovakor Member Posts: 26
    Looks like our timezones cross over pretty badly, since it's the late evening right now and I'm about to call it a night. Any help with SCS would be much appreciated because while I don't want to play at a stupid difficulty level, I'd really like to try this mod everyone seems to rave about!

  • NovakorNovakor Member Posts: 26
    Oh, and I'm using a Samsung galaxy Tab S, which handled both the vanilla bg1ee and bg2ee fine, I get slight lag, or more accurately the game just seems to slow down (walking pace becomes a crawl) occasionally.

  • GusindaGusinda Member Posts: 1,588
    HI @Novakor, this is what's good about the forum. No need to worry about time zones... I have used the Tab S in the past, in fact it is my wife's device now as I went to a hybrid.

    -----------
    Easy one first:

    Centralfix problem is just a typo. The .bat file reads:
    centralfix lang-un_US.zip

    but should read
    centralfix lang-en_US.zip

    -----------
    SCS:

    I prepared an install with all the mods exactly (including versions) as you installed, except I guessed a little for the SCS mod as WeiDU did have much info and the .debug file does capture keystrokes. Sad news is that I couldn't get it to fail. I suspect that you might have had a couple of uninstalls/reinsatlls of mods before hand which might have upset the cookie cart and might have produced some errors?

    The best thing to do now is to give yourself a clean slate. To do this without having to unpack all the files again is to delete 'override' folder, WeiDU.log (keep weidu.conf as this only has your default language selection), all of the .DEBUG files and make sure you have a clean version of the dialog.tlk. I keep a clean copy inside the \lang\en_US folder called dialog_orig.tlk and I have a batch file to copy over the modified one. If you want to create one, create a text file called 'Z_StartNewDialog.bat' or whatever makes sense to you. It only contains one line so copy and paste the line into it, save and close:

    copy dialog_orig.tlk dialog.tlk

    You will may also notice a folder called 'weidu_external'. This is mostly used by SCS, so delete it as well.  Once all the files are deleted, it is like a brand new install. I wouldn't worry about the couple of files in Music or the Scripts folders. You can delete them if you want to but they would be written over with the new install and they wont interfere with other mods. BTW, I am unsure where the file '0ikmorph.bs' came from as none of the mods installed this in my scripts folder. There were no new scripts.

    I know how much everyone enjoys installing mods, sitting there reading everything and selecting the right options. I use batch file installs because I also enjoy it, so have created a batch file for your install. This will allow you to install any number of times if the need arises, like the installation fails for some reason. Copy the file down, rename it from:
    _BG1EE 2.5.17.0.NoSOD Novakar Mods Install.bat.txt to

    _BG1EE 2.5.17.0.NoSOD Novakar Mods Install.bat

    and place it in the root of your mods install area (where chitin.key is). I have used a pause at the end of each mod install. Once you are happy, you can either delete the pause line or just place a 'rem' in front of it. This represents a remark and what follows is ignored by the command prompt.

    If you want to modify it to add new content, mods etc, or remove particular components, open the file with a text editor and you are likely to get a sense of how it is built. If you don't then let me know and I will describe it. The numbers at the end of the command line all come from WeiDU.log. So you will need to install a new mod manually at least once to get the component numbers you want. The ones I use are a little more comprehensive but if you want a copy, I am more than happy to pass them on. For the text editor, I use Notepad+ (free) but Windows Notepad will do the trick. You just need to make sure that Notepad doesn't add a .txt to the end of a new save (which it is known to do).

    I have included the Tweaks stacking of items in this install but let you know which numbers to remove if you don't want them. I have also taken a guess at what SCS components to be installed. If you want to not install it as part of the first run, add a 'rem' in front of the command. ie:

    rem setup-stratagems.exe    --language 0    --force-install-list    3010 etc...

    and it will be ignored. You just then need to run setup-stratagems.exe manually and answer the prompts etc. To fix up .bat file, get the numbers from WeiDU.log and make sure that only those are in the command line.



    Before you install again, I recommend the following:

    PPE v1.01 - has the latest WeIDU (this is a good thing with recommendation below)
    Unfinished Business v14 - update to v16 - Some components removed do to BG1EE patch level.
    BGQE v18 - no change
    BG1RE v2.7 - no change
    BG1NPC Project v23.3 - update to 24.0 Beta. There were some problems with 23.3 and BG1EE 2.5.17.0. You might want to install this first prior to everything else, get the numbers from WeiDU.log and update the command line to make sure you get the components you want. Then clean all the files away again for a clean install.
    BG1NPC Music v6 - no change
    CDTweaks v8 - no change
    Strategems v32 rc7 - RC8

    I have used the updated mods in the install batch file. I have also included a copy of the WeiDU.log to show what was installed.

    Make sure your WeiDU is up to date, the PPE version is the latest. If it doesn't update automatically, then just do it manually. ie: make a copy of setup-PPE.exe, which should then read 'Setup-PPE - Copy.exe', copy the name of setup-stratagems.exe, delete setup-stratagems.exe and rename 'Setup-PPE - Copy.exe' to setup-stratagems.exe. Rinse and repeat for all the other setup-modname.exe.

    You should now be ready to run the install batch and see what happens. When complete, have a look at WeiDU.log to make sure everything is what you want.

    [casts True Seeing and Bless]
    Gus


  • NovakorNovakor Member Posts: 26
    edited February 2019
    @Gusinda
    I installed the latest versions of the mods as you suggested, and I seem to have found the root (or one of the roots) of the issues with SCS for me. When installing the 'Ease of use Party AI' it still errors, giving me the message:
    This version of D:\Baldur's Gate\BGEE_Android Retry\stratagems\ssl\ssl.exe is not compatible with the version of Windows you're running. Check your computer's system information and then contact the software publisher
    (Emoji there because I used D next to : don't know how to stop that...)
    It had also run into an error before this point when trying to install 'Improved NPC customisation and management'
    Here was the error message:
    ERROR locating resource for 'COPY'
    Resource [splprot.2da] not found in KEY file: [./chitin.key]

    I didn't try the batch file this time round, I wanted to test if I could install all of the newest versions of the mods without it, but I will try that next (not to optimistic with the windows version incompatibility though.)

  • NovakorNovakor Member Posts: 26
    I've now tried the batch file you gave me too, with similar results to when I installed the mods manually, except this time there seemed to be several hundred of what I assume to be issues when installing UB and my other quest mod. I've attached the debug files and the weidu.log, if that helps in finding the issue
    I ran into the same issue with SCS, your .bat gave the same error message I mentioned in my previous post
    Since the issue is apparently my version of Windows, what I've been using is my lenovo 100s laptop, running Windows 10, 32bit operating system

  • NovakorNovakor Member Posts: 26
    For the tweaks mod, infinite ammmo stacking works, but infinite jewelry and potion stacking doesn't (but doesn't matter to me either tbh)

  • NovakorNovakor Member Posts: 26
    Also, it's worth mentioning that with the current mods I've installed, most of the new items are called 'invalid xxxxx' with differing numbers, and the descriptions of said items, as well as every piece of armour in the game is also invalid

  • GusindaGusinda Member Posts: 1,588
    Hi @Novakor, what version of Windows are you using? For info, I use Windows 10 Pro v1803 (still waiting for the current update) but my laptop (Lenono 720) has Windows 10 Home 1809 version and both have no problems installing the mods. If you are unaware of which version, you can open 'Settings', click on 'System' then 'About'. Both are 64 bit version so I will check to see if there is a difference when running 32 Bit (I still have an older laptop somewhere that has 32 Bit on it).

    I shall have a look at the logs throughout the day and see what can be found.

    For the invalids, would you be able tto upload you lang-en_US.zip file? I can test it against a build.

    Gus

  • GusindaGusinda Member Posts: 1,588
    Not sure what is happening with the forum but it seems we can't edit our posts anymore... ignore the typos.

    Had a thought. what anti-virus software are you using? Try disabling it when you do the mods install just to see what happens.

    Gus

  • NovakorNovakor Member Posts: 26
    @Gusinda windows 10 home 1607
    I've attached the lang file, and will try disabling my antivirus, thanks once again for the help here.

  • NovakorNovakor Member Posts: 26
    When installing mini quests and romantic encounters I'm still getting bombarded with:
    PARSE WARNING at line XXX column x-xx
    [StateCheck] argument [CD_STATE_NOTVALID] not found in [State.IDS]

  • NovakorNovakor Member Posts: 26
    When using the .bat that is.

  • NovakorNovakor Member Posts: 26
    I'm getting other ones too, such as [SetGlobalTimer] argument [TWO_ROUNDS] not found in [GTimes.IDS]

  • NovakorNovakor Member Posts: 26
    Same issue with SCS too I'm afraid

  • NovakorNovakor Member Posts: 26
    Oh and my anti-virus is malwarebytes free version

  • GusindaGusinda Member Posts: 1,588
    @Novakor, something is definately not right... It is like the override folder/dialog.tlk are not vanilla (clean) prior to a new install and some of the old files are interfering with the mod process. Your Windows version shouldn't be a concern. 32 Bit is fine but how did you stay on 1607? I am guessing this notebook doesn't touch the net too much. I have a Lenovo 100S as well that I have recently updated to the latest version of Windows. I am doing it up for one of my sons. I will see if I can use it to do the install. Do you have any addition storage (or just the 64GB) and does this mean that you are using a USB as D drive to do the install of mods? If so, is it a HDD or a key?

    I would start again from scratch, rename (or delete) the folder you are working in and unpack the .obbs again (making sure that you unpack main...obb first then patch...obb (there is an update in the patch that will overwrite one of the files. Rather than copy the mods folder, I would unpack the mods again from their download file into the new work area.

    When you unpack the .obbs, you should end up with 2,117 Files, 86 Folders when you look at the properties of the parent folder (with no mods in it).

    I had a quick look at your lang-en_US, it looks like it has been treated as expected. Index, structure and contents are good. I will place it in with the game I have put together to see if I get any naming of armours etc. I don't expect it to be fully compatible but I should see some armour.

    Gus

  • NovakorNovakor Member Posts: 26
    edited February 2019
    @Gusinda
    I've been using a SanDisk microSD card (64GB), since the internal storage itself is only 32GB, and I've been using ~22GB space (on the SD) for modding. I've not really used the laptop much in the past few years, which should explain the lack of up-to-date windows.
    I'll do as you suggest, but I've definitely been using the vanilla dialogue.tlk thus far, and I've lost count of the number of times I've reattempted it from scratch by now (somewhere in the double figures) and it isn't like SCS installed on the very first time I tried the install either.

    Post edited by Novakor on
  • NovakorNovakor Member Posts: 26
    @Gusinda
    Here is the vanilla (I hope) dialog.tlk I've been using

  • NovakorNovakor Member Posts: 26
    edited February 2019
    @Gusinda
    Ok, so I have unpacked the obbs... 1024 files, 76 folders... Where the hell are the other 1100?

Sign In or Register to comment.