Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[How to] Install mods on Android



  • GusindaGusinda Member Posts: 1,773
    @martinistripes, for that soundset, it installs the sound files into '/lang/en_US/sounds'. You could take the entire sounds folder if you want (the folder is about 7m in size without the additional mod files) and copy it onto your device. You can either copy it to:


    You could even place the mod sound files into the override folder if you want, but I like to keep them apart...

    Hope that helps

  • martinistripesmartinistripes Member Posts: 17
    Will the subtitles for each voice pack also work, just by copying the sounds folder to /files on my tablet?

  • martinistripesmartinistripes Member Posts: 17
    No, they don't. I get the message "Char: Invalid: 41***" whenever a character speaks.

  • GusindaGusinda Member Posts: 1,773
    @martinistripes, interesting. It shouldn't matter where it finds the files, only the fact that they are there. Would you be able to upload your No need to worry about the voice files themselves. I am guessing that this is the latest version of IWDEE?


  • martinistripesmartinistripes Member Posts: 17
    Actually, when I added the lang folder complete the new sound packs were not showing during character creation. I got the sound packs to show by just copying the sounds folder into /files. Perhaps I need the dialog.tlk though for the subs to work. I've uploaded my modded lang folder anyway (minus the wav files).

  • martinistripesmartinistripes Member Posts: 17
    I also tried copying the entire lang folder from my modded desktop install (minus other languages and stock voices) to /files and also /files/overide. Neither worked.

  • GusindaGusinda Member Posts: 1,773
    @martinistripes, okay, had a look at the and it wasn't centralfixed. This may not be a problem depending on which way the is being used.

    If you unpack the on the device, then the needs to be centralfixed prior to packaging the modfile. If this is the case, then the doesn't need to be centralfixed and can be compressed.

    If you keep all of the mod (override folder and lang folder) contents in and it is placed into the root of /Files and not unpacked, then it needs to be an uncompressed package and centralfixed.

    I would recommend option 1 as when the override folder becomes too large, it is known to create some problems.

    I am assuming that you have unpacked the files on your device. Attached is the which has had centralfix applied. See if that works.


  • martinistripesmartinistripes Member Posts: 17

    I copied your to /files and then copied my sounds folder (uncompressed) also to /files. Now the voice packs are there AND the subtitles work. Great.

    Can't understand where I was going wrong. Whenever I used centralfix I got a line for each file and folder in the zip saying "Local and Central headers missmatch:" followed by the name of the file/folder. Is this normal or perhaps an error?

    Anyway, it's working now. I'll backup what I've got and keep it safe! Thanks for your assistance.

  • GusindaGusinda Member Posts: 1,773
    edited August 2019
    @martinistripes, it was just an adjustment to the method. I have taken a copy of your procedure and modified it a bit to show where the problem may have been.

    I'm trying to get S9SoundsetsVol2 into my Android version of IWD:EE.

    Steps I'm taking:
    Copy OBB files to PC
    Rename extensions as .zip
    Extract (main file first)
    copy S9SoundsetsVol2 files to directory
    run "Setup-S9SoundsetsVol2.exe"
    After install create new folder (Android Files)
    Copy lang/en_US/dialog.tlk (maintaining folder structure) and overide folder to Android Files
    --- Create with no compression and centralfix (lang folder structure only)
    --- Add and override folder to with compression (I now use 7Zip as well)
    xxx Add to without compression (I used 7Zip)
    --- Copy to different folder
    xxx Run centralfix
    --- [Don't run centralfix as the is the file that needs to be centralfixed]
    --- Copied to a different folder on the tablet (ie: not in .../files)
    --- Unpack so that it looks like
    --- ../Files/override
    --- ../Files/sounds
    --- ../Files/baldur.lua
    --- ../Files/

    xxx Copied to the correct directory on the tablet (.../files)

    --- = Added lines
    xxx = don't do

    Give it a whirl while it is still fresh. Hopefully it will fix it for future modfiles.

    All the best

    Post edited by Gusinda on
  • Mantis37Mantis37 Member Posts: 1,120
    A quick query. On my tablet I have found that starting a new game results in 'invalid' responses showing up as if the dialog.tlk wasn't working, while my saved games seem to be working just fine. Can anyone think of a reason for this sort of anomaly?

  • IsayaIsaya Member, Translator (NDA) Posts: 750
    @Mantis37 Did you run centrafix on It's requested on the second part of the sentence for the very first step starting with "---".
    It's the main thing that can explain the "missing" texts.

  • Mantis37Mantis37 Member Posts: 1,120
    Yup, I played through a whole campaign first! Have done another install for now anyway.

  • ProkhorZakharovProkhorZakharov Member Posts: 1
    edited December 2019
    @Mantis37 or anyone else facing this issue in the future: I had the same problem where I was getting "invalid" responses in dialogue when trying to install the IWDNPC project mod on my tablet. However, I was able to get it working correctly. Here's what I did to get it working:

    1. Follow the instructions as laid out in the original post up to the "Creating the mods archive to transfer to Android" steps.
    2. ZIP up only the modded lang/en_US/dialog.TLK nested folder structure into the archive.
    3. Run centralfix.exe on the archive containing just that nested folder structure.
    4. Copy over the "IWDNPC" and "override" folders in loose (un-archived, un-zipped) format into the same directory where you place (/files).

    After that, the 'invalid' responses went away and the voices and dialogue work correctly. I hope this helps!

  • marhanmarhan Member Posts: 3
    edited December 2019
    I'm trying to install Unfinished Business mod for Planescape Torment on android. I got it to work fine (with the help from this topic) unless I use generalized biffing. There's a bug in this game that resets areas and merchants unless you use biffing. Is there any way to get generalized biffing working on tablet?

  • GusindaGusinda Member Posts: 1,773
    Hi @marhan, and welcome. Never had to do biffing for any of the EEs. Do you have a saved game that I could use to test with (and perhaps your WeiDU log as well)? Does this happen at a particular point in the game or for any area change? Also, what platform are you on (not that it should make any difference)

    There is still the Generalized Biffing mod that I have heard that people have used for EE (though haven't used it myself).


  • Warrax01Warrax01 Member Posts: 14
    I've have a very strange issue and i am hoping someone might be able to help me solve it.

    When i create a male main char, the mods are not working correctly. For example. if i try to create a wizard slayer none of the kit revisions are working and the description in the character creation is the original version, and he does not get the 10% initial magic resistence from the wizard slayer revision mod etc. However, if i create a female PC, the mods are working as expected. I create a wizard slayer and the creation description is the updated wizard slayer revision mod description and she gets the 10% initial magic resistance. Also the male PC has issues with the KeyRing item from the SOD import mod, when i examine it once i pick it up from the table, it has an Invalid ###### instead of the string for the name KeyRing. The female PC the string is perfectly fine. Any idea what is going on with my install? I have attached my WeiDU.log for reference and to see if i installed the mods in the correct order.

    I have tried a lot of ways to get this set of mods to work on android. The last version i tried is as follows.

    1. Unzip the .obb files from my android phone into a directory.
    2. Install the mods into the same directory.
    3. Create a seperate directory(_modfile) in another place and put the lang/en_US/dialog.tlk and copy of it dialogf.tlk into the _modfile directory.
    4. Copy the override directory into the _modfile directory.
    5. 7zip the lang directory into storage, no compression) and centralfix it.
    6. Create a zip file with the centralfix'd and the override directory.
    7. Move that to my android com.beamdog.baldursgateIIenhancededition directory
    8. Unzip the override and and move them into the files/ directory.

    I've also tried to install after i modded my computer version to the exact same mods, but its the same thing.

    I am confused why it seems to work perfectly for female PCs and not for male PCs? This does not happen on my computer version with the same set of mods. The male PCs have the correct kit descriptions on creation it has to be something with the move/copying to android or where i'm placing the files maybe?? I have no idea and any help would be appreciated!


  • GusindaGusinda Member Posts: 1,773
    edited February 2020
    Hi @Warrax01, interesting problem... Would you also be able to upload the modfile (if it isn't too big)?

    When you unpacked the files in the folder, did you also remove the modfile itself?


  • Warrax01Warrax01 Member Posts: 14
    @Gusinda thanks for the help. I cannot upload it here, it is 104MBs. I tried without deleting the and _modfile/ directory where I unpacked it. Also just tried deleting them and it's the same thing. The Male wiz slayer is the default kit, and the female one is the modded kit. I may be able to remove scs and get it smaller. Will try to get that done after work today and try to upload it.


  • Warrax01Warrax01 Member Posts: 14

    So i've done some more testing and still no luck, i'm now in the process of deleting my android install on my phone and going to redownload from the app store it just to make sure i don't have corrupted files. I've attached a test modfile with only the wizardslayer rebalancing mod in it and no other mods. When i try to create a male pc he sees the old text in the class description, and a female pc sees the new text. I even tried just installing the SOD2bg2 items mod that imports items from sod into bg2 unconditionally. The keyring in the table on a male pc i start has an invalid string for the name and it has the correct keyring string on a female pc. I am at a loss. I can recreate any modfile configurations you need to test, i'm at a loss now as to what to do. I will update here once my reinstall is finished, and what a new testmod does with that install.

    Question. What is a typical output of the centralfix look like? I haven't had time to look through the open source code yet so i'm not sure what is normal.

    I'm a coder btw(been doing it for 20+ years), so modding really has peaked my interest again in this game(played it way to much skipping boring college classes) and over the next couple months i do plan on learning as much as i can about the infinity engine and its modding tools. So, anything you might be able to point me towards as far as references and documents would be appreciated.


  • Warrax01Warrax01 Member Posts: 14
    edited February 2020
    So with a brand new install from the android app store. I unpack the .obb's and created a modfile with only the wizardslayer rebalancing mod. After all the steps, centralfixing, zipping it up transferring and unpacking, it still does the same thing. The male pc character created sees the old standard wizardslayer kit description, and the female pc sees the new modded description. I'm not sure if this will effect gameplay or not, i'm going to start the male pc and see if he has any of the mod abilities or not and will update.


    The male pc does have the correct magic resistance. But the innate abilities all have invalid names and descriptions, so something is definitely off still.

    Going to test the female pc and see if the innate descriptions are good or not and will update.


    Female pc wizard slayer's innate skill descriptions are perfect, no issues that i see.

    So, this leaves me to believe something is still messed up with my modfile, and i am reluctant to start any modded games on my phone until i have this resolved. I don't want to get far into the game and it start crashing on me or missing/invalid text starts showing up.

    Can you please try to make a test modfile for me for my android that i can test with only the wizardslayer mod installed? I've attached the wizardslayer mod download zipped up that i have been using.


  • GusindaGusinda Member Posts: 1,773
    Hi @Warrax01, can confirm your problem. Works well on PC but not on Android.

    Built another modfile with the same content for you to look at. Works on both Android and PC.

    Your 'Centralfix' is good so no problems there. The expected output for centrafix is a series of mismatch header errors and message of cleaning it up. If you try to centralfix again, there should be no header errors. All the program is doing is rewriting the header info so that the zipped file can be read by the game otherwise it ignores it and reads the original dilog.tlk.

    I am trying to look at the dialog.tlk. I would have expected the same size files as the same content is installed. Since you downloaded today, I expect that you have the latest version of the game so should be no change. You will see that the one I did is smaller so something is happening. I can see you are using the latest WeiDU, and since this is the file you are using, the content should be the same. Your .log shows the same...

    Anyway, I will have a look inside the dialog.tlk (using NearInfinity if you want to try same; you need Java runtime) and see if there is a hint as to what may have happened.


  • Warrax01Warrax01 Member Posts: 14

    I'm looking at the modfile you created for me. I am not seeing how your dialog.tlk is smaller? I'm looking at the size of the that i centralfixed in my modfile and it is 23,267,646 bytes, and your is 23,415,022(Which is 147,376 bytes bigger then mine). So i'm wondering if something is not working right when i am installing the mods to update the .tlk file. Could it be some kind of windows permission that is causing this where WeiDU is not able to write to the dialog.tlk correctly? I'm going to try to run the install as admin and see if that helps or makes a difference.

    Thanks for looking into this, and i'm glad its something that can be worked around since the one you sent obviously works. I appreciate your efforts, now I just need to figure out how to make my own modfiles that work.


  • GusindaGusinda Member Posts: 1,773
    Hi @Warrax01, I found out the difference... When I increase the size of the fonts for the World Map (I play on my phone so text is very small), I have changed the text in my dialog.tlk to delete some irrelevant information like instead of 'Travelling Hours' I have 'Hours' and changed 'Destination Unreachable' to 'Unreachable' otherwise they overlap. I just used the wrong dialog.tlk to create the modfile. I have just created a new one with the proper vanilla dialog.tlk and it shows the same results.

    However, I have also been able to get the result you are getting on your end with my files. If you unpack the modfile, then place the into another empty folder and unpack that. You will notice that I have a number of other folders that have dummy files in them. I was having problems with a different (can't recall now which one) mod and adding these fixed the problem so I just do it for all my BG2EE modfiles now (I batch most things so it is nice to have a standard procedure)...

    The files relate to some other override folders used in the game. These are (along with the dummy files names which are simply empty files of 0 (Zero) bytes) :


    I added these folders and dummy files to your mod and it all worked as it should... I can't yet say why this is occurring but it is another step forward and if you make it part of your procedure, then your modfiles should work. By the way, these aren't needed for BG1EE and may not be needed for 2.6.x when it gets here.

    As I said earlier, I use batch files to do most of the leg work for me so, if your not aware, the command for creating the empty file is:
    type NUL > .\movies\empty.wbm

    Hope that works for you as well and enjoy your modded game

  • Warrax01Warrax01 Member Posts: 14
    Thanks @Gusinda!

    I did see those empty files in your example modfile and meant to ask you if that could be the issue. It's strange how empty folders/files can have that dramatic an effect on the mod working or not. But I guess in my coding experience I've seen stranger fixes for random things. Thanks for all the help and when I get home from work today I'm going to add these to my big modfile and finally get to start my gaming again.

    I can definitely see how batching would simplify the modfile creation, and I will be creating some for sure. I really appreciate the help!

    I play on my phone also, so I like the idea of how you shortened some names etc for displaying on the map. I'm going to download NI this evening and give that a look also.

    Thanks again!


  • GusindaGusinda Member Posts: 1,773
    No problems @Warrax01, we try various abstract things when we need to to fix persistent problems...

    If you need a hand with the batch files and font changes, let me know. I can give you my batch install but it is very specific to my setup with rem'd out lines that I make active when a change is required. It is all commented so if you understand the batch syntax, then it would be easy to make adjustments where you want. Better than reinventing the wheel though.


  • ball_manball_man Member Posts: 5
    Double clicking on CreateEmptyFile.bat doesent create any file. Anyone know what could be the reason? 😕

  • GusindaGusinda Member Posts: 1,773
    Hi @ball_man, and welcome. There shouldn't be any need to create empty files anymore, there are other ways around the problems and this should be used a s a last resort. What are the problems that you are encountering? When you reply, could you also include info such as what OS you are using, what game you are modding as well as the version of the game.


  • ball_manball_man Member Posts: 5
    thanks for the reply @Gusinda. im a bit confused.
    aren't i supposed to follow the guide on page 9? i have access to a pc but don't have pc versions of the game. game version for bgee and bg2ee is

  • GusindaGusinda Member Posts: 1,773
    Hi @ball_man, the guide was essentially writen for the 2.5.16.x Beta, which at the time were problematic for modding (this discussion can outline some of the problems that people were haveing if you are insterested). Have a look here, which will give a summary of the current method I use. I do have some other steps but it depends if you get any errors and what those errors are... I think that you may have BG2EE in v2.5.16.6 as the two games haven't caught up yet. You still can follow the summary (the guide itself tells you how to create your modding area on the PC, so it is still relevant there), with an adjustment with modifying the .obb. If problems still exist at the end of all the problem solving, then removing dialog.tlk from the .obb is the last resort.

    Have that helps

  • ball_manball_man Member Posts: 5
    @Gusinda thanks for the help. I created a modfile using your method which works perfectly fine if use female character but I get invalid error during dialogue if I use male character. Any idea what could be causing this?

Sign In or Register to comment.