Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[How to] Install mods on Android



  • GusindaGusinda Member Posts: 1,588
    @martinistripes, for that soundset, it installs the sound files into '/lang/en_US/sounds'. You could take the entire sounds folder if you want (the folder is about 7m in size without the additional mod files) and copy it onto your device. You can either copy it to:


    You could even place the mod sound files into the override folder if you want, but I like to keep them apart...

    Hope that helps

  • martinistripesmartinistripes Member Posts: 16
    Will the subtitles for each voice pack also work, just by copying the sounds folder to /files on my tablet?

  • martinistripesmartinistripes Member Posts: 16
    No, they don't. I get the message "Char: Invalid: 41***" whenever a character speaks.

  • GusindaGusinda Member Posts: 1,588
    @martinistripes, interesting. It shouldn't matter where it finds the files, only the fact that they are there. Would you be able to upload your No need to worry about the voice files themselves. I am guessing that this is the latest version of IWDEE?


  • martinistripesmartinistripes Member Posts: 16
    Actually, when I added the lang folder complete the new sound packs were not showing during character creation. I got the sound packs to show by just copying the sounds folder into /files. Perhaps I need the dialog.tlk though for the subs to work. I've uploaded my modded lang folder anyway (minus the wav files).

  • martinistripesmartinistripes Member Posts: 16
    I also tried copying the entire lang folder from my modded desktop install (minus other languages and stock voices) to /files and also /files/overide. Neither worked.

  • GusindaGusinda Member Posts: 1,588
    @martinistripes, okay, had a look at the and it wasn't centralfixed. This may not be a problem depending on which way the is being used.

    If you unpack the on the device, then the needs to be centralfixed prior to packaging the modfile. If this is the case, then the doesn't need to be centralfixed and can be compressed.

    If you keep all of the mod (override folder and lang folder) contents in and it is placed into the root of /Files and not unpacked, then it needs to be an uncompressed package and centralfixed.

    I would recommend option 1 as when the override folder becomes too large, it is known to create some problems.

    I am assuming that you have unpacked the files on your device. Attached is the which has had centralfix applied. See if that works.


  • martinistripesmartinistripes Member Posts: 16

    I copied your to /files and then copied my sounds folder (uncompressed) also to /files. Now the voice packs are there AND the subtitles work. Great.

    Can't understand where I was going wrong. Whenever I used centralfix I got a line for each file and folder in the zip saying "Local and Central headers missmatch:" followed by the name of the file/folder. Is this normal or perhaps an error?

    Anyway, it's working now. I'll backup what I've got and keep it safe! Thanks for your assistance.

  • GusindaGusinda Member Posts: 1,588
    edited August 2019
    @martinistripes, it was just an adjustment to the method. I have taken a copy of your procedure and modified it a bit to show where the problem may have been.

    I'm trying to get S9SoundsetsVol2 into my Android version of IWD:EE.

    Steps I'm taking:
    Copy OBB files to PC
    Rename extensions as .zip
    Extract (main file first)
    copy S9SoundsetsVol2 files to directory
    run "Setup-S9SoundsetsVol2.exe"
    After install create new folder (Android Files)
    Copy lang/en_US/dialog.tlk (maintaining folder structure) and overide folder to Android Files
    --- Create with no compression and centralfix (lang folder structure only)
    --- Add and override folder to with compression (I now use 7Zip as well)
    xxx Add to without compression (I used 7Zip)
    --- Copy to different folder
    xxx Run centralfix
    --- [Don't run centralfix as the is the file that needs to be centralfixed]
    --- Copied to a different folder on the tablet (ie: not in .../files)
    --- Unpack so that it looks like
    --- ../Files/override
    --- ../Files/sounds
    --- ../Files/baldur.lua
    --- ../Files/

    xxx Copied to the correct directory on the tablet (.../files)

    --- = Added lines
    xxx = don't do

    Give it a whirl while it is still fresh. Hopefully it will fix it for future modfiles.

    All the best

    Post edited by Gusinda on
  • Mantis37Mantis37 Member Posts: 1,046
    A quick query. On my tablet I have found that starting a new game results in 'invalid' responses showing up as if the dialog.tlk wasn't working, while my saved games seem to be working just fine. Can anyone think of a reason for this sort of anomaly?

  • IsayaIsaya Member, Translator (NDA) Posts: 737
    @Mantis37 Did you run centrafix on It's requested on the second part of the sentence for the very first step starting with "---".
    It's the main thing that can explain the "missing" texts.

  • Mantis37Mantis37 Member Posts: 1,046
    Yup, I played through a whole campaign first! Have done another install for now anyway.

  • ProkhorZakharovProkhorZakharov Member Posts: 1
    edited December 2019
    @Mantis37 or anyone else facing this issue in the future: I had the same problem where I was getting "invalid" responses in dialogue when trying to install the IWDNPC project mod on my tablet. However, I was able to get it working correctly. Here's what I did to get it working:

    1. Follow the instructions as laid out in the original post up to the "Creating the mods archive to transfer to Android" steps.
    2. ZIP up only the modded lang/en_US/dialog.TLK nested folder structure into the archive.
    3. Run centralfix.exe on the archive containing just that nested folder structure.
    4. Copy over the "IWDNPC" and "override" folders in loose (un-archived, un-zipped) format into the same directory where you place (/files).

    After that, the 'invalid' responses went away and the voices and dialogue work correctly. I hope this helps!

  • marhanmarhan Member Posts: 3
    edited December 2019
    I'm trying to install Unfinished Business mod for Planescape Torment on android. I got it to work fine (with the help from this topic) unless I use generalized biffing. There's a bug in this game that resets areas and merchants unless you use biffing. Is there any way to get generalized biffing working on tablet?

  • GusindaGusinda Member Posts: 1,588
    Hi @marhan, and welcome. Never had to do biffing for any of the EEs. Do you have a saved game that I could use to test with (and perhaps your WeiDU log as well)? Does this happen at a particular point in the game or for any area change? Also, what platform are you on (not that it should make any difference)

    There is still the Generalized Biffing mod that I have heard that people have used for EE (though haven't used it myself).


Sign In or Register to comment.