Skip to content

[MOD] BGII:EE - Unofficial Item Pack

2456789

Comments

  • DarkersunDarkersun Member Posts: 398
    @Edvin to "List of BG2EE Compatible Mods" hope you don't mind. :)
    Edvin
  • EdvinEdvin Member, Translator (NDA) Posts: 3,173
    Version 2.0 !
    Many new things ! :)

    Girdle of Fortitude
    Blackmist +4
    New Items
    SoD Items
    Better archery shop
    mf2112rorikon
  • iavasechuiiavasechui Member Posts: 273
    ...i downIoaded this at 1pm today and now you have updateded it XD gIad I havent installed it just yet
  • iavasechuiiavasechui Member Posts: 273
    its not letting me download just telling me to sign it/ create an account
  • CahirCahir Member, Moderator, Translator (NDA) Posts: 2,795

    its not letting me download just telling me to sign it/ create an account

    Same to me, both on Chrome and Firefox.
  • EdvinEdvin Member, Translator (NDA) Posts: 3,173
    Sorry, my bad.
    Fixed.
    mf2112
  • iavasechuiiavasechui Member Posts: 273
    thanks ^_^
  • rorikonrorikon Member Posts: 105
    I'm gonna install this mod for the fixed girdle of fortitude alone. It always drove me mad the amount of tedious micromanagement that involved. I mean, it already lasted for like 12 hours anyway, how much difference would the full day really make?
    ineth
  • batoorbatoor Member Posts: 676
    Ohh!! You buffed blackmist=D

    While I rarely use that item, I always love the way you can acquire it.
  • EdvinEdvin Member, Translator (NDA) Posts: 3,173
    batoor said:

    Ohh!! You buffed blackmist=D

    Blackmist was certainly the weakest halberd +4.
    New passive ability is strong (especially against casters), but not OP.
    Dark side has to be more seductive. >:)
    mf2112batoor
  • comebackhomecomebackhome Member Posts: 254
    edited June 2016
    Seeing those bolt updates make my crossbow wielding Archer very happy. Since bows are boring after being overused. Any chance of replicating some more arrows with by e.g. bolt of piercing, bolt of slaying, bolt of dispelling/detonating. I know it's probably tedious but much appreciated.

    Also,please be compatible with item revisions because that's a staple MOD these days
  • EdvinEdvin Member, Translator (NDA) Posts: 3,173

    Any chance of replicating some more arrows with by e.g. bolt of piercing, bolt of slaying, bolt of dispelling/detonating.

    Interesting idea...

    Also,please be compatible with item revisions because that's a staple MOD these days

    Only first part of my mod is not compatible with item revisions.
    Remaining five are 100% compatible.

    Total compatibility will require redoing almost all items in first part.
    I can do it, but first I want to finish my mod.
    I still have a few more ideas.
    comebackhomemf2112
  • The user and all related content has been deleted.
    comebackhomeGrammarsaladmf2112
  • ameliabogginsameliaboggins Member Posts: 287
    edited June 2016
    nm)
  • ArthasArthas Member Posts: 1,091

    Edvin said:


    Only first part of my mod is not compatible with item revisions.

    Total compatibility will require redoing almost all items in first part.

    Worth it!
    agree.

    And by the way, wouldn't you be able to make the mod compatible with item revision, just by making only the artifacts be changed (like the mask you need to detect the fire elemental on firkraag's ruins?
  • EdvinEdvin Member, Translator (NDA) Posts: 3,173
    edited June 2016
    @Arthas
    I will create a separate installation for Q items.
  • ameliabogginsameliaboggins Member Posts: 287
    2 of the sod items seem bugged....

    Circlet of the Cynosure, wont move from inventory slot

    Wizzard Hat, says wrong item type when you try to equip it

    havent tried all the sod items, guess i should.

  • StefanOStefanO Member Posts: 346
    Could you please rename your mod to a name without blanks, e.g. UnofficialItemPackV2? It would make the life of us MacOS and Linux users a little bit easier.
    DrewUK
  • EdvinEdvin Member, Translator (NDA) Posts: 3,173
    edited June 2016


    Wizzard Hat, says wrong item type when you try to equip it

    I tried it just now.
    Wizzard Hat work perfectly fine.


    Circlet of the Cynosure, wont move from inventory slot

    Circlet contained script for Caelar Argent.
    Not a very good thing for BG2. :)
    Fixed.
    StefanO said:

    Could you please rename your mod to a name without blanks, e.g. UnofficialItemPackV2? It would make the life of us MacOS and Linux users a little bit easier.

    Tomorrow I will do a new version
  • ameliabogginsameliaboggins Member Posts: 287
    edited June 2016
    tried to equip the wizard hat on 3 differnt chars and it wont go in a slot, says `wrong item type`

    it is worn item right?

    can someone else try this item, see if working for them...

    can try keeper to add it....

    Weight: 0

    that the problem?
  • EdvinEdvin Member, Translator (NDA) Posts: 3,173


    Weight: 0

    that the problem?

    "Weight: 0" is original weight from SoD.
    This hat is 100% exact copy.
    I didn't change anything.
  • GrimLefourbeGrimLefourbe Member Posts: 637
    I might not understand correctly but just in case, iirc the wizard hat is worn as a hat and not a quick item. When in doubt, you can drag the items on the center of the inventory and it'll take care of it.
  • ameliabogginsameliaboggins Member Posts: 287
    nah wont work for me, had to keeper it onto the head slot. which is fine untill the char dies, then cant requip.

    think the Circlet of the Cynosure, maybe something at my end, I have a bow stuck in my inventory as well.I bought the circlet from the vendor, but will have to clear it out with keeper.

    perhaps its linked to haveing the 1.3 patch and not v2 patch /shrug

  • GrimLefourbeGrimLefourbe Member Posts: 637
    Yes you should have v2, not 1.3.
  • rorikonrorikon Member Posts: 105
    edited June 2016
    Yeah, that'll definitely be it. You're trying to use an SoD (and therefore post v2) item. Of course there's going to be problems with some of them, given a lot of the new engine features were to enable new item abilities and/or restrictions that were not possible before. You're kinda lucky ANY of the items work :)

    EDIT: perhaps the mod should check if the game version is lower than 2.0? Is that possible?
  • EdvinEdvin Member, Translator (NDA) Posts: 3,173
    I'll see what I can do.
  • The user and all related content has been deleted.
    rorikonEdvin
  • ameliabogginsameliaboggins Member Posts: 287

    Yes you should have v2, not 1.3.

    bought the disks.....informed this is all i can get.
  • GrimLefourbeGrimLefourbe Member Posts: 637
    This is surprising, I can't see any good reason the v2 would not be given to disc users, you can probably contact the beamdog support and download the v2. If you're unable to download at all then it might be a more complicated issue.
  • rorikonrorikon Member Posts: 105
    Sorry to hear that @ameliaboggins. I'd forgotten some people actually can't update to 2.0.

    I really hope Beamdog sort that out (regardless of who's responsible for the situation), it's inexcusable that those who bought a physical copy of BG can't get any patches. At least the android / IOS people know they'll get it eventually!
    ameliaboggins
Sign In or Register to comment.