Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

If you cannot install the EE or SoD on Mac OS Sierra

2»

Comments

  • grantggrantg Member Posts: 3
    Hi - any update on this issue? I've tried all the suggested workarounds and still cannot get the games to fully download.

    The only workaround that seems to work is deleting the download after it gets stuck. The downloads are getting stuck at different points for each game each time I try and download them.

    I haven't even been able to fully download any of the games yet so I don't even know if I'll have issues running them or saving games as other players have raised elsewhere...

    Thanks!

  • MartianartistMartianartist Member Posts: 1
    I was having this EXACT problem with Sierra, I changed my security settings, wrote myself a sysctl.conf file, and nothing would induce my Mac to start the download... until I realized I could still sudo launchtl. So, this is what fixed it for me, and in fact it was so good I registered here just so I could write this comment and maybe save some others the pain. From the command line:
    launchctl limit maxfiles
    --> this will return probably maxfiles 256 unlimited

    Then all you have to do is:
    sudo launchctl limit maxfiles 4080 unlimited

    You could also use a higher number if you're feeling adventurous, but I don't like to risk my system too much.

    Then from inside the Baldurs gate application in /Applications/Baldurs\'s\ Gate\ II\ -\ Enhanced\ Edition/Baldur\'s\ Gate\ II\ Launcher.app/Contents/MacOS/
    from command line run
    open ./Baldurs\'s\ Gate\ II\ Launcher\ Release
    (this is the exec file)

    I then got it to download and do everything it's supposed to. It appears as smaller because of my stupid high screen resolution but otherwise everything is roses. Good luck all.

    Gallowglasslolien
  • GallowglassGallowglass Member Posts: 3,356
    Perhaps this might even deserve to be stickied, since various Mac users have been struggling. What sayest thou, @JuliusBorisov?

  • manbearpighuntermanbearpighunter Unconfirmed, Member Posts: 1
    I registered for this site just to say thank you. I'm on Sierra 10.12.2 and I was having the same problem. The game is downloading now.

    JuliusBorisovlolien
  • chazhchazh Member Posts: 4
    Hey all

    I had a very similar issue, and had been using the game, then tried to "repair" it. After that I could not re-launch the game again, just sat in "Waiting for download". I did change GateKeep to permit "Anywhere", and I did what Marthianartist stated above, still didn't work hmpf!

    So, in concert with Marthianartist's procedures, and I went to the Baldur.lua file at:
    /Users//Library/Containers/com.beamdog.baldursgateenhancededition/Data/Documents/Baldur\'s\ Gate\ -\ Enhanced\ Edition

    ... and renamed the file to Baldur-temp.lua, then re-ran the launcher, and it sat there, so I tried to "repair" once again, and finally it downloaded and installed the app again. I launched the game with the bad default settings, and then quit. I went back to my folder above, removed the Baldur.lua file the game created, and renamed mine back to this name, then ran the game again, and all appears to be GREAT!

    You'd wish BeamDog could fix this, but perhaps all the Mac Experts here will get some type of compensation for fixing their issues as it's as if we are BD staff.

    Thanks all!

    Happy BGEE'ing!

    JuliusBorisovlolien
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 21,138
  • StefanOStefanO Member Posts: 343
    edited January 2017
    First of all: It isn't a BG2:EE only problem. BG:EE, SoD, and IDW:EE have the same issues. Since the thread is now stickied the title should reflect this.

    There are (at least) 3 major Sierra related problems:
    1. The launcher app itself can't be installed due to changed gatekeeper settings.
    2. Baldur's Gate / Baldur's Gate II / Icewind Dale Launcher keeps hanging on download. For a possible solution see @Martianartist post above.
    3. For modded games only: UPX compresssed binaries will not run on Sierra. Consequence: Each distributed weidu, disguised as setup-modname, will fail with the error message "Signal 9: killed". Consequence: The state of each modded game on Sierra is frozen unless the installer is either updated or decompressed. @subtledoctor has updated his OSX-Weidu-Launcher to include the newest stable version of Weidu, v240, which comes uncompressed.
    All this was known November last year. There should be some kind of Beamdog support document regarding the Sierra related problems. Together with recommended circumventures.

    JuliusBorisov[Deleted User]AstroBryGuylolien
  • StefanOStefanO Member Posts: 343
    Thanks to whoever changed the thread title.

    JuliusBorisovAstroBryGuylolien
  • AstroBryGuyAstroBryGuy Member Posts: 3,414
    Beamdog needs to do something about #1 & #2, but I don't see #3 as their problem. Issuing technical support documents about third-party modding tools isn't something they need to do. The modding community needs to spread the word among its members to update to WeiDU v240.

    A few years ago, many mods were still distributing PowerPC binaries of utilities like sox, etc.. Didn't look to Beamdog for a solution. We contacted mod authors asked them to update their distributions (and/or offered to create updated packages for OS X).

    StefanO
  • S4kagS4kag Member Posts: 1
    edited February 2017
    Hi all, I am having the same trouble as pgibbs who posted earlier with BGII EE - the game crashes on the first autosave following the dialogue with Imoen in Irenicus' dungeon. It was suggested that this could be fixed by recreating the "Baldur's Gate II - Enhanced Edition" folder inside the Documents folder but I have tried that and it has no effect. The game still crashes at the same point every time. Were there any other fixes or ideas?

    Edit: I am in the middle of migrating from one MacBook Air to a newer MacBook Air, both the same model. The new one came preloaded with Sierra 10.12.2 but has since been updated to 10.12.3 and this is is the machine I am having trouble with. The older machine came pre-loaded with Yosemite but has since been upgraded to El Capitan and then again to Sierra, also now currently running 10.12.3. I was able to bypass the Applications folder write permissions problem (happened on both machines, even the older one at the time it was running Yosemite) by copying the installer file to my desktop and launching from there. I just noticed now that iCloud had copied the installer from my new machine's desktop over to my older machine's desktop (as a new file) so I decided to try launching it on the older machine to see what would happen. It actually reinitiated the download and after this was complete I clicked launch and the game ran fine with no crashes upon saving. I have to get rid of this older machine (giving it away) so this is not a solution for me. Does any of this monkey business make sense or shed any new light on the issue?

    Edit 2: Hmm. Still having problems and they seem to change after every attempt to fix them. This time I went back to the drawing board and deleted all BGII EE related files on the entire machine and emptied trash. I then pulled the original .dmg file that I purchased out of my archive and tried installing the game all over from scratch. Install went fine. When starting from the game icon in the Applications folder I got the write permissions error again which I again fixed by copying it to my desktop and starting from there. Once started, it checked for an update, found one (first time I ever saw that), then began installing the update. When the update finished I clicked the "launch" button and the game crashed immediately. Now it crashes at this point every time, no exceptions. I created a new Baldur's Gate II - Enhanced Edition folder inside my documents folder, still no luck. Does this sound familiar to anyone?

    Post edited by S4kag on
  • DarkchanterDarkchanter Member Posts: 13
    I posted by hassles and eventual resolution to this under a different thread: https://forums.beamdog.com/discussion/comment/849729/#Comment_849729

  • BookwormcnyBookwormcny Member Posts: 1
    I am on Sierra 10.12.3 and I played last night with no problems. However, right now, the Launcher is stuck saying, "Waiting to Download". I would love to be able to do what others have suggested (ie. Martianartist, StefanO, etc) but I am a relatively newer Mac user and I don't want to (or know how to) mess with settings. I'm not familiar with Macs in that capacity and am quite irritated that a whole new fixable download hasn't been issued.

    Just thought I'd vent. So here I sit in Waiting to Download hell. :(

  • AstroBryGuyAstroBryGuy Member Posts: 3,414
  • StefanOStefanO Member Posts: 343
    A few minutes ago Beamdog has closed my bug report

    Bug #26828: Mac launchers should run correctly on macOS 10.12

    because the new Beamdog client fixes the bug. I agree.

  • GreenerGreener Member Posts: 388
    I can confirm, that BGEE, BGEE SoD, and BG2EE can be installed on macOS 10.12.6

Sign In or Register to comment.