Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


New Premium Module: Tyrants of the Moonsea! Read More
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Thief Controlled Script Responds to "D" Command, But Doesn't Stealth

grahamersgrahamers Member Posts: 29
I just finished BG1:EE and used "thief controlled" AI script on my thief. It worked fine, D-button changed between trap searching and stealthing mode. Now in BG2:EE I chose the same AI script, but the stealth mode does not work anymore. It DOES change between modes when pressing D, and search traps work normally, but stealth mode does not turn on, even if the character says "attempting to hide in shadows" on top of it. My thief just stands theer and there is no subsequent "failed" or "succeeded" message nor does the stealth button geta red outline or get greyed out as if a failure had happened.

If i click the stealth on manually, it works. I get the stealth message correctly on the chat window, but when it fails eventually, it does not turn on again automatically.

I have also tried toddling the "V" key ("attack enemies"/"do not attack enemies") but it does not affect search/stealth mode.

This is character I imported from BG1:EE, in case that matters.

I searched the forums and didn't see anyone post about this, but I did see an unanswered post on reddit describing my exact issues. (I stole much of his description for use here since it was exactly the same thing I was seeing.)

Any thoughts?


Sign In or Register to comment.