Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Neverwinter Nights: Enhanced Edition has been released! Visit to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Bg2:ee android fullscreen

AralyonAralyon Member Posts: 11
Hi, When I try to open baldurs gate 2 in fullscreen mode on Huawei mate 10 pro, it gets deformed and only about 1/3 of screen is visible while controls work the same. It works in bg1. What can i do about it aside of refund? I do really love this game, but this is huge hinder.
When I do not use fullscreen mode game window occupies only about half of screen.


  • GusindaGusinda Member Posts: 1,110
    @Aralyon, welcome to the forum. Would you be able to go into Options/Graphics and deselect Scaling just to see what happens? Also, if scaling is off already, make sure your font size isn't set to maximum.


  • AralyonAralyon Member Posts: 11
    edited January 2018
    Hi Gus, thanks for answer.
    I have tried to lower font size and disable scaling, but impact was unfortunately next to none.
    Maybe it is caused by 18:9 aspect ratio of mate 10, which is still not so common? Below are screenshots with and without fullscreen mode (enabled by that blue message)

    I would be super happy to resolve this issue as it would be blocker even to try iwd and iwd2 too. I would miss that a lot :(

    Edit: it is unfortunately impossible for me to try it in game as i am unable to navigate there.

  • GusindaGusinda Member Posts: 1,110
    edited January 2018
    Could you post the contents of your baldur.ini (found in '/android/data/com.beamdog.baldursgateiienhancededition/files').

    I also notice in the first picture that you have your homebar showing. Is this normal when you start or there for some other reason? If so, this might be interfering with full screen mode. I believe that there is an app to help with this.


    Edit: Having a quick look around, I think it is called 'Immersive Mode' (not on my phone). Do you have a toggle switch to enable/disable?

  • AralyonAralyon Member Posts: 11
    Homebar is displayed there because i took screenshot, otherwise it is not there in fullscreen (immersive) mode. If i actually disable this mode, game looks like this (note that it does not ocuppy whole screen, because there is space for that blue message and homebar - it worked perfectly in BG1) :

    As a bonus, I am unable to play cinematics in both bg1 and bg2 no matter the settings I use.

    Content of ini file with fullscreen mode:
    CREATE TABLE options (
    section string,
    name string,
    value string
    INSERT INTO options ROWS (
    'Fonts', 'ko_KR', 'UNBOM',
    'Fonts', 'zh_CN', 'SIMSUN',
    'Fonts', 'ja_JP', 'MSGOTHIC',
    'Fonts', 'ru_RU', 'PERMIAN',
    'Fonts', 'uk_UA', 'PERMIAN',
    'Graphics', 'version', 'OpenGL ES 3.2 v1.r8p0-00cet0.24b144663ec71bd0e3044e6fb024530e - build 256',
    'Graphics', 'renderer', 'Mali-G72',
    'Graphics', 'vendor', 'ARM',
    'MOVIES', 'LOGO', '1',
    'MOVIES', 'BLACKPIT', '1',
    'Graphics', 'Scale UI', '1',
    'Game Options', 'Footsteps', '1',
    'Game Options', 'Memory Level', '1',
    'Game Options', 'Mouse Scroll Speed', '36',
    'Game Options', 'GUI Feedback Level', '5',
    'Game Options', 'Locator Feedback Level', '3',
    'Game Options', 'Bored Timeout', '3000',
    'Game Options', 'Always Dither', '1',
    'Game Options', 'Subtitles', '1',
    'Game Options', 'Keyboard Scroll Speed', '36',
    'Game Options', 'Command Sounds Frequency', '2',
    'Game Options', 'Selection Sounds Frequency', '3',
    'Game Options', 'Effect Text Level', '62',
    'Game Options', 'Infravision', '0',
    'Game Options', 'Weather', '1',
    'Game Options', 'Tutorial State', '1',
    'Game Options', 'Attack Sounds', '1',
    'Game Options', 'Auto Pause State', '0',
    'Game Options', 'Auto Pause Center', '1',
    'Game Options', 'Difficulty Level', '2',
    'Game Options', 'Suppress Extra Difficulty Damage', '0',
    'Game Options', 'Quick Item Mapping', '1',
    'Game Options', 'Environmental Audio', '1',
    'Game Options', 'Heal Party on Rest', '0',
    'Game Options', 'Terrain Hugging', '0',
    'Game Options', 'HP Over Head', '0',
    'Game Options', 'Critical Hit Screen Shake', '1',
    'Game Options', 'Hotkeys On Tooltips', '1',
    'Game Options', 'Area Effects Density', '100',
    'Game Options', 'Duplicate Floating Text', '1',
    'Game Options', 'Tiles Precache Percent', '100',
    'Game Options', 'Color Circles', '1',
    'Graphics', 'Zoom Lock', '0',
    'Game Options', 'Over Confirm Everything', '0',
    'Game Options', 'Show Learnable Spells', '1',
    'Game Options', 'Render Actions', '2',
    'Game Options', 'Confirm Dialog', '1',
    'Multiplayer', 'Disable Banters', '1',
    'Program Options', 'Disable Cosmetic Attacks', '0',
    'Game Options', 'Render Travel Regions', '1',
    'Game Options', 'Pausing Map', '0',
    'Game Options', 'Extra Feedback', '0',
    'Game Options', 'Filter Games', '1',
    'Game Options', 'All Learn Spell Info', '0',
    'Graphics', 'Hardware Mouse Cursor', '1',
    'Game Options', 'Maximum HP', '1',
    'Game Options', 'Show Character HP', '1',
    'Game Options', 'Nightmare Mode', '0',
    'Game Options', '3E Thief Sneak Attack', '0',
    'Game Options', 'Cleric Ranger Spells', '1',
    'Program Options', 'Font Name', '',
    'Program Options', 'Double Byte Character Support', '0',
    'Program Options', 'Drop Capitals', '1',
    'Program Options', '3D Acceleration', '1',
    'Program Options', 'Maximum Frame Rate', '30',
    'Program Options', 'Path Search Nodes', '32000',
    'Program Options', 'Tooltips', '60',
    'Program Options', 'Translucent Shadows', '1',
    'Program Options', 'Sprite Mirror', '0',
    'Fonts', 'Zoom', '130',
    'Program Options', 'Volume Movie', '90',
    'Program Options', 'Volume Music', '40',
    'Program Options', 'Volume Voices', '100',
    'Program Options', 'Volume Ambients', '40',
    'Program Options', 'Volume SFX', '80',
    'MOVIES', 'INTRO15F', '1',
    'Language', 'Text', 'cs_CZ',
    'Program Options', 'Display Subtitles', '0',
    'Game Options', 'Last Save SOA', '000000001-Quick-Save',
    'Multiplayer', 'Last Protocol Used', '1',
    'MOVIES', 'INTRO', '1',
    'Window', 'Maximized', '0'

  • GusindaGusinda Member Posts: 1,110
    All looks well but I would rename the file to baldur.ini.old (or similar) and restart the game, let it build a new one. Will prob not make any difference but worth a try.

    The other one is Immersion. I don't have this on my phone (I think) as it has hard keys. Any chance you could try this (CMD Full Screen from Play) application to see if it makes any difference. It would be easy to remove if it doesn't work. It looks as if it is a different way to get full screen other than the way that the Huawei is using.

    [Casts True Seeing]

  • AralyonAralyon Member Posts: 11
    edited January 2018
    So I can confirm that it made no difference at all :(

    Anyway I have made particulary interesting discovery! When I change resolution of device to HD+ ( 1440x720) which is available in EMUI settings, it works perfectly! When I change it to FHD+ (2160x1080) it breaks again.
    So it seems that app has particular problem with this very high resolution. It might be fixable then :). Maybe there is some hardcoded cap in engine?

    After change to HD+ ( 1440x720):

    [Casts Greater Wish]

  • GusindaGusinda Member Posts: 1,110
    @Aralyon, you need to make sure that you post something about this to be looked at by the developers, otherwise Greater Wish never has a chance of success...

    Have alook here on how submitted a ticket (bug report). I tried to make a link to Redmine/Support pages but for some reason I am being timed out. Might be some work happening on the server. Include any of your screen shots in the description.


  • AralyonAralyon Member Posts: 11
    I will deffinitely do that, but i am also unable to connect to redmine :( Anyway - thanks for your help and we shall see if devs will do something about it :)

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 16,748
    Aralyon said:

    I will deffinitely do that, but i am also unable to connect to redmine :( Anyway - thanks for your help and we shall see if devs will do something about it :)

    The site has been down for one day, indeed (should be fixed ASAP). Thank you, @Aralyon , in advance (for reporting the issue).

  • AralyonAralyon Member Posts: 11
    For anyone willing or wanting to track this issue - it is created here:

  • AralyonAralyon Member Posts: 11
    In case somebody is interested in this issue - it does NOT happen in icewind dale: enhanced edition
    It still happen in BG2 tho and issue was not yet fixed...

  • AralyonAralyon Member Posts: 11
    edited June 2018
    good news everyone! It seems that after todays update it finally works! :)

Sign In or Register to comment.