Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[Kit Pack] Deities of Faerûn - v 1.9.4 [42 Cleric Kits and more for IWD, BG(2)EE and EET]

145791030

Comments

  • RaduzielRaduziel Member Posts: 3,431

    I forgot to mention that 1.6.5 did install the strongholds when I selected install all. I needed to uninstall that one component after.

    Are sure you used 1.6.5?

    I just tested using the "Install everything" option and it does not install the stronghold component.

    [DeitiesOfFaerun/Tra/English/setup.tra] has 43 translation strings
    [DeitiesOfFaerun/Tra/English/DeitiesOfFaerun.tra] has 229 translation strings

    SUCCESSFULLY INSTALLED Base Cleric Changes (required for all components)

    SUCCESSFULLY INSTALLED Install kit: Heartwarder of Sune

    SUCCESSFULLY INSTALLED Install kit: Battleguard of Tempus

    SUCCESSFULLY INSTALLED Install kit: Strifeleader of Cyric

    SUCCESSFULLY INSTALLED Install kit: Nightcloak of Shar

    SUCCESSFULLY INSTALLED Install kit: Alaghar of Clangeddin

    SUCCESSFULLY INSTALLED Install kit: Hoodwinker of Baravar

    SUCCESSFULLY INSTALLED Install kit: Fastpaw of Baervan

    SUCCESSFULLY INSTALLED Install kit: Watcher of Helm

    SUCCESSFULLY INSTALLED Install kit: Stormcaller of Talos

    SUCCESSFULLY INSTALLED Install kit: Dawnbringer of Lathander

    SUCCESSFULLY INSTALLED Install kit: Holy Justice of Tyr

    SUCCESSFULLY INSTALLED Install kit: Lorekeeper of Oghma

    SUCCESSFULLY INSTALLED Install kit: Painbearer of Ilmater

    SUCCESSFULLY INSTALLED Install kit: Dweomerkeeper of Mystra

    SUCCESSFULLY INSTALLED Install kit: Holy Champion of Torm

    SUCCESSFULLY INSTALLED Install kit: Silentwalker of Mask

    SUCCESSFULLY INSTALLED Install kit: Icevassal of Auril

    SUCCESSFULLY INSTALLED Install kit: Talon of Malar

    SUCCESSFULLY INSTALLED Install kit: Waveservant of Umberlee

    SUCCESSFULLY INSTALLED Install kit: Silverstar of Selune

    SUCCESSFULLY INSTALLED Install kit: Malagent of Talona

    SUCCESSFULLY INSTALLED Install kit: Pain of Loviatar

    SUCCESSFULLY INSTALLED Aerie, the Fastpaw of Baervan

    SUCCESSFULLY INSTALLED Anomen, the Watcher of Helm

    SUCCESSFULLY INSTALLED Viconia, the Nightcloak of Shar

    WeiDU Timings
    OUTER_INNER_PATCH_SAVE 0.000
    parsing .tra files 0.000

  • Necromanx2Necromanx2 Member Posts: 908
    edited March 2018
    It did for me. I knew it installed when I could not get the priest to appear. I checked log and saw it installed.
    I confirmed I have 1.6.5. No biggie as it was easy to uninstall the one component.

    EDIT: I uninstalled and reinstalled and you can see it adds the stronghold.




    // Log of Currently Installed WeiDU Mods
    // The top of the file is the 'oldest' mod
    // ~TP2_File~ #language_number #component_number // [Subcomponent Name -> ] Component Name [ : Version]
    ~WILLOWISP/WILLOWISP.TP2~ #0 #0 // Will NPC, shaman stronghold and new shaman kit for BG2EE
    ~WILLOWISP/WILLOWISP.TP2~ #0 #1 // Change shaman .tlk string to remove "Ineligible for any stronghold" line
    ~WILLOWISP/WILLOWISP.TP2~ #0 #2 // New items for shamans and undead NPCs
    ~WILLOWISP/WILLOWISP.TP2~ #0 #3 // Optional: Drider and Dark Treant Enemies
    ~WILLOWISP/WILLOWISP.TP2~ #0 #4 // Crossmod Banters
    ~WILLOWISP/WILLOWISP.TP2~ #0 #5 // Witchlight Shaman standalone kit for BG:EE and BG2:EE
    ~TASHIA/SETUP-TASHIA.TP2~ #0 #0 // Tashia NPC Mod -> Full version (ToB required): v1.3
    ~TASHIA/SETUP-TASHIA.TP2~ #0 #2 // Tashia Add-on Pack by Bri and Lord Ernie (English only, Tashia ToB Required) -> Action Style dialogues: v1.3
    ~TASHIA/SETUP-TASHIA.TP2~ #0 #4 // Alternate portrait for Tashia. -> Tashia's Alternate Portrait 1 - Created by Amalthea.: v1.3
    ~TYRISFLARE/SETUP-TYRISFLARE.TP2~ #0 #0 // Tyris Flare NPC: v7
    ~YASRAENA/SETUP-YASRAENA.TP2~ #0 #0 // Yasraena (BG2:SoA & TOB NPC) created by nethrin & Sillara of the Tamari: v16_charsets
    ~NINDE/NINDE.TP2~ #0 #0 // Ninde NPC Mod for BGII: v2
    ~ISRA_BG2/ISRA_BG2.TP2~ #0 #0 // Isra for BGII: v2.1
    ~SETUP-AMBER.TP2~ #0 #0 // Amber the NPC MOD for BGII:SoA: v4
    ~UNOFFICIAL ITEM PACK/SETUP-UNOFFICIAL ITEM PACK.TP2~ #1 #0 // Unofficial Item Pack
    ~UNOFFICIAL ITEM PACK/SETUP-UNOFFICIAL ITEM PACK.TP2~ #1 #1 // Scarlet Katana
    ~UNOFFICIAL ITEM PACK/SETUP-UNOFFICIAL ITEM PACK.TP2~ #1 #2 // Gourmet from Underdark
    ~UNOFFICIAL ITEM PACK/SETUP-UNOFFICIAL ITEM PACK.TP2~ #1 #3 // Holy symbols
    ~UNOFFICIAL ITEM PACK/SETUP-UNOFFICIAL ITEM PACK.TP2~ #1 #4 // New Items
    ~UNOFFICIAL ITEM PACK/SETUP-UNOFFICIAL ITEM PACK.TP2~ #1 #5 // SoD items
    ~UNOFFICIAL ITEM PACK/SETUP-UNOFFICIAL ITEM PACK.TP2~ #1 #6 // Better archery shop
    ~UNOFFICIAL ITEM PACK/SETUP-UNOFFICIAL ITEM PACK.TP2~ #1 #7 // Reworked free action
    ~SOUTHERNEDGE/SOUTHERNEDGE.TP2~ #0 #0 // Southern Edge: the new district of Athkatla -> Yes, but don't patch the existing save games: 1.10
    ~C#SB_SILBER/SETUP-C#SB_SILBER.TP2~ #0 #0 // Adalon's Blood - Modification for BGII by Gandalf the white: 14
    ~ELDRITCH_MAGIC/ELDRITCH_MAGIC.TP2~ #0 #0 // EE: Item Expansion: v1.68
    ~ELDRITCH_MAGIC/ELDRITCH_MAGIC.TP2~ #0 #1 // Congenio's Pebble Collection: v1.68
    ~ELDRITCH_MAGIC/ELDRITCH_MAGIC.TP2~ #0 #3 // XP Cap Removal -> Remove XP Cap: v1.68
    ~A7-GOLEMCONSTRUCTION/SETUP-A7-GOLEMCONSTRUCTION.TP2~ #0 #0 // Golem Construction Ability for Spellcasters: 5.3
    ~A7-GOLEMCONSTRUCTION/SETUP-A7-GOLEMCONSTRUCTION.TP2~ #0 #10 // Replace original Golem Manual: 5.3
    ~A7-GOLEMCONSTRUCTION/SETUP-A7-GOLEMCONSTRUCTION.TP2~ #0 #50 // Add "Teleport" ability to golems: 5.3
    ~BARDICWONDERS/SETUP-BARDICWONDERS.TP2~ #0 #0 // Bardic Wonders: Abettor of Mask Kit
    ~BARDICWONDERS/SETUP-BARDICWONDERS.TP2~ #0 #1 // Bardic Wonders: Dancer Kit
    ~BARDICWONDERS/SETUP-BARDICWONDERS.TP2~ #0 #2 // Bardic Wonders: Storm Drummer Kit
    ~BARDICWONDERS/SETUP-BARDICWONDERS.TP2~ #0 #3 // Bardic Wonders: Troubadour Kit
    ~BARDICWONDERS/SETUP-BARDICWONDERS.TP2~ #0 #4 // Bardic Wonders: Items
    ~PALEMASTER/SETUP-PALEMASTER.TP2~ #0 #0 // Pale Master Kit for BG:EE, BG2:EE and IWD:EE: v1.4.5
    ~SHADOWADEPT/SETUP-SHADOWADEPT.TP2~ #0 #0 // Shadow Magic: Shadow Adept mage Kit for BG:EE
    ~SHADOWADEPT/SETUP-SHADOWADEPT.TP2~ #0 #1 // Shadow Magic: Shadow Monk monk kit for BG:EE
    ~SHADOWADEPT/SETUP-SHADOWADEPT.TP2~ #0 #2 // Shadow Magic: Item Pack
    ~ALCHEMISTKIT/ALCHEMISTKIT.TP2~ #0 #0 // Alchemist Kit for Mages: 1.0
    ~ZKWSALARIN/SETUP-ZKWSALARIN.TP2~ #0 #0 // Weavescale Sorcerer Kit for BG:EE
    ~C0WARLOCK/SETUP-C0WARLOCK.TP2~ #0 #0 // Warlock Kit
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #0 // Base Cleric Changes (required for all components): 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #1 // Install kit: Heartwarder of Sune: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #2 // Install kit: Battleguard of Tempus: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #3 // Install kit: Strifeleader of Cyric: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #4 // Install kit: Nightcloak of Shar: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #5 // Install kit: Alaghar of Clangeddin: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #6 // Install kit: Hoodwinker of Baravar: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #7 // Install kit: Fastpaw of Baervan: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #8 // Install kit: Watcher of Helm: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #9 // Install kit: Stormcaller of Talos: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #10 // Install kit: Dawnbringer of Lathander: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #11 // Install kit: Holy Justice of Tyr: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #12 // Install kit: Lorekeeper of Oghma: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #13 // Install kit: Painbearer of Ilmater: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #14 // Install kit: Dweomerkeeper of Mystra: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #15 // Install kit: Holy Champion of Torm: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #16 // Install kit: Silentwalker of Mask: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #17 // Install kit: Icevassal of Auril: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #18 // Install kit: Talon of Malar: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #19 // Install kit: Waveservant of Umberlee: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #20 // Install kit: Silverstar of Selune: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #21 // Install kit: Malagent of Talona: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #22 // Install kit: Pain of Loviatar: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #23 // Aerie, the Fastpaw of Baervan: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #28 // Anomen, the Watcher of Helm: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #30 // Viconia, the Nightcloak of Shar: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #32 // Strongholds Alterings (requires the respective kit component): 1.6.5

  • RaduzielRaduziel Member Posts: 3,431
    @Necromanx2

    I'm working on a solution with a huge help from Kjeron.

    The non-spawning problem was solved, but some other things need to be fixed first. I'll let you know as soon as everything works properly.

  • Necromanx2Necromanx2 Member Posts: 908
    edited March 2018
    @Raduziel, I am starting games in BG2EE and notice some issues. The Icevassal of Auril cannot use bludgeoning or axe when creating a new charter. It was fine when I dual-classed to this kit.
    The Painbearer of Ilmator cannot use a mace. Isn't a mace considered bludgeoning?

    EDIT: I see the same think in BGEE.

    Post edited by Necromanx2 on
  • RaduzielRaduziel Member Posts: 3,431
    edited March 2018

    @Raduziel, I am starting games in BG2EE and notice some issues. The Icevassal of Auril cannot use bludgeoning or axe when creating a new charter. It was fine when I dual-classed to this kit.
    The Painbearer of Ilmator cannot use a mace. Isn't a mace considered bludgeoning?

    EDIT: I see the same think in BGEE.

    I will take a look, thanks!

  • subtledoctorsubtledoctor Member Posts: 10,016

    @Raduziel, I am starting games in BG2EE and notice some issues. The Icevassal of Auril cannot use bludgeoning or axe when creating a new charter. It was fine when I dual-classed to this kit.

    Dual-classing is broken in various ways when it comes to usability and proficiency, so don't use that as the baseline.

    Raduziel
  • RaduzielRaduziel Member Posts: 3,431
    @Necromanx2 I'll release the multiclass kits yet, that should solve it.

  • Necromanx2Necromanx2 Member Posts: 908
    edited March 2018
    To be clear, it is the single class kits I am having issue with. The plain Icevassal of Auril can't use axes or most blunt weapons (only staffs), while Ilmator cannot use blunt except for staff. So a multi-class update would be nice, but it is the single class kit that I see issues with.

    WAIT! It may be a strength issue.

    Yes, I am an idiot! Strength was the issue.

  • RaduzielRaduziel Member Posts: 3,431

    To be clear, it is the single class kits I am having issue with. The plain Icevassal of Auril can't use axes or most blunt weapons (only staffs), while Ilmator cannot use blunt except for staff. So a multi-class update would be nice, but it is the single class kit that I see issues with.

    WAIT! It may be a strength issue.

    Yes, I am an idiot! Strength was the issue.

    We've all been there, mate.

  • RaduzielRaduziel Member Posts: 3,431
    edited March 2018
    So, after a hellish week I'll be touching this again.

    I'm still working on a solid solution for the stronghold component - It is 75% percent done, the only thing missing is redirecting the clerics for the churches I want to - actually, only the Talos NPC is behaving in an unexpected way. The problem with the Unseeing Eye quest is fixed, the other strongholds are working. Just need to understand this damn little Talos detail.

    Next update will be basically a lot of MC kits, the stronghold fix and some surprises :)

    After dealing with this I'll focus on producing kits once again but as I decided to release larger packs the next updates should take a while.

    Cheers!

  • Necromanx2Necromanx2 Member Posts: 908
    Question: Baervan's 15th level ability is change staff. The spell duration at the top says 5 turns, but the spell description near the end says 1 turn per level. Which is it?

  • RaduzielRaduziel Member Posts: 3,431

    Question: Baervan's 15th level ability is change staff. The spell duration at the top says 5 turns, but the spell description near the end says 1 turn per level. Which is it?

    Neither, 10 turns.

    All kit-special summons that are 1 turn/level on PnP were altered to 10 turns for balance purpose (as they summon very strong creatures starting at high levels).

    It is fixed already and will be up with version 1.6.6

    Thanks :)

  • Necromanx2Necromanx2 Member Posts: 908
    I have 1.6.5 installed in BG2EE. Just picked up Anoman and he has the special abilities of Helm, but none of Helms spells to memorize (only cure light wounds only for 1st level, and a 2nd, and 3rd level spell and nothing more). His second class says Cleric instead of Helm (I know the class description will be only for cleric, but the class name should appear on the character sheet with the 6 stats.).

  • RaduzielRaduziel Member Posts: 3,431

    I have 1.6.5 installed in BG2EE. Just picked up Anoman and he has the special abilities of Helm, but none of Helms spells to memorize (only cure light wounds only for 1st level, and a 2nd, and 3rd level spell and nothing more). His second class says Cleric instead of Helm (I know the class description will be only for cleric, but the class name should appear on the character sheet with the 6 stats.).

    Have you reinstalled the Anomen component once you got 1.6.5?

    Because I thought I solved the spheres issue with everyone when I solved the Aerie/Quayle/Tiax/Glint issue.

    If you didn't, please do. In the meantime I'll check the code when I get home.

  • Necromanx2Necromanx2 Member Posts: 908
    edited March 2018
    I did install it.

    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #0 // Base Cleric Changes (required for all components): 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #1 // Install kit: Heartwarder of Sune: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #2 // Install kit: Battleguard of Tempus: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #3 // Install kit: Strifeleader of Cyric: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #4 // Install kit: Nightcloak of Shar: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #5 // Install kit: Alaghar of Clangeddin: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #6 // Install kit: Hoodwinker of Baravar: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #7 // Install kit: Fastpaw of Baervan: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #8 // Install kit: Watcher of Helm: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #9 // Install kit: Stormcaller of Talos: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #10 // Install kit: Dawnbringer of Lathander: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #11 // Install kit: Holy Justice of Tyr: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #12 // Install kit: Lorekeeper of Oghma: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #13 // Install kit: Painbearer of Ilmater: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #14 // Install kit: Dweomerkeeper of Mystra: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #15 // Install kit: Holy Champion of Torm: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #16 // Install kit: Silentwalker of Mask: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #17 // Install kit: Icevassal of Auril: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #18 // Install kit: Talon of Malar: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #19 // Install kit: Waveservant of Umberlee: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #20 // Install kit: Silverstar of Selune: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #21 // Install kit: Malagent of Talona: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #22 // Install kit: Pain of Loviatar: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #23 // Aerie, the Fastpaw of Baervan: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #28 // Anomen, the Watcher of Helm: 1.6.5
    ~DEITIESOFFAERUN/DEITIESOFFAERUN.TP2~ #0 #30 // Viconia, the Nightcloak of Shar: 1.6.5


    EDIT: As a note, Arie does not get Baervan spells even though the description says she is a Fastpaws of Baervan (though the class says cleric).





    Raduziel
  • RaduzielRaduziel Member Posts: 3,431
    Ok, I'll work on it.

    Thanks!

  • Necromanx2Necromanx2 Member Posts: 908
    Question: It seems that the cleric of Mystra is suppose to be immune to magic stripping spells at 15th level. However, I notice Khelben's Warding Whip is not in the list of immune spells. Is this intentional as that spell just removes wards from the target?

  • RaduzielRaduziel Member Posts: 3,431
    edited March 2018

    Question: It seems that the cleric of Mystra is suppose to be immune to magic stripping spells at 15th level. However, I notice Khelben's Warding Whip is not in the list of immune spells. Is this intentional as that spell just removes wards from the target?

    Not magic striping spells. He-She is immune specifically to Dispel Magic, Remove Magic and Spellstrike.

    @Necromanx2 , version 1.6.6 is not officially released, but it is on Github with a fix for Anomen.

    I'm working on some news before releasing it.

    And still trying to make the stronghold component behave as I intend. The damn thing is like 85% done.

    Post edited by Raduziel on
  • RaduzielRaduziel Member Posts: 3,431
    edited March 2018
    This post is now updated and contains the list of the multiclass that will be released with v 1.6.6 (it is inside the spoiler, in each deity description).

  • Necromanx2Necromanx2 Member Posts: 908
    Good luck with the work! And thank you for all your efforts!

    Raduziel
  • RaduzielRaduziel Member Posts: 3,431
    @Necromanx2 Thank you for your patience. I know that bumping this often on bugs must be frustrating. I try to solve everything ASAP, but somethings just take time (like the strongholds).

  • Necromanx2Necromanx2 Member Posts: 908
    I wasn't bumping. I wanted to say thanks! And more so since you are so responsive.

    Raduziel
  • RaduzielRaduziel Member Posts: 3,431

    I wasn't bumping. I wanted to say thanks! And more so since you are so responsive.

    By bumping I meant "often finding". I think that my English made me say other thing :)

    Anyway, I do my best to reward the patience if the players.

    Again, thanks!

  • RaduzielRaduziel Member Posts: 3,431
    edited March 2018
    Version 1.6.6 is up on Github and it contains:

    - A fix for the "Anomen won't get spells" issue

    - Consistent description for Changestaff

    - Multiclass kits! Check this post to know the details

    - A component for Sirene, turning her into a Painbearer of Ilmater (if the Fighter/Cleric version is chosed)

    - A component for Gavin, turning him into a Dawnbringer of Ilmater

    - A component for Drake, turning him into a Holy Justice of Tyr

    - A change in the Tenya component, keeping her as Chaotic Neutral

    - A boost for Oghma's Legend Lore

    The stronghold fix advanced a little but it is not completely ready. @kjeron is helping me a lot with this but some extra tests need to be done. I would say that we are in 80% with it.

    To use this version, completely uninstall any previous install of DoF, exclude the folder from your game directory and only then you add this new one. A lot of things had to be reworked in order to make the multiclass kits work properly.

    Due to the new multiclass kits, it is no longer possible to use both multiclass kits from DoF and FnP. Sorry about that.

    Don't forget that DoF must be installed before FnP!

    I want to thank @subtledoctor for helping me with some multiclass issues and @Aquadrizzt for providing the tool. Kjeron is always helping me in the backstage also has my applause. And @Necromanx2 who is being a hero and reporting every little stupid thing I do: thanks!

    I also want to thank @Artemius_I for trusting me two of his beloved NPCs. Also, @jastey for giving me full support with Gavin.

    Have a Cleric NPC and want him in the pack? Send me a PM!

    There will be a 1.6.7 version with (probably) the Stronghold component fully functional, and (maybe) another NPC!

    Post edited by Raduziel on
  • Necromanx2Necromanx2 Member Posts: 908
    @Raduziel, thanks for the update!

    I used the beta 1.6.6 (so not the latest above) and Anoman received spells. However, he could not wear any armor.

  • RaduzielRaduziel Member Posts: 3,431

    @Raduziel, thanks for the update!

    I used the beta 1.6.6 (so not the latest above) and Anoman received spells. However, he could not wear any armor.

    @Necromanx2

    Are you sure that he can't use any armor? As a Watcher of Helm, the only armor that he can use are those classified as Plate Mail and Full Plate Mail.

    So no hide, leather, studded leather, chain or splint mail.

    I did a quick test here and his armor restriction is working as intended. Can you please double-check?

    Thanks!

  • Necromanx2Necromanx2 Member Posts: 908
    edited March 2018
    This is what I see'




    EDIT: GAH!!! Just realized you say Helm can only wear plate. Ugh my vision and memory are both sucking way too much!

    Post edited by Necromanx2 on
    Raduziel
  • RaduzielRaduziel Member Posts: 3,431

    EDIT: GAH!!! Just realized you say Helm can only wear plate. Ugh my vision and memory are both sucking way too much!

    You just reminded me that I need to alter the starting gear for Anomen.

    Thanks :)

  • RaduzielRaduziel Member Posts: 3,431
    edited March 2018
    Version 1.6.7 is finally up and it contains:

    - A fix for the stronghold component (actually, it was totally redone by @kjeron and his Weidu-ninja HLA)

    - A fix for the F/C multiclass proficiencies (now they can achieve 2 slots as expected)

    - Proper starting gear for Anomen

    This mod will be on hold for a moment because I'm working on a huge update (7 kits and probably another crossmod). Stay tuned :)

    I tested the stronghold a lot, but if anything goes wrong please let me know.

    Cheers!

    Post edited by Raduziel on
  • Necromanx2Necromanx2 Member Posts: 908
    I noticed that the multi-class Gnome says he is an Illusionist, but has the bonus spell removed. I thought he gets the bonus spell and has the Illusionist benifits/drawbacks?

145791030
Sign In or Register to comment.