Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Downloader Known issues

123457

Comments

  • GravityslaveGravityslave Member Posts: 4
    I've been following this thread with interest because I'm having the same "server error". I have no trouble logging onto the Beamdog site, and I am also running WinXP sp3. I have tried everything that everyone further up the thread has tried in order to fix this, but nothing works.
    I'm feeling pretty frustrated, because I love BG and really wanted to play this - and having paid for it, I feel ripped off. If anyone does find a solution, please let me know. My desk is getting serious head-shaped dents in it now.

    CrazedSlayer
  • SchnizzelSchnizzel Member Posts: 25
    edited December 2012
    I will setup a new, clean win7 installation this weekend. My ISP and my router isn't the problem because I can install the game smoothly on my Laptop but not on my PC. When I try to install this game on my PC I get the "verification oder unable to bla bla bug". Both systems running win7 64-bit.
    It drives my crazy not to know what the problem is.
    So the easiest way to figure it out is a clean win7 installation because my laptop is "close" to a clean installation. Just 2-3 programms are installed and nothing else. My PC is heaviliy used, many things are installed and de-installed. So probably I will have success with a new installation.I'll keep you updated. Sry for my bad english.

  • ElectroburnElectroburn Member Posts: 2
    I am unable to run the game. I was able to install the game and play it. But when update 5 came out and I attempted to update it, the Checker kicks in, runs to about 10% and then the loader crashes (running on Win7). I was able to run the game by running straight from the game exe until that also stopped working. I have since tried running in compat mode for WinXP SP3, and running as Administrator, none of which worked. I have uninstalled the program and now I can't reinstall the program as the downloader also crashes. I see nothing in the BeamDogAdmin log.

  • wednesdaywednesday Member Posts: 61
    If running the game from the .exe has stopped working have you tried loading task manager and seeing if the process is still open? Im running it from the .exe and hoping it keeps working :(

  • nopnop Member Posts: 25
    edited December 2012
    @Sylvus_Moonbow, @Gravityslave, @Schnizzel, and others getting the "Verification failed due to server error." and "Unable to sign in due to a server error, please try again later." messages when logging in to the Beamdog client or trying to verify your BGEE purchase.

    I'm the main programmer behind the launcher, and I'd like to get a hand from those of you having persistent issues with our login servers. I realize it's a little odd going through the forums rather than the more official support channels. I'm hoping I can get this fixed more quickly by cutting the support guys out of the loop. (And they can get to other issues more quickly.)

    What I need from you guys are some technical details. I've got a small app ready that'll simulate the login/verification process and create a detailed log of everything that goes on (hopefully capturing the details of the error on your end of the connection). All you have to do is grab it, run it, and email me the file it generates. Volunteers, please shoot me an email me at [email protected] and I'll get you set up with the app.

    Again, this is only for those consistently getting the "Verification failed due to server error." and "Unable to sign in due to a server error, please try again later." messages.

    Cheers!

    Post edited by nop on
    CrazedSlayerGravityslave
  • ElectroburnElectroburn Member Posts: 2
    @wednesday I couldn't run the exe after a reboot. Eventually I had to get round this by downloading the beamdog client. Redownloading the game and starting this from the beamdog client. Not sure how long this solution will last for.

  • wednesdaywednesday Member Posts: 61
    I saw the beamdog client required a brand new download/install... I'm still running the game from the .exe so far, and fingers crossed it keeps working. I just wish there was a better solution so i could access the new patch. ugh.

  • nopnop Member Posts: 25
    edited December 2012
    @Gravityslave: thanks! Your help is really appreciated.
    @Sylvus_Moonbow: I emailed you back, but haven't heard from you since. No rush if you've just been busy, but if you haven't, then check your spam folder or let me know if you just haven't gotten the reply.
    Other volunteer who's forum name I do not know: you're awesome!

    Those getting "Verification failed due to server error." and "Unable to sign in due to a server error, please try again later.": at least some of you are getting this error because your root certificates are out of date or otherwise incomplete. (For those that don't know what a root certificate is, it's a core component of what makes most web security and online encryption work. It's essential to ensuring that your emails and passwords are properly encrypted when the launcher communicates with our servers.)

    Root certificates are regularly updated by Microsoft through Windows updates. These updates are typically labelled "Security Update", though they're sometimes called something else with "Security" or "Root Certificate" in the name. At least one user mentioned that a Windows Update had fixed this issue for him, and this is likely why that is.

    I'm also looking into a workaround for those that can't apply all of the updates, or for anyone that's applied all updates but, for whatever reason, continues to have this problem.

    Also note that those error messages cover a fairly broad range of possible failure modes. If applying all updates doesn't fix this error for you, then drop me a line at [email protected] and I'll set you up with the diagnostic tool. The quicker I know why the launcher won't work for you, the quicker I can get a fix in place.

    LaufBoLauf
  • SchnizzelSchnizzel Member Posts: 25
    @nop
    I emailed you too. Was very busy this weekend. Your help iy very welcome!

  • nopnop Member Posts: 25
    Another thing that can mess up SSL certificate validation is your system erroneously thinking that our certificate has expired. Check your system clocks. If the date is off by enough, that too can cause this issue.

    LaufBoLauf
  • SchnizzelSchnizzel Member Posts: 25
    Problem solved. You pushed me on the right direction :-) I had a tool installed called "xp-antispy" (also works for win7) where you can disable most of the annoying windows automatisms. I thought manually updating is enough but it wasn't. There was an option to turn on/off "automatically download windows certificates in background". This option were disabled and so I turned it on again.
    It just downloads the game right now here. Finally I can play. So everybody check your tools and certificates. Everything works fine now. :-D

    CameronToferLaufBoLaufnop
  • nopnop Member Posts: 25
    @Schnizzel: glad you remembered that setting. I wouldn't have thought of third-party software messing with certificate processing.
    @Sylvus_Moonbow: you really, really rock. Thanks for finding that.

    LaufBoLaufGravityslave
  • LaufBoLaufLaufBoLauf Member Posts: 20
    @Nop: I followed this thread here and in the German forum.

    I just can say: Thumbs up! Great support for the people with that problem!
    Keep up that good work and everyone who really LOVES Baldur's Gate will stay und support BG:EE.

    And now I have to go back to Boo.....go for the eyes :-)

  • CrazedSlayerCrazedSlayer Member Posts: 130
    Yes!! Ive finally been able to log in thanks to this solution!! Thank you so much for your help

    Gravityslave
  • GravityslaveGravityslave Member Posts: 4
    @Sylvus_Moonbow, as an addendum to your post (in case anyone in our boat is going to try that link), the app in question *appears* to do nothing, but that's because they didn't bother to make a dialogue showing anything actually happening...
    but a reboot later and I'M IN! Wooooooo!

  • wednesdaywednesday Member Posts: 61
    Any word on a fix for those of us who cant download the latest update? still getting stuck during "checking files"

  • Luke00016Luke00016 Member Posts: 7
    Still having problems with the downloader after ever single patch. I use the downloader to get the patch and the downloader freezes at 99.8-9%. I have to close it through task manager and keep re-opening the client and hoping it finishes downloading before it freezes again. It also keeps dropping to extremely low download speeds (<100 bits/second) before freezing.

  • bigdogchrisbigdogchris Member Posts: 1,336
    @Sylvus_Moonbow

    I joined this conversation very late, so excuse me if you've already heard this.

    1 - Have you tried connecting to the server at a different location than your home (i.e., School, Work, Friend)?
    2 - Have you disabled the Windows Firewall?

  • IlredeIlrede Member Posts: 2
    Hi guys, can you tell me pls, how can i disable p2p option ? My launcher crashing (solo and beamdog too), so i cant download the game. I read here, that disable p2p can help, but i cant see p2p option in properties (right click on launcher icon). Thanks.

  • IlredeIlrede Member Posts: 2
    New information. On notebook of my wife it works fine. Game is installed and i can create character. On notebook is win Vista.

    My PC has Win XP 64 bit. Error message contains:
    EventType : clr20r3
    P1 : bgee.exe
    P2 : 0.2.6.2
    P3 : 50b7f5a8
    P4 : presentationframework
    P5 : 3.0.0.0
    P6 : 4f7e714f
    P7 : 6263
    P8 : e1
    P9 : system.windows.markup.xamlparse

    I cant disable p2p, because my launcher will not start at all. After doubleclick on baldurs icon i will get immediately error message (send / dont send to Microsoft).

  • CerevantCerevant Member Posts: 2,314
    Ilrede said:

    I cant disable p2p, because my launcher will not start at all. After doubleclick on baldurs icon i will get immediately error message (send / dont send to Microsoft).

    The following works for disabling P2P for the beamdog client:
    * Run regedit
    * Go to HKEY_CURRENT_USER\Software\BeamDog\Player\1.0 and set AllowUploading to 0


  • Sese79Sese79 Member Posts: 478
    edited January 2013
    Hi,
    We could play the game on 06.01.2013, but since then the XP machine can't run or install the game. My Win7 could update and run it, but the XP not. It doesn't work neither with the BaemdogClient nor the Launcher. I could run the game from the game folder, but then i couldn't update the game. Because of this i tried to reinstall the game, but it just tries to install himself but right before the end it crashes. I checked the Information Panel for Applications on Windows, and it says the problem is with "mscorwks.dll" . This is categorized under .NET Runtime 2.0 Error. Could you please help us, we could play this game until two weeks. Thanks.

  • Sese79Sese79 Member Posts: 478
    I was able to solve this with cleaning off the old .NET versions 2.0 and 3.0 and then installing 3.5 SP1 only.

    Cerevant
  • NaastriilNaastriil Member Posts: 60
    Ever since the last patch update I can't run the game.
    I was able to run it via Baldur.exe earlier but now it freezes as well. Will there be a new patch that will solve my issues?
    Because I can't re-install the game since it crashes as well.

  • I'm two patches behind. Trying to download them is an exercise in outrageous frustration.

    The loader starts, checks the files and begins downloading at about 20 KB per second. After about five minutes it drops to one or two KB, sometimes even only a few hundred B, and them it promptly locks up.

    Only way to close it is to use the Task Manager, and after the loader will not reopen. I have to reboot the PC in order to get it responsive again... and it appears to be random whether or not it kept the data I actually managed to download so far. Usually not, hence having to try again... and for what? It probably won't work. It hasn't worked for a month.

    I suppose I'm being punished by some gaming deity for having such a huge backlog of games, eh?

  • NaastriilNaastriil Member Posts: 60
    Naastriil said:

    Ever since the last patch update I can't run the game.
    I was able to run it via Baldur.exe earlier but now it freezes as well. Will there be a new patch that will solve my issues?
    Because I can't re-install the game since it crashes as well.

    Is there anyone that can help me out?
    I would like to continue playing the game...

  • wednesdaywednesday Member Posts: 61
    Still cant download the latest update despite deleting and reloading the launcher. I can run the game from .exe but the launcher is totally broken for me, stalling on "checking files" since two patches ago. any word on how to fix?

  • CerevantCerevant Member Posts: 2,314
    If you've tried everything in this thread, you should submit a support request to [email protected]

Sign In or Register to comment.