Skip to content

How to use custom portraits (BG1, BG:EE, BG2, BG2:EE, IWD, IWD:EE, IWD2)

1356711

Comments

  • Raistlin82Raistlin82 Member Posts: 256
    Talarasha said:

    I edited the files with GIMP, made them the size indicated in this thread, saved them as "Windows bitmap" BMP (which I guess is the 24-bit version).
    ...
    HELP?

    You guess wrong. GIMP default save is 32-bit, you must manually check the 24-bit radio button (there will be a window after you click "save").
    Oooooh! Thank you! :)

  • DoctorJDoctorJ Member Posts: 2
    @Luigirules check if your bmps are 24bit, when mine was 32bit bmp, the portrait doesn't show up, just a question mark with a silhouette of human
  • DoctorJDoctorJ Member Posts: 2
    @Luigirules and check the directory
    C:\Users\user name\Documents\Baldur's Gate - Enhanced Edition\Portrais
  • LordLeviathanLordLeviathan Member Posts: 97
    In the end, I had to use paint.net to create my portraits the right size but thank you anyway Aosaw.
  • cutlasskiwicutlasskiwi Member Posts: 35
    Anyone having trouble with the game crashing when picking a custom portrait? I've tried with several different ones and as soon as I click one the game crashes.
    Edwyn
  • GaldarianGaldarian Member Posts: 13
    Did you know that if you put portraits named after NPCs, the game will use these, like ImoenS.bmp and ImoenM.bmp ?
  • Twilight_FoxTwilight_Fox Member Posts: 448
    Thanks
  • reedmilfamreedmilfam Member Posts: 2,808
    Nic_Mercy said:

    I still don't see the custom button under the default portraits and I don't know why. I created a portraits folder in the correct location and added portraits of the correct format and dimensions

    C:\Users\Administrator\Documents\Baldur's Gate - Enhanced Edition\portraits

    files:

    NICMERCY_L.bmp
    NICMERCY_M.bmp
    NICMERCY_S.bmp

    I tried with and without the underscores in the file name. I don't know what else to try.

    @Nic_Mercy Pretty sure you need to make the Portraits folder to make this button work.
  • reedmilfamreedmilfam Member Posts: 2,808
    @Nic_Mercy I mean with the CAPITAL P. Otherwise, BG:EE won't see it. Old DOS Kernel issue where cap and lowcase were seen as totally different letters.
  • mibblesmibbles Member Posts: 31
    edited November 2012
    Odd, custom portraits worked fine for me without the capital P in the folder name.
    Dee
  • DeeDee Member Posts: 10,447
    capitalization should no longer be an issue. If it's not showing up, it's something else.
  • darthmarudarthmaru Member Posts: 7
    Where can I find the override folder? Here there's only data folder and no override inside it.
  • DeeDee Member Posts: 10,447
    You'll have to create it--sorry, I should have mentioned that. Create a folder called "override", and put anything in there that you want to change the game.
  • darthmarudarthmaru Member Posts: 7
    Now its done! Thank you.
  • reedmilfamreedmilfam Member Posts: 2,808
    @Nic_Mercy Did you open them in MS PAINT and Save as (choosing 24 bit BMP), as well as double-verifying size? It has to exactly match and, I'm told, be 24 bit color bmp for BG:EE to read them as valid.

    Hope this works for you
  • Nic_MercyNic_Mercy Member Posts: 408
    edited November 2012

    @Nic_Mercy Did you open them in MS PAINT and Save as (choosing 24 bit BMP), as well as double-verifying size? It has to exactly match and, I'm told, be 24 bit color bmp for BG:EE to read them as valid.

    Hope this works for you

    My issue was resolved earlier in the thread but ty for replying. My problem was the name of my pic was too long. Apparently the name cant be more than 7 characters plus the L/M/S. Mine was too long (NICMERCY_L .bmp for example). I renamed to NICL.bmp and it worked fine after that.

  • ramenbitoramenbito Member Posts: 7
    Ok I have named the AnL AnS and they are 24 bit bmp and the folder is named Portraits, but the image does not show up in the game even though i can see custom button and click on it.
  • MortesMortes Member Posts: 45
    @ramenbito If you want, you can upload them somewhere and I'll check if I can find the issue.
    ramenbito
  • XKalXKal Member Posts: 58
    Regarding custom portraits for your NPCs, you can actually use the same portraits/ folder you use for uour main character (rather than using an override directory). As always, the filename does need to match the expected name for a given NPC (IMONEM/IMOENS for Imoen, JAHEIRAM/JAHEIRAS for Jaheira, BRANWEM/BRANWES for Branwen, etc.) I have custom portraits for all of my NPCs using this folder, and it works fine.

    I will note that the new NPCs are by default using some of the new portraits, and if your protagonist is using that same portrait, the NPC will have a different one (pulled from the standard portrait list) when you meet them, and this customization does not work. To fix this, I ended up choosing a different portrait for my protagonist, and reloading to before I met the NPC. Then, when I met them, they used their default portrait, and, when I added custom portraits with that filename, they switched to that custom portrait.
    Moira
  • MasonguitarMasonguitar Member Posts: 35
    Anybody have a link to some High Def 210 by 330 portraits that are usable? Sorry if this has been asked before.
  • Hi_Its_Me_Imoen1Hi_Its_Me_Imoen1 Member Posts: 15
    edited November 2012
    Hey, I used these instructions yesterday to give my char a custom portrait and it worked just fine, but the today when I loaded my save game my picture had been replaced with a question mark over a silhouette of a head.

    Then when I tried to go to the character sheet/menu my game crashed. It does the same thing every time I try, and my other saves (auto save etc.) have the same problem. I can go to the character menus of the rest of my party, just not my main char.

    Is this a problem with my custom portrait or some other kind of bug?

    Edit: I went to the character creator to check if the portrait was visible there and it was.

  • AvengingExileAvengingExile Member Posts: 33
    Finally got my pics to work. Apparently, MSPaint was not saving the files as 24 bit even though I specifically told it to do so. Right-clicking and checking the properties of the portraits files was telling me that the images were still in 32 bit format. Finally used GIMP and made sure the formats got saved correctly, so if anyone is using MSPaint to save, I'd try something else.
  • seloneselone Member Posts: 3
    Thanks for tis this, the dimensions are a little changed now but a very informative post, thanks.
  • DustynBDustynB Member Posts: 1
    Just an idea i Created an character on my old copy of Dragon Age 2 and uploaded it to the Bioware website. then just saved the image and it is now the portrait for my BG char.
  • R0GUER0GUE Member Posts: 27
    junk11 said:

    @R0GUE
    Imoen's BG1EE portrait should be IMOENS.BMP IMOENM.BMP IMOENL.BMP

    Ah that fixed it, I got some bad info about the naming convention for Imoen's portraits I guess. Thanks!

  • KomarrKomarr Member Posts: 80
    edited November 2012
    Since a lot of folks seem to have questions about resizing portraits in MS PAINT here is the exact procedure to follow. I'm using Windows 7, but Paint really isn't very different in other versions.

    1. Open the image you want in Paint.
    2. In the toolbar click "Image".
    3. In the drop down menu click "resize".
    4. A new window opens titled "Resize and Skew".
    5. In the Resize section make sure "Pixels" is checked, not "Percentage".
    6. Make sure "Maintain aspect ratio" is NOT checked.
    7. All the sizes listed in this thread are "Horizontal x Vertical". Enter those numbers in the appropriate boxes.
    8. Click Ok.
    9. Click "Save as" in the menu offered click BMP.
    10. A new window opens for the folder you are saving the images to.
    11. At the bottom in the line offered for "File name" type the name you want followed by the size "NAMEL" or "NAMEM" or "NAMES". The name must be 8 characters or less INCLUDING the size letter (S, M, or L).
    12. In the line below that for "Save as type" choose "24-bit bitmap (.bmp)" from the drop down menu.
    13. Done. Place in the appropriate directory.
    Moira
  • FentonFenton Member Posts: 38
    Thanks and I do have my BG:EE portrait for my Blackguard. I'm uploading it on my profile pic now.
  • MoiraMoira Member Posts: 173
    Paint in XP doesn't seem to have the nifty resizing by pixels options, so I've resized by percentage (from L to M it's 82% and from M to S it's 31%) and cropped off the 1-2 pixels needed to get to the perfect size. If there's an easier way for this, do let me know ^_^ But this works too.
  • cutlasskiwicutlasskiwi Member Posts: 35
    Can anyone think of a reason why my game crashes every time I click on a custom portrait?
Sign In or Register to comment.