Howdy, Stranger!

It looks like you're new here. Sign in or register to get started.

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[How to] Install mods on Android

17810121321

Comments

  • CavakCavak Member Posts: 25
    Thanks @Gusinda . I got everything going, SCS, Ascension, Rogue Rebalancing, all.working well.

    Oddly npc_ee, while it works, has weird text calls when advancing weapon proficiency and I was worried I might encounter other errors.

    Also with Might and Guile choosing warrior feats had a hiccup, but that was on the npc_ee install so it could have been related. Since I was playing a board I went with RR instead anyway

    JuliusBorisovGusinda
  • trinittrinit Member Posts: 688
    @Gusinda i salute you for all the help and continued dedication! :)

    JuliusBorisovGusinda
  • GusindaGusinda Member Posts: 1,808
    @Cavak, I take this is on BG1EE 2.5.16.4 Beta... If so, can I get a copy of your WeiDU.log? Also, did you add any 'throw in the override' (non-WeiDU) folder mods? I believe that it might be a script problem and if we can track it down to the file, we might be able to setup vanilla game.

    I haven't been able to put NPC_EE onto 2.5 and reading the discussion, there are a number of others as well. A suggestion was to roll back to 3.1.2 but that didn't work either.

    @trinit, thanks for your kind words.

    Thanks
    Gus

    trinit
  • CavakCavak Member Posts: 25
    Hey @Gusinda

    Na it's for BG2EE beta. I gave up on bg1ee for now

    Gusinda
  • GusindaGusinda Member Posts: 1,808
    @Cavak, no probs... Is that BG2 Beta because the 2.5.16.6 patch has been officially released. If you are still on 2.5.16.4 Beta, I would guess it is time to update :smile:.

    Gus

  • CavakCavak Member Posts: 25
    Huh my bad ya it's not the beta. Good looking out though lol.

  • GusindaGusinda Member Posts: 1,808
    edited August 2018

    Edit: Removed to not confuse anyone...

    Happy Gaming
    Gus

    Post edited by Gusinda on
  • IsayaIsaya Member, Translator (NDA) Posts: 752
    @Gusinda I wonder if patching the obb file is still needed.

    Here is my experience with BGEE 2.5.17.0 and a small set of mods, notably Finch, that you meet in Candlekeep. I did not change the obb file. My "lang.zip" contains lang/fr_FR/dialog.tlk (and dialogF.tlk) and a few files in music from BG1 NPC. All other mod files are directly in the override folder in files.

    Texts added by the mods, in particular the initial dialog with Finch, are displayed properly. Since somebody mentioned having a crash with the protection spell from Firebead with the previous version, I did that tiny quest and the game behaved properly.

    Since in BGEE french is a supported language, this shows that overriding a dialog.tlk from the obb file is working. Regarding the spells, I don't know if it's a good enough proof (I didn't have a mod with spells to test with).

    Maybe you could avoid the obb patch in BGEE and probably SoD and IWDEE.

    Gusinda
  • GusindaGusinda Member Posts: 1,808
    @Isaya, sounds like a much better plan. Much better not to play around with these things! I haven't modded the game at all yet. I was just prepping it for when the GoG release came about and do them both together (maybe)... I will likely do a Vanilla run anyway to celebrate the release. I hope that when BG2EE gets an update, it is fixed as well.

    I don't own SoD or IWD on the Android platform, so we will have to wait and see.

    Thanks
    Gus

  • MystreMystre Member Posts: 78
    Hello there!

    Anyone succeed in modding BGEE with the new version 2.5? I tried different methods.. one make the game crash when a spell is cast. The other one give me text:invalidxxxx for every new text...

    I would love to be able to play these game with mods.. :-(

  • GusindaGusinda Member Posts: 1,808
    edited August 2018
    Hi @Mystre, I setup a bunch of mods and seem to have no problem. They are mainly convience and item mods so nothing that involves additional quests or NPCs yet.

    Are you running 2.5.17.0? The game was crashing on the beta 2.5.16.4.

    Gus

    Edit: based on your other post... Have you previously modded 1.3 or is this the first? The answer below is based on having previously modded.

    There is no need to modify the patch.obb at all for BGEE 2.5.17.0. All you need to do is to install the game and run once to setup your folders. Setup your mods as on a PC as before, centralfix and copy across to your device and install.

    If this is your first time (or if the problem still occurs), let me know and I will make a procedural list of how I created mine.

    JuliusBorisov
  • MystreMystre Member Posts: 78
    edited August 2018
    Hello @Gusinda , I was previously playing BGEE on android with mods (v1.3). I've just finish it a couple of days ago. And then i wanted to continue with my character in SoD. Then i realize that i accidentaly lost my finale save (i've copy it in my computer, but dont know why, the files was empty.. and i deleted the game from my phone just before I notice it...).
    So i decided to play again the game from the beggining (see.. even with that issue i keep wanna play^^). Anyway, then i've downloaded again BGEE that turn to be automatically in v2.5 this time.. (i've already heard about issue with this version...).
    I remod the game as I've done before (it was with Isaya's help). But i've got text:invalidxxxxx on many thing (i'm playing a kit added by a mod so it beguns here...). Otherwise, the game is playing correctly.
    Then i tried the methods that needs to repatch the obb files (kinda difficult but I've made it). I didn't even install mod after this. Just try see if the game still works.. but here spells make the game crash...
    So.. i have no idea how to proceed now...

  • GusindaGusinda Member Posts: 1,808
    edited August 2018
    @Mystre, could you upload your modfile and WeiDU.log (renamed as .txt)? I can have a look at it and see if the problem is there. If not, then just your WeiDU.log so I can build it and see whether it is any of the mods. My guess without looking is that your dialog.tlk is compressed and it doesn't like that.

    Gus

    Edit: Spelling

    Post edited by Gusinda on
    JuliusBorisov
  • MystreMystre Member Posts: 78
    I'm gonna retry my installation (Isaya's method) and let you know right after :-)

  • MystreMystre Member Posts: 78
    Hello @Gusinda ,

    I've retried the installation. Same problem, the game is working but not the text (invald:text0000).
    I've done my installation with "lang" and "override" on a zipfile treated by centralfix. all other files (music, script, movie, data, engine.lua, chitin.key) were also transfert on a zipfile that I've decompressed once on my phone.

    I attached my WeiDu with this comment.

  • MystreMystre Member Posts: 78
    edited August 2018
    I really don't understand anything!!
    I tried different ways to install the mods (zipping, unzipping, some files in one zip, the other ones in another, swithching the content of the zipfiles, etc..
    At some point i had 2 zipfiles (one with lang and music. The other one with data, override, script, movie, chitin.key, engine.lua). I launch the game and it was working!! No text invalid for the choice of my kit. But it crash on spellcast... i unzipped it.. and text were missing again..
    I tried to do exactly what i've done before... still not working... i dont understand what was different the time it was working.. and cant get it work properly again... :-(
    Just succeed once to get it back.. but crash again on casting spells.. im so upset..

    Post edited by Mystre on
  • IsayaIsaya Member, Translator (NDA) Posts: 752
    edited August 2018
    @Mystre, I didn't have time to answer you earlier on the french forum, so I'm answering here so that @Gusinda knows about it.
    I managed to mod BGEE 2.5.17.0 using the "standard" method, as I mentioned in an earlier post on the 18th of August. Without text issues and without spells cranshing the game.
    You just need two zips. The first one, that you'll have to zip without compression and process it with centralfix, that includes the modified dialog.tlk and dialogF.tlk in lang/fr_FR. If a mod added any music, you also need to add a music directory including *only* the added files (check the files date to identify them).
    The second zip will contain the override folder. Possibly a script folder, if you have a mod that added scripts in there, but only include modified or new scripts (check the files date again). In most cases, that's all. This one can be compressed as you'll have to unarchive it in Android/xxx/files folder. After unarchiving it, remove the second zip from Android/xxx/files folder in order not to interfere (or move it elsewhere).
    You should never include data, movie, chitin.key, engine.lua, in any zip file, they are already in the obb files.
    There could be an exception for movies, if you installed a mod that changes them. Then apply the same rule as for scripts or music, only include modified or added files.
    If you zip with compression the zip file including the dialog.tlk files, it will fail to read texts, resulting in "invalid:xxxx". Possibly centralfix will complain already.
    If you unzip in Android/xxx/files the content of the zip file containing the dialog.tlk files, it will fail as well.
    Only keep one zip in Android/xxx/files, the one processed with centralfix.
    If you want, I could upload my two zip files for you to test.

    GusindaJuliusBorisov
  • MystreMystre Member Posts: 78
    I'm gonna try that as soon as i get back home (in 2hours on average). I'll try that and keep you uploaded whether it's working or not. Thanks again for the helps!! :-)

  • MystreMystre Member Posts: 78
    edited August 2018
    @Isaya @Gusinda
    So i've tried what you said Isaya, and I think I'm gonna have to marry you!!! 2nd time you help me!! It is working perfectly (well except the new interface.. but here, there's nothing we can do^^ it was prettier on the previous version^^). Anyway, so i was able to choose a DUKP kit, to cast a spell. I went to Thalantyr, his mod is on. I went to beregost, i saw a new merchand and was able to recruit a PNC from dark horizon mod. I also was able to hear to music of BGNPC when Imoen is talking with me... well so far.. seems to work perfectly!!! I'll keep you in touch if anything goes wrong.

    For the record, the mods I used are (installed in this order) :
    -Dark horizons BGEE
    -Baldur's Gate Quest Expanded
    -the Stone of Akanvar
    -thalantyr upgrade
    -bg1 npc
    -bg1 npc music
    -BG unfinished business
    -DUKP (kits)
    -cdtweaks.

    On the zip file (working with centralfix), I've got the lang file (with the 2 dialog.tlk) and the music file (with 45 files created today (so probably with mods) and 1 thing called "blank.mus" also created today..).

    On the other zip file that i'll unzipped on my phone, i've got the override file (with everything inside. Haven't touched anything) and the scripts file (with only 2 things inside also created today : "0ikmorph.bs" and "pxProfil.bs").

    Now I hope, everything will continue to run well. I still have a question.. when BGEE will be over, will I be able to mods SoD and BG2EE on the same way? (Except that SoD will have to be played in English.. and BG2EE, i will take your dialog in french that you posted somewhere else Isaya, even if the new content will be in english^^)

    GusindaJuliusBorisov
  • GusindaGusinda Member Posts: 1,808
    @Mystre, For BG2EE 2.5.16.6, you will need to repackage the patch.obb to remove the dialog.tlk & dialogf.tlk so that they don't conflict; as previously discussed in this thread a couple of pages back.

    I can't talk about SoD as I don't have it for Android. I have a mate that does, and I modded his previous version. My guess is that I will be modding the new version when he is ready (I think he is doing a full vanilla run first). When that happens, I will have a better idea.

    However, based on BGEE and IWDEE (both tested), I don't think they will be a requirement to repack.

    For your current BGEE install, be aware there may be a problem with BG1NPC and 2.5. So if something happens, then it could be that it isn't yet compatible. Also, BG1 Unfinished Business should be at version 16.0 (I noticed in your WeiDU.log that it is likely to be v14.0) for BGEE 2.5. And just one more... CDTweaks is now at version 5.0 with a couple of tweaks for 2.5. Hopefully that doesn't spoil your install.

    Enjoy the game
    Gus

    JuliusBorisov
  • MystreMystre Member Posts: 78
    @Gusinda,
    Thanks for the infos. Then I'll see.. hipefully everything will go.... keep you in touch if anything goes wrong :-)

    JuliusBorisovGusinda
  • IsayaIsaya Member, Translator (NDA) Posts: 752
    @Mystre Nice to see you became a happy player! I think the issues with older versions of BG1 UB and BG1 NPC regarding new dialogs added in V2.5 are minor and will only impact minor dialogs.

    I believe what @Gusinda recommends for BG2EE is not necessary if you intend to play the game in french, ie with the translation mod. Since french language is not included in BG2EE, there is no conflict regarding lang/fr_FR/dialog.tlk in the obb file.
    I reported here the test I made after the 2.5 patch for BG2EE was released. I can confirm that the texts added by Skipping Chateau Irenicus were displayed properly and that casting a spell didn't crash the game.

    JuliusBorisovGusinda
  • vyvexthornevyvexthorne Member Posts: 58
    edited August 2018
    So the dialog.tlk problem seems to be with the android version of that specific file itself. I grabbed the override folder and dialog.tlk from the pc version of the game and everything appears to work fine on android. The only mod I was trying to install was cd tweaks v5. At any rate, that works...so if you have the pc version just follow the initial instructions but use your pc files instead of modding the android version.


    Edit: doesn't work on Siege of Dragonspear though. Can't get that to work with mods at all. All other games work fine.


    Post edited by vyvexthorne on
  • IsayaIsaya Member, Translator (NDA) Posts: 752
    @vyvexthorne No. There is no issue with the dialog.tlk file available in the Android version. There is no need for a PC version to mod any Android game.

    From my experience and the feedback from @Gusinda, the "simple" method (i.e. without modifying the obb file) described in the first message still works with BGEE and IWDEE V2.5.17.0.
    For BG2EE, the method involving removing dialog.tlk from the obb file described by @Gusinda is usually required. The only exception is when you play in a language that is not present in the official version of the game, such as french (incomplete translation added through a mod), because the conflit for reading the dialog.tlk in an modded zip file / reading version in the obb file does not trigger in such case.

    In principle SoD runs on the same engine as BGEE and IWDEE, there is a great chance that adding content in the game throough a zip file works as for those games. Since SoD on Android does not include all parts of BGEE, there is a chance that installing mods fails though. Please clarify what is not working when you are tryning to mod SoD. Thank you.

    Gusinda
  • vyvexthornevyvexthorne Member Posts: 58
    edited September 2018
    Thanks for the reply.

    The only mod I was trying to get working was cdtweaks anthology and I play in English. The only thing that failed is that I would get "Invalid" errors when using anything that modded text. So if I installed something like the rebalanced weapon proficiencies .. the proficiencies that were moved around would just say "invalid" followed by a string of numbers.

    Before the 2.5.17 patch the simple method on the front page worked fine on my samsung galaxy tab s2. After the patch, for whatever reason it did not. Simply grabbing the files from the pc version did work. I don't know why that worked and the other method did not as I'm not in any way proficient in modding. I just gave it a shot and it worked out. Repackaging the .obb file seems a bit too over my head so I probably won't try that.

    Gusinda
  • GusindaGusinda Member Posts: 1,808
    @vyvexthorne, now that the versions are the same, there is no problem in using the PC version to create the modfile (I do that myself with no problems).

    I have used all three methods of installing mods; Isaya's method; removing the dialog.tlk from patch.obb and building a modding area using the android version; as well as using the PC version to install mods and creating the modfile from them. All three have worked.

    Beamdog must have done a good job... I would continue to use the PC, that way your saved games are compatible.

    Gus

  • BollywoodHeroBollywoodHero Member Posts: 89
    edited September 2018
    For bgee, I've installed rogue rebalancing, tweaks, spell revisions, kit revisions, item revisions, scs, and npc_ee. I'm having some issues:

    Scenario 1: leave patch.obb alone, copy over centralfixed lang.zip and override folder. String are all messed up but spells work fine.

    Scenario 2: remove dialog.tlk from patch.obb and repack, adjusting for size and centralfix. Copy over centralfixed lang.zip and override folder. Now strings look fine but spells crash the game.

    Scenario 3: replace dialog.tlk in patch.obb with modded one and adjust size by replacing unused language file with dummy file. Central fix new patch archive. Copy over override folder. Behaviour is same as scenario 2.

    Post edited by BollywoodHero on
  • IsayaIsaya Member, Translator (NDA) Posts: 752
    @BollywoodHero, do you have the latest version (2.5.17.0)?
    Can you give a more detailed description of the text issue instead of "all messed up"?
    Thank you.

  • CavakCavak Member Posts: 25
    Is Bg2ee having issues with any mods? I noticed it hasn't been updated and is still 2.5.16

  • BollywoodHeroBollywoodHero Member Posts: 89
    edited September 2018
    @Isaya, yes I'm running 2.5.17.0. When the original dialog.tlk is left in the patch archive, the "invalid...." String references are all over the place (the spell books in particular because of spell revisions).

    @Gusinda, override folder has 6636 files in it. Could that be a problem? I think I read somewhere else in this thread that there is a ~4000 file limit. Anyway, I've tried putting the override and lang in the same centralfixed zip without success. Crashes when casting spells. Tomorrow I'll try with less mods to reduce the size of the override folder - perhaps I'll remove scs (though it pains me to do so).

    Has anyone had success with bgee and a modded dialog.tlk?

    Update1: removing scs left the override folder with 4063 files and did not fix the crash-when-casting problem.

    Post edited by BollywoodHero on
Sign In or Register to comment.