Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[How to] Install mods on Android

1456810

Comments

  • trinittrinit Member Posts: 667
    edited July 3
    @Gusinda followed the steps exactly but not working unfortunately... i will try a complete reinstall, maybe there is some conflict i'm unaware of. the only thing that bothers me is that it really worked flawless previously and i changed none of the permissions on the phone or anything like it. because this might be the issue i think, something specific on my end:(

    edit- damn, tried copying backup files from version 2.3 that was working but now the game wont start without updating -.- so even that is lost :/

    Post edited by trinit on
  • trinittrinit Member Posts: 667
    edited July 3
    okay, reinstalling did nothing. i did notice one thing- game recognizes and plays music form lang.zip file, but only if dlg folder structure is preserved. if i move dlg file directly into lang.zip along with the music folder the music is not played.

    so far no results with lang.zip, either with or without folder structure, with or without music. this is so infuriating. and yes, i checked it it the correct dlg file. it just makes no sense :/

    Post edited by trinit on
  • GusindaGusinda Member Posts: 733
    @trinit, what mods are you trying to install and what language?

    Gus

  • CavakCavak Member Posts: 23
    So, I am having the oddest bug.

    The mod I am trying to install is Faiths and Powers.

    I am installing first by putting dialog.tlk in its file structure, in a non-compressed archive and only centralfixing it, and then leaving the override folder un-centralfixed and unzipped next to the lua.

    Now, when I do this I get a ton of invalids for the names of the kits, spells, etc. BUT everything works the way it should. For example, if I choose the Woodscout of Meilikki, the kit has all its abilities, spells, the sphere system works, and he even has Sunscorch which is a custom IWD spell added by Grammarsalad and Subtledoctor (i just know where the kit is to select it for this test). The spell icon is even correct, but all text added shows invalid strings. So like, the kit name is invalid 1356, and I just know which option = woodscout from memory.

    If I follow the OP instructions all the way and also put override into Mods.zip and centralfix it alongside, then all text shows up, but when casting sunscorch or anything else custom, the game crashes. I experienced this once before and fixed it by having the override sit outside the Mods.zip and it worked like a charm ( no invalid strings).

    So...ya thats all I got.

  • trinittrinit Member Posts: 667
    will wisp
    quest pack (only revised hells trials)
    assassinations
    refinements
    edwin romance
    dorn romance
    iwd2 gui for bg2ee
    high resolution portraits

    everything english language. i should mention, on my PC i tried copying baldur.exe to modified android folder to run it. it was glitchy but i could verify that dlg was functioning well (mod text was visible and working)and mods were installed properly.

    when i copy override and lang.zip to android, override gets recognized and all the mods function, game fails to recognize dlg file and display any text (i get "invalid:randomnumber" all over the place when mods activate)

    and thank you @Gusinda for taking time to talk to me. even complaining to someone helps :)

  • CavakCavak Member Posts: 23
    It sounds like Trinit and I have the same problem. Is the invalids from the dlg file?

    Does that mean centralfix is not working quite perfect? I forgot to mention I'm working on BGEE not 2. I thought that the centralfix bug was fixed tho.

    Is everyone else modding BGEE without a prob?

  • trinittrinit Member Posts: 667
    edited July 4
    @Cavak i downloaded centalfix from the OP. at this point i would be relieved if centralfix turns out to be the problem

    - btw, game plays music form mods if i put it into lang.zip. guess that means it recognizes zip as valid (thus properly centralfiexd i guess)

    EDIT- i can confirm putting everything into mods.zip still doesn't show text as it should

    Post edited by trinit on
  • CavakCavak Member Posts: 23
    Huh, see if i put everything into mods.zip and centralfix the whole thing then I get all the text correct, but certain calls will crash the game.

    For example, any spell from IWDification that does damage.

    Override outside and everything PLAYS correctly, it just throws invalids on any custom text.

    I've tried a bunch of different combos, like:
    -centralifixing lang and not override, but putting them both into a non-compressed archive to see if having them together in the file structure helped
    -centralfixing lang and then unpacking it in the phones file directory
    -centralfixing everything and then moving override to sit next to lang in the file structure.

    Something is getting in the way, and if it's not centralfix then it must be related to how the game is accessing the file structure...

    Basically I've been getting weird, and honestly like 99% of the time this random tinkering pays off. Not this time tho and I want my GD baldurs gate on my new note 8!

    Next steps will be diving into the code which means I'm really gonna go off the deep end. centralfix is pretty simple, but I can't imagine the changes they've made to the game and it's probably beyond me

    /Rant

  • trinittrinit Member Posts: 667
    edited July 4
    @Cavak I've tried so many different combos of folder structure and different elements i lost count already :D but unfortunately i didn't get dialog working even once. if i did at least i would have some hope i guess. right now i simply have no idea what could be done differently within standard procedures.

    please let me know if anything you do produces some result :) and good luck!

  • GusindaGusinda Member Posts: 733
    @trinit, @Cavak. Some good news and some bad news...

    First the bad news (always finish on a high):

    Yes, there appears to be a problem when using centralfix on the lang.zip. I was able to reproduce both of your problems and can get the INVALID strings.
    @Cavak - Although I don't have the beta version of BGEE on PC, I installed FnP onto BG2EE 16.6 (a number of times..). The Sphere System doesn't appear to be compatible with 2.5. I was able to install all the kits though and this worked as expected (although I didn't test all kits), just created and was able to see all that were available without errors.

    @trinit, I was able to install all the mods that you were trying on the PC version of BG2EE (just to make sure that they were compat).

    Second the good (and painful) news. I was able to get them installed onto the Android platform using the @junyangche method... Both installs seemed to work fine, had no string errors and played movies/sounds etc.

    To summarise the method (if you have any questions, please ask):
    - Install your mods as you normally would.
    - Create a new folder in which you place the only contents of your patch .obb (keeping the folder structure)
    - Copy and replace the dialog.tlk from the modding folder to your new folder
    - find another dialog.tlk to delete (for BGEE, I deleted from the cs_CZ\ folder and for BG2EE, I deleted from the ko_KR folder. I selected these only because they were by themselves and didn't have any other folders included)
    - Using a command prompt and sitting in the folder that you deleted the dialog.tlk from (you could probably use any, but because I was there, that is where I created the empty file), create an empty file using the following command:

    fsutil file createnew 000.000 0

    - Zip up the new folder (with the contents of the patch .obb) using the 'STORE' method (ie: Not compressed)
    - Find the file size (in bytes) of the newly created patch.zip (look at the properties of the file) eg: (2,067,975,314 bytes)
    - Find the file size (in bytes) of the original patch .obb (2,072,661,623 bytes)
    - Determine the size of a file (in bytes) to create to bring it to the original size. eg: (4,686,309 bytes). This is done by subtracting the modded patch.zip from the original patch .obb
    - Go back to the empty file that you created and delete it. Create a new file that is the required size by using the following command in a command prompt:

    fsutil file createnew 000.000 4686309

    - The numbers above were for BGEE and are only an example. Please use the figures that you find.
    - Delete the newly created patch.zip file and create a new one using the 'STORE' method. Check to make sure that the file size is exactly the same size as the original patch.obb
    - Centralfix the patch.zip
    - Rename patch.zip to be the same name as the patch .obb (including the extension)
    - Copy to your device
    - Copy you override folder to your device Files Folder (you can do this in a zipped form and unpack on your device - preferred method and very much time saving).
    Lets Play!

    All of that above is written with the thoughts that you understand what is going on and have done it or some of it before such as the modding, and that you know where the files should be placed on your device etc... I get the feeling that you have. If I am wrong, let me know and ask Qs about the part that is grey and murky in your mind. You can find the discussion @junyangche has done a couple of pages back from this one for more info as well.


    @JuliusBorisov, can you report to the developers that centralfix is still not working properly (on the BGEE 2.516.4 Beta and BG2EE 2.5.16.6 release). I have had it running with various mods (Tweaks Anthology, aTweaks, BG1NPC etc), but it seems that when a new kit is added, INVALID strings appear when centralfix is applied to the modfile which contains dialog.tlk. It probably means that '[Android] Mod archives created with centralfix don't work properly (partial content only) (35976) ' is still open as a job. I understand that centralfix is not supported and is created privately, but if there something that can happen in the 2.5 releases to allow it to work properly... Thanks

    Hope that helps
    Gus

    JuliusBorisovtrinit
  • trinittrinit Member Posts: 667
    edited July 5
    @Gusinda i followed each step precisely, and the game refuses to even start now. i checked and the file size seems to be the correct size up to a byte.

    i did manage to make it work with this method few days ago but i also switched some music files then and as a result none of the music or movies played in game. this time i only switched dlg file, as you instructed, but nothing happened


    well, the most important thing is that you managed to locate the bug, if nothing else. hopefully the fix will come soon-ish? also, i tried installing only with mods that add no kits (made fresh install with no refinements and will'o'wisp, but no luck with lang.zip)

    thank you very much for all of your work and trying to help, i really appreciate it. i hope @Cavak has better luck

  • GusindaGusinda Member Posts: 733
    edited July 5
    @trinit, that's a shame... I had the game crash first up, but then I thought about it and I had forgotten to centralfix the patch zip before renaming it to .obb and copying it to the device.

    I have a modfile that works which has the following: Unfinished Business, Wandcase, Thrown Hammers, Enchant the Missile Launchers, Useful Plot Items for BG2EE, More Style for Mages, Tweaks Anthology, aTweaks, EEUITweaks, & Show Hidden Gameplay Options.

    I thought that it was related to New Kits as that was the only problem I had. I will have a play here and see what happens without the kit adds...

    Gus

    Edit: Give this a try. It contains Assassinations, Quest Pack (Hell Trails), Edwin, & Dorn Romance. You should be able to place the IWD GUI staight into the override (but try it before hand). Starts up okay on my Note 4 with no crashes or INVALID strings. May be different once you get to Dorn/Edwin or any of the Assassination requirements. Would be good to know.

    To Install:
    Download to device
    Unpack into Files folder keeping structure. There should be the lang.zip and override folder. You know the story.

    Just out of interest, what device are you installing on, and for the obb names, are they main.576 and patch.570? Thinking out aloud if the device CPU/Graphics makes any difference (Snapdragon/Adreno for Note 4)

    Good Luck
    Gus

    Post edited by Gusinda on
    trinit
  • trinittrinit Member Posts: 667
    edited July 5
    @Gusinda transferred the file directly into data/files and unzipped them there. i added nothing else into override. when i got to edwin i again got the invalid response errors. text is simply refusing to show itself.

    it's samsung galaxy j pro 2017- gpu is Mali-T830 MP1
    it must be something in this update. the 2.3 version, and even beta 2.5 worked perfectly for me :/

    @JuliusBorisov are you maybe aware of this bug, or know what's causing it?

    Gusinda
  • GusindaGusinda Member Posts: 733
    edited July 5
    @trinit, thanks. Well it is more than just new kits then...

    Gus

    Edit: Upon further testing, I have also found INVALID strings in the modfile that I am using :( I just wasn't using the kit that was modded.

    Post edited by Gusinda on
  • CavakCavak Member Posts: 23
    Well, I will just do a run with some scs and npc_ee (pick npc kits and they start at lvl1 with xp) and skip custom kits for now I guess

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 15,457
    https://support.baldursgate.com/issues/34985 was closed.

    Please create a new bug report with some easy repro steps for the issue. We did some fixes for it but perhaps it didn't fix everything.

  • GusindaGusinda Member Posts: 733
    edited July 7
    @JuliusBorisov, shall do. Thanks.

    Gus

    Edit: @Cavak, Tried installing NPC_EE onto BG2EE 2.5 and was getting errors for selecting the kits in game. Having a read of the thread, it seems that the errors are also in 2.5 beta. You may want to have a look or maybe pick your kits prior to installing. I didn't change any of the kits on installation, as I was looking to open the options up in the game.

  • CavakCavak Member Posts: 23
    Ya, I did find that and just reverted everything. Might just do a vanilla throne of bhaal difficulty run to try it out, and wait.

    I considered emulating windows on my note 8, but then decided that nuts even for me.

    Gusinda
  • GusindaGusinda Member Posts: 733
    @JuliusBorisov, @trinit, @Cavak

    Report submitted.

    Hope it get's fixed soonish.

    Gus

    JuliusBorisov
  • CavakCavak Member Posts: 23
    Nice stuff Gus. Thanks for reporting on all of our behalf and so thorough.

    And thanks everyone involved in making this Android modding possible. I know how much time I sink just touching the edges of these mod setups. Really appreciate all efforts

    Gusinda
  • trinittrinit Member Posts: 667
    @Gusinda thank you! :) and i echo the @Cavak's sentiment! hopefully the fix will be out soon

    Gusinda
  • Mantis37Mantis37 Member Posts: 720
    Level 1 NPCs worked on the 2.5 beta though, you could try Crevsdaak's fixed version of that.

    Gusinda
  • CavakCavak Member Posts: 23
    Thanks for that, that will make the gameplay a bit more fun. I'll explore with new duals maybe heh.

  • IsayaIsaya Member, Translator (NDA) Posts: 671
    @Gusinda, @JuliusBorisov
    On my side, I'm not facing any issue with texts coming from mods with Android version 2.5.16.16. However I'm using a very small amount of mods (2) and one probably doesn't add texts to dialog.tlk (the point was to check also how the game behaved regarding dialog.tlk and L_xx_xx.lua files).

    My setup:
    • Sony Xperia Z tablet with Android 5, BG2EE V2.5.16.16: since there is not enough space left, I had to uninstall the 2.5.16.14 beta and reinstall everything. The Play store was announcing it was downloading from the beta channel.
    • PC setup for obtaining the mod files: Android obb files transfered to PC and extracted in a directory, all mods (translation plus the two other mods) have been installed in that directory.
    I installed the partial french translated (which is a weidu mod too), then two mods: Skipping Chateau Irenicus and Hidden options (both latest versions).
    The centralfixed zip file contains both the lang/fr_FR directory (dialog.tlk, dialogF.tlk, data and sounds as well) and the override directory.
    In game, the french translation notes (added to dialog.tlk) are present and the dialog from the thief in Skipping Chateau Irenicus is properly displayed (from dialog.tlk) and the additional options also appear (from L_fr_FR.lua in override).
    For this test scenario, there is no regression from beta 2.5.16.14 (although I didn't test with additional mods back then).

    Possibly a big difference with your attempts is that the lang/fr_FR doesn't exist in the base game so that the game doesn't have to choose between original and modded dialog.tlk files.

    As a side note, the zip file that I built with only the partial french translation in order to check beta 2.5.16.14 back in may is also working with Android 2.5.16.16: texts, including the translation notes added in french beyond the range of en_US dialog.tlk texts). At that time, the translation mod had been installed on the PC version of beta 2.5.16.14 and tested with Android successfully with beta 2.5.16.14. So it doesn't look like installing the mods on a PC version of the game or on an Android package copied over to a PC has any effect.

  • trinittrinit Member Posts: 667
    @Gusinda i've went through the procedure with patch.obb again. i removed english dlg file completely and created new 000 file in spanish folder. this time the game started and the game recognized modified dlg file in lang.zip properly. however, i had the same problem as when i followed junyangche's instructions last week- i have no music, movies or character selection sounds (however, game played voice files that were in override folder)

    i have no idea if this is problem with my phone or procedure (i use winrar to create zip files with store option). it almost seems like the game starts because patch.obb is present and the correct size but then proceeds to ignore ALL the resources in it.

    in any case, i'm very happy to hear we managed to locate the problem, or at least come closer to the solution.

    Gusinda
  • GusindaGusinda Member Posts: 733
    edited July 8
    @trinit, damn, your right! I rarely play with sound on when using android (I mostly keep my volume off). Back to the drawing board for a little while longer. That's for both BGEE and BG2EE... [shakes head and reaches for a blanket size hanky]

    Gus

    Edit: OK, I am officially red faced... Tried quite a number of things then as I was going through my baldur.lua, I found the following...
    SetPrivateProfileString('Program Options','Volume Voices','0')
    SetPrivateProfileString('Program Options','Volume SFX','0')

    Couldn't believe it so popped into the game options, sound and there they were, set to 0. Lifted them a bit higher and now I hear voices in my ears... [Folds blanket back up and places beside computer]

    That was for both BG1 & 2 as I use the same prepped (with all the changes I like) baldur.lua.

    I am sure it isn't the same problem, so lets get back to fixing it. Could you tell me what size your lang.zip is?

    Post edited by Gusinda on
  • trinittrinit Member Posts: 667
    @Gusinda my lang.zip is 24.34 mb. It contains dlg folder and music folder from mods.

    Also, checked my baldur.lua to make sure sound levels are above 0 and everything was in order. Soinds should be heard but are not. However, i do hear environmental sounds and mouse clicks and sound effects. But no music or voice. Also, for some reason everytime i load a savegame, i now get a pop-up screen with the information about the help button.

  • GusindaGusinda Member Posts: 733
    edited July 9
    @trinit, any chance you could upload your lang.zip? I still have the configuration from the above mods list, which sounds now work fine. I will try your lang.zip on my Note... Which mod added the music?

    Thanks
    Gus
    Edit: forgot to ask... and you WeiDI.log.

    Post edited by Gusinda on
  • CavakCavak Member Posts: 23
    edited July 9
    So, the method of changing the dialog.tlk in patch with a blank file of matching size IS working?
    Even if it's just sounds, that's fine for me! I don't custom in any sounds

    Edited for apparently posting mid thought

    Post edited by Cavak on
Sign In or Register to comment.