Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Drizzt Saga v3 released, now BGEE compatible!

prophet1prophet1 Member Posts: 172
Drizzt Saga is a quest mod that brings Drizzt and his companions into the game as joinable characters with their own major quest and side quests, numerous new areas, items (some to be forged) and creatures. It was originally released for BG1:TotSC, later updated to be compatible with BGT/Tutu, and now as of v3 also works with Baldur's Gate Enhanced Edition.

All credit for the story and content goes to the original author: Flysoup The full list of changes from previous versions is in the readme.

Listed below is an explanation of the mod's components:

1. The Drizzt Saga (Main component)

This is the core component and must be installed for the mod to work. You will be prompted to install one of two possible versions, which differ in how many of the new areas are added to the game's worldmap (this changes how player will be able to reach them):

a) Default version: areas connected by travel triggers
    This subcomponent works the same as the original BG1 version of the mod: only 4 new areas are added to worldmap, and most areas are connected with travel regions, meaning that travelling between them happens automatically when the player clicks at the appropriate edge of the map. Choose this if you're not planning to install the BP-BGT Worldmap mod later, or if you are not sure what option to pick.
b) BP-BGT Worldmap version: all areas added to worldmap
    This subcomponent makes use of the larger worldmap offered by the BP-BGT Worldmap mod by adding all 8 possible areas to game worldmap. Method of travel between some of the added areas is changed from travel regions to the usual method of manually picking the destination area on worldmap. Choose this only if you're planning to install the BP-BGT Worldmap mod later.
2. Optional component: Raise the XP cap

Installing this component will lift the default XP limit present in vanilla BGEE and Tutu games, setting it at 3750000 experience points for all classes. Drizzt and all his companions are high level characters, and without this component their actual level will not match their current experience shown on the character record screen - the game will "truncate" their experience to the highest value allowed by the current XP cap. This will not affect their in-game performance (level-dependant stats like THAC0, attacks per round, etc. all depend on the actual level of the character, not current experience), but will just look weird when opening their record sheets.

This component is only available for BGEE and Tutu, and is automatically skipped for BGT.

3. Optional component: Delayed Start - Drizzt joins after Durlag's Tower

This optional component aims to improve compatibility (see below) and balance - by delaying the mod's start until the protagonist character has enough experience to be more effective against the high-level enemies and threats introduced by Drizzt Saga. Instead of joining the party right in the middle of the initial encounter with the gnolls, Drizzt will now meet the party after completing Durlag's Tower and can be later recruited in Ulgoth's Beard inn.

This component resolves potential compatibility issues with several mods (see the compatibility notes section in readme for more details) by leaving the original Drizzt vs gnolls encounter completely untouched.

Please note that since the Worldmap mod has not yet been updated to work with EE, BGEE users must choose the "Default" version of the core component when installing.



  • Princess_SarahPrincess_Sarah Member Posts: 39
    edited March 2014
    hello there. first up - this mod looks great and I would love to play it :) - thank you so much for taking the time to make it.

    unfortunately I am having a technical hiccup and not being very tech savvy myself I wondered if anyone out there can identify a solution for me.

    I am running a version of BGEE (version 1.2.0) I downloaded from the App Store on OS X version 10.8.5. not being very good at this modding stuff myself I have been using this little gizmo (made by @subtledoctor‌) to install mods and it has worked with most things:

    every time I attempt to install the mod this is what I see in the terminal:

    Last login: Sun Mar 16 21:53:01 on ttys000
    You have new mail.
    Sarah-Callows-MacBook-Pro:~ sarahcallow$ cd '/Applications/Baldur'\''s Gate - Enhanced'
    Sarah-Callows-MacBook-Pro:Resources sarahcallow$ ./setup-drizztsaga
    [./setup-drizztsaga] WeiDU version 23107
    This is a non-stable version. Unless you're sure about what you're doing, consider downgrading.
    [./setup-drizztsaga] Using scripting style "BG2"
    In state 679, I expected one of these tokens:
    [0] EOF
    [3] <<<<<<<<
    [22] RANDOM_SEED
    [23] ADD_KIT
    [29] WITH
    [38] LOG
    [43] SILENT
    [44] KEEP_CRLF
    [46] BEGIN
    [48] ADD_MUSIC
    [50] BIFF
    [60] PRINT
    [72] ACTION_IF
    [76] APPEND
    [88] OUTER_FOR
    [91] FAIL
    [110] REINCLUDE
    [113] MOVE
    [117] ADD_AREA_TYPE
    [137] MKDIR
    [139] OUTER_SET
    [140] WARN
    [141] STRING_SET
    [143] COPY_RANDOM
    [152] UNINSTALL
    [159] VERBOSE
    [167] IF_SIZE_IS
    [168] UNLESS
    [173] ACTION_MATCH
    [174] REQUIRE_FILE
    [181] CLEAR_CODES
    [188] EXTEND_TOP
    [190] CLEAR_MEMORY
    [196] IF_EVAL
    [201] COPY
    [207] IF
    [209] COPY_LARGE
    [217] END
    [220] COPY_KIT
    [223] ADD_SECTYPE
    [240] ALTER_TLK
    [249] FORBID_FILE
    [250] CLEAR_IDS_MAP
    [253] ALTER_TLK_LIST
    [262] OUTER_PATCH
    [266] AT_EXIT
    [275] APPEND_COL
    [284] ADD_SPELL
    [288] GET_FILE_ARRAY
    [292] AT_NOW
    [294] LOAD_TRA
    [306] ACTION_TRY
    [311] INCLUDE
    [326] OUTER_SPRINT
    [348] COMPILE
    [359] ADD_SCHOOL
    [364] APPEND_OUTER
    [370] DELETE
    [382] OUTER_WHILE
    Parse error (state 679) at ~~

    [DRIZZTSAGA/DRIZZTSAGA.TP2] PARSE ERROR at line 306 column 1-11
    Near Text: ADD_JOURNAL
    GLR parse error

    [DRIZZTSAGA/DRIZZTSAGA.TP2] ERROR at line 306 column 1-11
    Near Text: ADD_JOURNAL
    ERROR: parsing [DRIZZTSAGA/DRIZZTSAGA.TP2]: Parsing.Parse_error
    ERROR: problem parsing TP file [DRIZZTSAGA/DRIZZTSAGA.TP2]: Parsing.Parse_error

    FATAL ERROR: Parsing.Parse_error

    Press ENTER to exit.

    It auto runs through all of this until it hits whatever the problem is so I have not entered any choices along the way in this.

    If anyone has a clue how to get around the problem I would really appreciate it.

  • prophet1prophet1 Member Posts: 172
    The problem is the wrong version of WeiDU executable you (or Easy Mod Installer in your case) are trying to install the mod with. Drizzt Saga is designed to install with WeiDU version v236 or later, while you're installing with v231:

    [./setup-drizztsaga] WeiDU version 23107

    It's therefore choking on ADD_JOURNAL command, which was introduced in version 232.

    I don't know where Easy Mod Installer gets the WeiDU executable it uses to install mods later on, so I'm not sure how you end up with that early version or what you may do to ensure it uses the latest version.

    Manual solution would be to follow the instructions in the readme to get the latest WeiDU version:
    - download the latest version of Mac OS X WeiDU
    - extract the WeiDU binary from the archive (it's in the 'bin' subfolder), and rename it into "setup-drizztsaga"
    - move this renamed setup-drizztsaga file into the main BGEE data folder next to the setup-drizztsaga.command file (replacing the existing 'setup-drizztsaga' which is already there)

    Then run the .command file to install.

  • Princess_SarahPrincess_Sarah Member Posts: 39
    @prophet1‌ thank you so much for the help! unfortunately I'm in need of a little more :(

    I downloaded the WeiDU version you linked me to and it worked great - I managed to get the install rolling which was more than was happening before. Unfortunately I seem to now be getting stuck on the maps part of the install. this is what I am seeing in the terminal:

    Biffing area data...
    [data/DZTS-ARE.bif] will contain 156 resources totalling 1476375 bytes
    Stopping installation because of error.

    ERROR Installing [Default version: areas connected by travel triggers], rolling back to previous state
    Will uninstall 699 files for [DRIZZTSAGA/DRIZZTSAGA.TP2] component 0.
    Uninstalled 699 files for [DRIZZTSAGA/DRIZZTSAGA.TP2] component 0.
    ERROR: Sys_error("data/DZTS-ARE.bif: Permission denied")
    PLEASE email the file SETUP-DRIZZTSAGA.DEBUG to flysoup,
    Using Language [English]

    whatever "biffing area data" is - it seems to be having some trouble with it. (sorry I am not very technologically minded!) I am not sure what the problem really is or therefore how to fix it :( - but if anyone can figure this out and give me some help it would be much appreciated!

  • prophet1prophet1 Member Posts: 172
    edited March 2014
    This time it is a permissions error:

    ERROR: Sys_error("data/DZTS-ARE.bif: Permission denied")

    This message means either your OS X user account or WeiDU don't have necessary read/write priveleges to access that file.

    - you might need to login with administrative rights to install mods in OSX
    - you might have to change permissions for files in the Resources game folder as described in this guide to installing mods on OS X under "SPECIAL NOTE FOR MAC APP STORE PURCHASERS"

  • Princess_SarahPrincess_Sarah Member Posts: 39
    @prophet1‌ thanks very much that solved it and it has now successfully installed :) it caught me out as I thought I had changed all the permissions before for other mods but obviously missed the data folder. really looking forward to playing this through - thanks again for making this :)

  • Princess_SarahPrincess_Sarah Member Posts: 39
    hello again. sorry to be a pain - I am now having a pretty major issue with the mod and it is beyond me to figure out the problem. It has installed fine but now the game crashes on launch. I have attached a script of the problem report my mac displays after failed launch but it is really beyond my technical ability to decipher what the problem is out of this.

    I am certain this is a problem with the mod itself and not being caused by a clash as when this initially occurred yesterday I completely obliterated BG:EE from my system and any other mods I had installed. This morning I re-downloaded BG:EE from the app store and only installed this mod and the problem still occurred in exactly the same way - installs fine but game now crashes on launch.

    the only other things I have as custom content are custom portraits I have created myself and one portrait pack for NPCs. I am on Mac OS X version 10.8.5.

    I had a look at the support forums for the mod and could not see this a know issue (unless I missed something) so I don't know if this is a mac-wide issue for the mod, but I thought you would like to know about this in case it is and needs some tweaking.

    Obviously I am about to uninstall it all again but if you do have any suggestions on fixes I would be willing to try them out and see if it works.

    It's a real shame - the mod looks great and I would love to play it.

    thanks for all the help.

  • Princess_SarahPrincess_Sarah Member Posts: 39
    sorry I attached a DOCX rather than a PDF - here is that in case you're not running word.

  • prophet1prophet1 Member Posts: 172
    So on Mac OS X the game launches fine without DS, but after installing the mod it immediately crahes upon launch?

    Unfortunately the crash report has little meaningful information to go on.
    Exception Type: EXC_CRASH (SIGBUS)
    Exception Codes: 0x0000000000000000, 0x0000000000000000
    Quick google search shows this to be just a generic app crash notification, with no indication as to what might have caused it.

    This thread reports a similar crash in BG2EE caused by one of user's "character files":
    but Drizzt Saga doesn't add any CHR files, so I'm at a loss why installing DS would cause this.

    I'm afraid I can't help debug this problem without having access to a Mac myself, sorry. Tagging @AstroBryGuy in hope he may be able to give some hints on why this crash could be happening on OS X, since I have little experience with it...

  • AstroBryGuyAstroBryGuy Member Posts: 3,415

    I'm not sure from the crash report. I might be that there is a file the mod writes that OSX is reading as mal-formed. For example, if I write a bad .2DA file, BGEE will crash on loading. However, it in that case, you can see in the crash report that it was related to 2DA processing. The error message here is pretty generic.

    I'll give installing the mod myself a shot, and see how it goes.

  • AstroBryGuyAstroBryGuy Member Posts: 3,415
    Well, I started with a fresh install, and it worked fine. At least, everything installed and BGEE started up. Of course, I'm installing on OS X 10.9.2 and I have the Beamdog install. So, it's possible that makes a difference.

    @Princess_Sarah‌ - You wouldn't happen to have a copy of the file SETUP-DRIZZTSAGA.DEBUG?

  • StaglordStaglord Member Posts: 27
    I have finish what i assume is the content for DS but now i seem to stuck in the new areas and all the priginal areas have the "destination unreachable" mark on them, how do you return to the riginall story?

  • Princess_SarahPrincess_Sarah Member Posts: 39
    @prophet1‌ and @AstroBryGuy‌ thanks for looking into it. I'm afraid I don't have that file on my mac - I had to have a pretty extensive purge after the crashing to get BGEE working again. The version I am running is a mac App Store download which I have had other mod problems with and which I have seen other users reporting even more mod issues with so perhaps it is simply a problem on this version. I am about to uninstall and reinstall everything I have again after updating the game version from the App Store so will give drizzt saga another go and let you know how I get on.

  • Princess_SarahPrincess_Sarah Member Posts: 39
    Ok … so … I fully updated the game to v.1.3.2049 (which is the latest version, according to the app store anyway) and tried a clean install of DS to see what would happen. I got exactly the same as before, prior to DS install game runs fine, DS installs fine, but, afterwards, BG EE will crash on load, giving me the same error report as before.

    I do now, however, have a file called SETUP-DRIZZTSAGA.DEBUG sitting in my resources folder and have managed to get a copy of it (thanks to text edit) into pdf format so I can show it to you @AstroBryGuy‌ in the hopes that you can make more of it than I can. it should be attached to this post.

    The only things I can think of are; my version of OS X (10.8.5) is causing the trouble; the fact that its an App Store download is responsible; or that I skipped the raise level cap step (which I don't think it is, as, from memory, previously I tried installing this too and still got crashing).

    If anyone can figure out what the trouble is, you will be my absolute hero and I will be very grateful.

  • AstroBryGuyAstroBryGuy Member Posts: 3,415
    @Princess_Sarah‌, @prophet1‌ - I think the problem is that the version of tisunpack for OSX that is distributed with Drizzt Saga is for PowerPC CPUs, not Intel CPUs. I noticed that the mod is not installing the tis files properly for the new areas that the Drizzt Saga installs (note that the source is "null.file").
    Unpacking area tilesets...
    Copying 1 file ...
    Copied [.../fl#inlined/null.file] to [DRIZZTSAGA/tiz/F_0111.tis]
    Moving DRIZZTSAGA/tiz/F_0111.tis to override/F_0111.tis
    Copying 1 file ...
    Copied [.../fl#inlined/null.file] to [DRIZZTSAGA/tiz/F_0112.tis]
    Moving DRIZZTSAGA/tiz/F_0112.tis to override/F_0112.tis
    Copying 1 file ...
    You'll need to replace the version of tisunpack in the mod with a modern version.

    tispack and tisunpack are distributed with WeiDU. Download the WeiDU package if you don't have it, or discarded the other files after copying out the weidu program.

    tisunpack is located in the WeiDU-Mac/bin/x86-64 folder. Copy the file tisunpack to the Drizzt Saga mod, replacing the old version of tisunpack found in the drizztsaga/tiz/osx folder.

    tisunpack requires that libjpeg be installed on your system. If it isn't, you can download an installer here:

    After you replace tisunpack and installed libjpeg, you should be able to install the Drizzt Saga mod.

  • ZakharonZakharon Member Posts: 72
    Ok Drizzt is in my what

  • switswit Member, Translator (NDA) Posts: 494
    edited September 2014
    @prophet1 please consider updating your code:

    COPY ~DRIZZTSAGA/Anim/MNO2~ ~override~ //FROST GIANT
    COPY_EXISTING ~ORC06.cre~ ~override~
    ~HLOLAF.cre~ ~override~
    ~CHAK.cre~ ~override~
    ~AR18FIG.cre~ ~override~
    WRITE_LONG 0x28 0xE700 //IC_OROG1 instead of IC_OROG2

    BG:EE doesn't have limit for new animations, so it is no longer necessary to replace existing animations. This is not only reducing the amount of available unique animations, but also creates compatibility problems with mods that use this vanilla animation slot for their creatures.

    Also I suggest changing this part:
    COPY ~DRIZZTSAGA/Anim/MTAN~ ~override~ //Merilith
    your animation is orange, and the original one is green. There is no need to replace the original one. Just add it to a new slot.

    If you don't know how to use BG:EE new animation slots functionality just copy the code and files from this mod:

    Thanks in advance.

    edit: you can use this code to add Frost Giant into the game following Extended Animations standard, without overwriting exisiting animations:
    APPEND ~EXTANIM.2DA~ ~57935 0 1 1 0 0 0 47 0 0 NONE NONE NONE 8 5 MGFR NONE 0 0 NONE~ UNLESS ~57935 0 1 1 0 0 0 47 0 0 NONE NONE NONE 8 5 MGFR NONE 0 0 NONE~
    APPEND ~EXTSPEED.2DA~ ~57935 8~ UNLESS ~57935~

    And rename your MNO2 files to MGFR, or better yet just use sounds, wav and 2da files from Extended Animations. I've uploaded all files for frost giant here:

    Post edited by swit on
  • MercilecMercilec Member Posts: 55
    edited February 2017
    what if i have pregenerated full party. will i still be able to have access to the new areas, items etc?
    nvm stupid questions by a newbie to BG games.

    Post edited by Mercilec on
  • MordekaieMordekaie Member Posts: 67

    I am planning to manually mod BG:EE2.3.67.3/SoD/Big World Fixpack (no BWS this time…) and i am thinking about including this mod to my mod list.

    Would you recommend this mod ?

    Would it be compatible with BG:EE V2.0+ ?

    What would be the issues or bugs ?

  • VanhardiskVanhardisk Member Posts: 34
    edited July 2018
    Mordekaie said:


    I am planning to manually mod BG:EE2.3.67.3/SoD/Big World Fixpack (no BWS this time…) and i am thinking about including this mod to my mod list.

    Would you recommend this mod ?

    Would it be compatible with BG:EE V2.0+ ?

    What would be the issues or bugs ?

    I'm currently playing DS... if I could summarize the mod in one image it would be:

    Too much fighting, very little/simple dialogue, feels like testosterone infused bloodbath of endless waves of enemies with little sense... and not precisely in a good way (I'm all for mindless powergaming slaughter from time to time to relieve tension, but this feel too detached from the franchise's narrative).
    It's not bad it just feels like playing Icewind Dale but with poor writing.

    I recommend it only so you can take it out of your chest and say "I was in a party with Drizzt and we kicked ass and it felt awesome!". If you're looking for a cool story and good narrative, look elsewhere.

  • nesciociceronesciocicero Member Posts: 11
    edited July 2020
    I'm playing the drizzt saga and it doesn't show me the new areas (the icewind dale'areas).
    After talking to Ellminster, he sends me to a small area where I find a dying person updating my map.
    If I look at the world map, I am still in Ulgoth Beard and I can't go to lands of Icewind ale.
    Are there any codes to go there? How can I solve it?

    Probably the problem is due to my mistake: in the installation options, I gave the second choice, but I had previously installed the world map. If I reinstall the world map, could I solve it or would I just create problems?

    Post edited by nesciocicero on
  • NiziNiziNiziNizi Member Posts: 70
    Did you simply try to exit area at place where dying person is? Or you did just turn on map (which show you are still in UB)?

    Which installer you used for your game?

Sign In or Register to comment.