Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Disobediant A.I.

Hello everyone.

I tried searching for a solution to this issue but if a fix is out there I wasn't able to find it. I am having trouble with A.I. and commands. When I tell a character to do something he immediately does something else. I went to customize and changed the script to passive but that doesn't work.


  • TressetTresset Member, Moderator Posts: 7,951
    Have you tried turning off the AI by pressing the lantern button directly above the select all button?

  • iso12000iso12000 Member Posts: 9
    I haven't tried that yet. Would it turn off and/or reset dialogue?

  • TressetTresset Member, Moderator Posts: 7,951
    edited June 2014
    No, it shouldn't do anything like that. It just turns off the party's AI scripts.

  • iso12000iso12000 Member Posts: 9
    I just tried it and it worked. Thank you very much for helping me with this problem.

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    @iso12000, could you state which AI script it was you were having trouble with? Turning off the party AI is only a temporary solution. To fix the problem, someone needs to know which script is causing the problem.

    Also, are you using any mods?

  • iso12000iso12000 Member Posts: 9
    edited June 2014
    I'm not using any mods. I tried multiple types of scripts but they were all the same. They started with their default script.

  • Gate70Gate70 Member, Developer Posts: 3,738
    Have you got an example of what you wanted to do and what the character did.

    (I don't use scripts, found in the originals that I would choose to attack casters but the party members would switch to nearest attacker and give enemy casters free rein, so thought it worth asking what issues you are seeing)

  • iso12000iso12000 Member Posts: 9
    That's basically it. I tell a character to attack an enemy and he either melee's the guy closest to him, or if the party member is hit by an enemy he would go attack that opponent.

  • CrevsDaakCrevsDaak Member Posts: 7,152
    iso12000 said:

    That's basically it. I tell a character to attack an enemy and he either melee's the guy closest to him, or if the party member is hit by an enemy he would go attack that opponent.

    Common and expected behavior (even if it's as bad as it is), I wouldn't say it's a bug, but a very good feature request.

  • dunbardunbar Member Posts: 1,560
    edited June 2014
    I've found that the effectiveness of AI depends on how you use it. I normally play with it off but a while back I switched it on by accident and this happened:

    Somewhere in Durlag's I'd set my party up to blitzkrieg a new room (PC and Shar-Teel up front with Safana and Viconia loitering behind to throw sticks and stones - all hasted), so when I entered the room (with AI inadvertently on) all hell broke loose and one fleeing enemy caused the whole slaughterhouse to spill over into the next room leaving the party knee deep in blood, very little of which was their own.

    So I now use AI as a yardstick, re-playing significant encounters with the AI on to see if it affects the outcome and varying my tactics accordingly (sort of using the AI against itself).

  • Gate70Gate70 Member, Developer Posts: 3,738
    OK, I did a quick search on the net and top result came back to this site. Have a look as at least 2 people have created alternate scripts that may help.

  • PibaroPibaro Member, Translator (NDA) Posts: 2,989
    I use the standard attack script, but if I want to cast a spell I have to turn ai off.
    To be more precise:
    A round starts:
    If i cast a spell before doing anything else it's ok, i will cast the spell.
    If i drink a potion (1/10 of a round) and i want to cast a spell I have to wait for the round to end, or the character will stop casting (he will not really start casting) and he will attack someone.
    The same thing happens if i want to cast two spells in a row (or a spell and a potion) I have to wait for the round to end or my command will be lost.

  • dunbardunbar Member Posts: 1,560
    edited June 2014
    I've now got a similar problem in my first playthrough of BGEE (I know this is a 2 thread but it's the topic that's relevant):
    Everything was fine when I had a party of 5, then I added Neera and party movement went pear-shaped. Specifically, when moving in single file with the whole party selected Neera (in position 6) will randomly either do what she's told, move very slowly, not move at all or move in the opposite direction. When ordering the whole party to attack, Neera refuses to do so until I click on her specifically. Also there is a roughly 50/50 chance that no.5 will move up and push into number 2's position.
    I've tried shuffling the party order around and Neera behaves herself when she's at the front but I really, really don't want Neera tanking for me, and problems continue further down the line with 4 and 5 trying to get into the same position.
    BTW I'm playing a vanilla version which I got from Steam a few days ago.
    The constant micro-management is exhausting so any help would be greatly appreciated.

  • Gate70Gate70 Member, Developer Posts: 3,738
    Moving in the opposite direction usually happens to me if the party are following each other and one person is blocked by another. They then seem to work out an alternate route, e.g. 3 sides round the docks district and into sight of everybody I don't want them to encounter.

    Has Neera got any items that cause her to walk quicker than other party members such as boots of speed.

  • dunbardunbar Member Posts: 1,560
    That sort of makes of makes sense as when my scout goes ahead and then calls for the rest to catch up they do tend to appear from slightly different directions. Neera's only equipped with are her staff and belt.

  • DeathOfNamesDeathOfNames Member Posts: 39
    edited August 2014
    @CrevsDaak‌ This definitely is a bug, and it's the same for BG:EE.

    Like @Pibaro‌ said. It's worst when trying to cast a spell. Even if you have the most basic (Default) A.I. script on a character, it will still interfere with spell-casting.

    Basically, the mage will attack nearby enemies even if you've told him to cast a specific spell. This did not happen in vanilla. The casting will work, if he can begin casting immediately, but if he has to wait for the next round/cool-down/whatever, then the script will override user commands in accordance to the selected script. The script should never interrupt a user command and in the vanilla game it didn't.

    I've previously discussed it in this thread: I did not create a bug report as I assumed the issue would be obvious... If it wasn't in BG:EE it certainly is in BG2:EE as there is more "casting" going on.

Sign In or Register to comment.