Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Planescape on Older PC: Exit Code 3221225477

DRMDRM Member Posts: 9
I know little about PCs and haven't played a game on PC in years. Picked up Planescape for my phone, liked it so much I bought it on PC, but when I click "Play," it gives me the exit code listed above. No idea why. Am I doomed? Out 20 bucks?

Comments

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 21,636
    Thank you for reporting! We'll try to look into it and help.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 21,636
    edited April 2017
    Please, make sure they have the latest drivers for your video card, not just the windows default.

    Nvidia
    AMD
    Intel

    If that doesn't help you, we'll need a crash dump from you (just attach the dump to your comment). Thank you.

    DRM
  • DRMDRM Member Posts: 9
    I updated the video card (Intel) as best I could (I'm no expert at that), but I still get the same exit code; hence, I've attached the dump. Thanks, for trying at least.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 21,636
    Our developers have checked into the crash dump. The game crashed while attempting to initialize OpenGL which usually means that you are using the default windows drivers, and not the updated drivers from Intel. 

    You'll need to install updated graphics drivers for your video card in order to get OpenGL support.

    DRMGate70
  • DRMDRM Member Posts: 9
    Ah, well, thanks for the info. Turns out my PC was old enough to have a graphics driver that's no longer supported by Intel, and the PC's an all-in-one too, which means I can't upgrade its graphics card. & so I am out of luck. At least I still have the game on my phone ...

    Gate70
  • elminsterelminster Member, Developer Posts: 16,215
    Whats your PC/intel graphics card? The game needs OpenGL 2.0

    DRM
  • DRMDRM Member Posts: 9
    Don't laugh: it's an Intel G45/G35 Express Chipset (WDDM 1.1). ... Well, okay. Laugh!

  • elminsterelminster Member, Developer Posts: 16,215
    Ehh I've got a computer with a chipset that can only support OpenGL 1.4. So that's nothing :)

    Go into my documents/planescape torment enhanced edition/ and open the baldur.lua file (with like wordpad or some other text editor).

    If your baldur.lua file has it change this line from a 0 to a 1

    SetPrivateProfileString('Graphics','Backend','0')


    If it doesn't then add the following line to the file


    SetPrivateProfileString('Graphics','Backend','1')

    DRMGate70JuliusBorisov
  • DRMDRM Member Posts: 9
    Wow, elminster. The fix didn't exactly work--but I was shocked to receive such a positive, helpful response. Thanks!

    Here's what happened: the only .LUA I could find was called "engine.lua" (not "baldur.lua"). I added the line of text you so helpfully wrote to "engine.lua" & tried to launch the game ...

    Now it tells me "Could not compile Direct X shaders" and "exit code: 1"; so, while the problem isn't fixed, progress has been made! Hope, however feeble, is being rekindled ...

    Gate70JuliusBorisov
  • IllydthIllydth Member, Developer Posts: 1,641
    edited April 2017
    @DRM

    Ok, couple things here.

    1) The LUA file you're looking for is in your "My Documents" directory, not in the PST:EE Game directory.

    If you have the line in the engine.lua file, go ahead and take it out.

    2) This has happened in the past, the game's not getting far enough to create a baldur.lua file or a directory structure for you. I'm assuming you're using windows so I'm going to guide you through a few things that may hopefully help.

    Start by opening your file browser on your OS (not sure which Windows OS you're using so I'm going to be generic).

    You'll want to navigate to your "my Documents" directory, which should be available as a "hot link" on the left side of the file browser, if not you're probably looking for "C:\Users\[ loginname ]\My Documents"

    You'll want to right-click in the right hand pane and find the ability to create a new folder, name it "Planescape Torment - Enhanced Edition" (to be clear, this should be at C:\Users\[ loginname ]\My Documents\Planescape Torment - Enhanced Edition" on your PC)

    Once you have this directory created, you'll need a default baldur.lua file (since the game is unable to create one for you).

    I've attached one to this post with the Graphics engine already turned to DirectX (as noted above, Graphics 1 instead of 0)

    Unzip this so it's named "Baludr.lua" (unzip it, don't just rename it) and move it into that Planescape Torment directory you just created in My Documents

    You should now have:

    C:\Users\[ loginname ]\My Documents\Planescape Torment - Enhanced Edition
    C:\Users\[ loginname ]\My Documents\Planescape Torment - Enhanced Edition\Baldur.lua

    Try starting the game again and let us know what happens.

    DRMGate70JuliusBorisovHadar
  • DRMDRM Member Posts: 9
    Once again, wow! What awesome help! Thanks! ... However, here's what happened:

    I removed the line of code from "engine.lua".

    I already had a "PT - EE" folder in My Documents, but it was empty.

    I downloaded your zip of Baldur.lua (thanks!) and copied it into the empty folder.

    I hopefully launched the game ... & got the same "Could not compile Directx shaders - exit code: 1" info.

    ... I know you're not out to steal my $; I blame myself for thinking an updated game would run on my older PC. But again, thanks for the help.

    Gate70
  • DRMDRM Member Posts: 9
    * When I say I "copied" the 'lua' into the folder, I mean I extracted it or whatever. I didn't just copy the zip.

  • IllydthIllydth Member, Developer Posts: 1,641
    Ok, back to the drawing board.

    Is your Operating System up to date? i.e. latest patches? If you're getting a directx error there's every possibility that too needs an update. If you're on Win7 or before OS Updates are not mandatory/auto-installed sometimes.

    Can you make sure your OS is fully up to date?

    Once that's done, please run "dxdiag" from your windows "run" line. Click that "Save information" and give us a post of the info (compress it if you can).

    DRMGate70JuliusBorisov
  • DRMDRM Member Posts: 9
    I'm using Windows 10 (or whatever). I ran an update and everything's current. Attached is the DxDiag, as requested. ... You are magnificently patient & helpful, Illydth. Even if things don't work out here, I'm enjoying the game immensely on my (tiny) phone.

    Gate70
  • Gate70Gate70 Member, Developer Posts: 3,770
    Hi
    That info helps, the card+chipset showing as G45/G43 and Intel 4 series. There is further information on the thread below but as you surmised earlier, official drivers for the card stopped after Windows 7 and Windows 8/10 will default to generic drivers.

    Without reverting/dual booting to Windows 7/Vista/XP, or possibly Linux you are unlikely to run the game on the machine. (I am assuming that installing the Windows 7 drivers on later releases is not feasible/likely to work)

    http://forums.beamdog.com/discussion/43274/windows-10-and-the-mobile-intel-r-4-series-express-chipset-family-causing-lag

    JuliusBorisov
  • mlnevesemlnevese Member, Moderator Posts: 10,154
    Some Windows 7 drivers work on Windows 10 if they are signed. If they aren't you'd need at least windows 10 Pro and knowledge of the Policy Editor to turn off signature enforcing. It may also require unpacking of the driver and direct access to the.inf file as the installer may try to check for Windows version.

    In other words, it may work but may be quite complicated.

  • DRMDRM Member Posts: 9
    Well, thanks for all the help, folks. We gave it the old post-college try, at least. & I learned a lot, too. ... Time to put on my magnifying glasses & boot-up the game on my phone ...

  • HadarHadar Member Posts: 168
    @Illydth

    I have Intel Arrandale in my laptop and Intel doesn't support this CPU+GPU since 2013. Because I have Windows 10 I'm forced to use Windows 10 drivers. Every 3D game works like trash on these drivers.

    Every time I launched PSTEE it crashed, then I downloaded your Baldur.lua file and now it works, but in options it says that I have AMD graphics card.

Sign In or Register to comment.