Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Sword Coast Stratagems (SCS) threads

24

Comments

  • subtledoctorsubtledoctor Member Posts: 9,856
    If that works, then it means a completely different component if SCS is what corrupts them. In which case maybe you could also just skip that other component.

    @JuliusBorisov you didn't post a weidu.log... did you install any of the early "spell tweak" components of SCS? Any mods before SCS, such as Spell Revisions or Tome & Blood?

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 16,768
    No, only SCS. I did install everything, step by step as the installation told me.

    https://www.dropbox.com/s/8u0hyfjw47bbqok/WeiDU.log?dl=0

    [Initialise AI components] and all subsequent components installed after the break and thanks to new files.

  • subtledoctorsubtledoctor Member Posts: 9,856
    My money would be on "Anti-magic Attacks Penetrate Improved Invisibility" being the culprit. It's probably worth trying an install without that component.

  • Luke93Luke93 Member, Mobile Tester Posts: 1,008
    edited April 2018

    My money would be on "Anti-magic Attacks Penetrate Improved Invisibility" being the culprit. It's probably worth trying an install without that component.

    No. You get that error in any case (even if you install just the first mandatory component "Initialise mod (all other components require this)"....)

    JuliusBorisov
  • AerakarAerakar Member Posts: 638
    For what its worth, I was having this same problem with 2.3 also. I eventually did a clean install and it worked.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 16,768
    Aerakar said:

    For what its worth, I was having this same problem with 2.3 also. I eventually did a clean install and it worked.

    If something happened with 2.3, it was not the same problem. The spells in the list a bit changed by the 2.5.15.1 patch, which might have led to this situation (this is why a macro within SCS needs to be updated). "A clean install" doesn't help with 2.5.15.1 (I tried 5 times), but the workaround helps.

    Aerakar
  • GalactygonGalactygon Member, Developer Posts: 370
    The reason those spells were changed is due to the hardcoded nature of the exhaust spell deflection/turning/trap spells. Once those spells are exhaused any remaining effects in the parent spell need to be removed (i.e. if a splstate is set). Otherwise, those extra effects will still remain when the spell becomes inactive.

    JuliusBorisovAerakar
  • kjeronkjeron Member Posts: 1,467
    In other words, opcodes 200, 201, 223, 226, 227, 228, and 259 now apply "(Resource).SPL" when they terminate.

    JuliusBorisov
  • GalactygonGalactygon Member, Developer Posts: 370
    Yes. Usually only one instance per header is enough if you've got more than one decrement opcode in the same header (i.e. for different spell levels).

    JuliusBorisov
  • Luke93Luke93 Member, Mobile Tester Posts: 1,008
    edited May 2018


    [./override/SPWI618.SPL] loaded, 8394 bytes
    ERROR: illegal 2-byte read from offset 3145914 of 8394-byte file SPWI618.SPL

    Failure Failure("SPWI618.SPL: read out of bounds") in check_standard_function: inputs were func=opcode, arguments=
    [stratagems_external/workspace/sfo_warnings.txt] loaded, 941 bytes
    Appending to files ...
    [stratagems_external/workspace/sfo_warnings.txt] loaded, 941 bytes
    Appended text to [stratagems_external/workspace/sfo_warnings.txt]
    ERROR: [SPWI618.SPL] -> [override/SPWI618.SPL] Patching Failed (COPY) (Failure("SPWI618.SPL: read out of bounds"))

    @argent77 Is WeiDU 245 supposed to fix this error? I tried to install SCS using WeiDU 245 and I still got this error.... Moreover, the installation process takes more time than expected on macOS (if compared to WeiDU 243 for example.....) (also tagging @subtledoctor )

  • subtledoctorsubtledoctor Member Posts: 9,856
    Luke93 said:

    Is WeiDU 245 supposed to fix this error?

    No, the Detectable Spells library in SCS needs to be updated.

  • Luke93Luke93 Member, Mobile Tester Posts: 1,008

    Luke93 said:

    Is WeiDU 245 supposed to fix this error?

    No, the Detectable Spells library in SCS needs to be updated.
    I see, thanks for the clarification.

    What can you tell me about the installation time? Did you notice it takes longer?

  • argent77argent77 Member Posts: 2,645
    Luke93 said:

    @argent77 Is WeiDU 245 supposed to fix this error? I tried to install SCS using WeiDU 245 and I still got this error.... Moreover, the installation process takes more time than expected on macOS (if compared to WeiDU 243 for example.....)

    Yes, performance is still an issue with the macOS binary (less so with the Windows binary). I'm currently doing some tests with the build configuration. Maybe there is something I can enable to improve performance.

  • subtledoctorsubtledoctor Member Posts: 9,856
    Is that with the 64-bit binary? Could that slow things down? FWIW I've never gotten an out-of-memory error on MacOS... if that's the main motivation for using a 64-bit binary, it might be better to stick with a 32-bit version.

    Although, is Apple forbidding 32-bit applications in the next MacOS update? (I'm a bit out of touch with that stuff, I only just upgraded from 10.8 to 10.12)

  • argent77argent77 Member Posts: 2,645
    The "out of memory" issue seems to be triggered only on really big megamod installations. I was able to trigger it with a full BWS "Tactics" test installation, which took over 48 hours to install. Apart from this special case there is no real need for a 64-bit WeiDU binary (yet). However, Apple has hinted that they will phase out 32-bit support eventually.

    Another, more WeiDU-specific, issue is the uncertain future of 32-bit binaries for macOS. I'm currently providing these binaries. Unfortunately they can only be built on an ancient 10.7 macOS virtual machine with an equally ancient OCaml compiler version. It is unlikely that I can continue providing these binaries when the WeiDU codebase will be modernized to keep up with more recent OCaml compiler releases.

  • LucidbroLucidbro Member Posts: 2
    bob_veng said:

    consider incorporating scs into vanilla as a difficulty level or game mode unto itself. scs is universally popular and it's a superior way to enhance difficulty to all other existing methods.

    call it "enhanced ai" "tactical ai" or something like that

    I 2nd this.
    I used the entirety of yesterday to try to get SCS to work and ended up just wasting a huge amount of time and never getting it to work.
    The game really needs some way to add difficulty other than the basic easy - insane slider.

    bob_veng
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 16,768
  • StefanOStefanO Member Posts: 315
  • legotaksinlegotaksin Member Posts: 59

    @Lucidbro At which point from https://forums.beamdog.com/discussion/comment/971562/#Comment_971562 did the install stop working for you?

    If we get 2.5 patches next week, can we install SCS without your method(exporting some spell files)?

    Can you predict this?

  • SavagostroSavagostro Member Posts: 17
    edited June 2018
    Same question here ,after yesterday's 2.5patch, release unable to install scs properly and spell revisions 4b10. Any news about
    upcoming fixes for scs and spell revisions?

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 16,768
  • SionIVSionIV Member Posts: 2,686
    ERROR: illegal 2-byte read from offset 3145914 of 8394-byte file SPWI618.SPL
    ERROR: [SPWI618.SPL] -> [override/SPWI618.SPL] Patching Failed (COPY) (Failure("SPWI618.SPL: read out of bounds"))
    ERROR: Failure("SPWI618.SPL: read out of bounds")
    Initialise AI components (required for all tactical and AI components) (Sword Coast Stratagems) was not installed due to errors.

    Using Big World Setup.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 16,768
    @SionIV Just use the workaround at the top of the page.

    SionIV
  • SionIVSionIV Member Posts: 2,686
    edited June 2018

    @SionIV Just use the workaround at the top of the page.

    2) run the install of SCS till you get the error

    3) exit installation and put the copies of those files you exported into /override


    Is the error you're talking about here, the same one I linked above? As in that's the moment I copy the clean install files into the override?

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 16,768
    Yes. SPWI618.SPL is mentioned in that post, along with other .SPL files in question.

  • DeeKayNLDeeKayNL Member Posts: 50
    Hello,

    I had the same problem. This solution worked partially for me.
    When i copied the files to the override folder en exit the installation en run again. I get the same problem.

    Only thing i did different was to leave the installation windows open. Then copy the files to the override folder. Then from the installation windows choose install again. After that it worked like a charm.

    With Regards DeeKayNL

  • tedmann12tedmann12 Member Posts: 6
    I posted this in a different section but figured this may be a more appropriate spot:

    I recently installed scs and rogue rebalancing mod after the 2.5 update. I got the game running, but I am having weird sound issues now. The game seemed noticeably quieter for me at first, NPCS voices etc were barely audible so I had to turn voice sound up all the way and everything else down just to hear them.

    Then in battle I noticed that none of the chanting that the characters do when they cast spells was happening. And the battle itself just seemed oddly quiet. No battle music, didn't hear anyone swinging their weapons. Could just hear effects of spells, and sometimes when my characters got hit I could hear them. But overall the sound was very lacking.

    Also, I was getting some of those bugs where random npcs names would be "invalid" or they would be some weirdly long piece of text from another point in the game.

    I removed my override folder and reloaded and the sound worked fine and didn't notice any of those dialogue issues.

    Any idea exactly what this could be?

    It is worth noting that this was a game I had running already and then got updated to 2.5, so I reinstalled the game, reinstalled scs and reinstalled rogue rebalancing, and continued the game.

  • tedmann12tedmann12 Member Posts: 6
    Ok, I removed Rogue Rebalancing mods and I get the casting sounds back. But now I get even more "Invalid" dialogues. I am doing the fight in the guarded compound and during battle I am getting all sorts of "invalid" text displaying in the UI.

Sign In or Register to comment.