Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[MOD] [BETA] Monastic Orders of Faerun

1234568

Comments

  • [Deleted User][Deleted User] Posts: 0
    edited October 2018
    The user and all related content has been deleted.

    Post edited by [Deleted User] on
  • lightbringer32lightbringer32 Member Posts: 19
    Hi Subtledoctor!

    You beat me to it. I found the solution to the item issue. In EE Keeper, I discovered a slew of "effects" attached to my character all called "Cannot Use Item" and referencing an item code. The resource was from this mod. I suspect that the Restrictions component took all items classified as Armor (which the special monk robe was) and banned them. The nature of the items on the list supports the notion (helms, shields, 2h weapons, etc).

    In EE Keeper, I was able to remove the effect on my character keyed to the item in question and now it's wearable.

    Carry on! :D

    [Deleted User]
  • erianneerianne Member Posts: 13
    Found a small error in SetUp-MonasticOrders.tp2:
    backstab
    sneakatt
    crippstr
    addresses only 40 rows - means level 0 to 39.
    Level 40 is empty
    This is the reason why remove xp cap from tweaks anthology won't work.

    Manually editing the .2da or adding one row to all kits is the easiest solution.

  • chunkyhobbitchunkyhobbit Member Posts: 7
    Stunning blows no longer stuns. I hit an enemy and the chat says "Stunned" but the enemy is not stunned.

  • chunkyhobbitchunkyhobbit Member Posts: 7
    Sorry but I cannot play this mod with such a bug. Terrible that upon installing and picking a regular Monk kit, the stunning blows (the most important early game ability) does not work.

  • HalcyonHalcyon Member Posts: 56
    Installed this on a fresh copy of BG 1. The Kits, race and multi-class options seem to install and the classes have the offensive and defensive stances, but the THACO and HP progressions are still those of a core thief.

  • HalcyonHalcyon Member Posts: 56
    Has anyone else had the THACO / HP problem? Ever any mod updates that addressed this?

  • AquadrizztAquadrizzt Member Posts: 982
    @Halcyon, I just checked the code and the HP and THAC0 updates should be working. Can you send me the HPCLASS.2da and the QDMONK**.2da files from your override directory?

  • HalcyonHalcyon Member Posts: 56
    edited June 2019
    Aquadrizzt wrote: »
    @Halcyon, I just checked the code and the HP and THAC0 updates should be working. Can you send me the HPCLASS.2da and the QDMONK**.2da files from your override directory?

    I actually haven't attempted the mod since I posted in February, I'll reload it and check; thanks.

    Loaded Mod Merge and Monastic Order, attack and hp shake out to thief.

    Huh, actually I've never posted or messaged a file on here and have no idea how to convert the file to something I can post. Will work on it.

    Post edited by Halcyon on
  • AquadrizztAquadrizzt Member Posts: 982
    @Halcyon, feel free to email them to me if you want ([email protected]). They're just plain text files with a weird extension. The files I need to check are HPCLASS.2da and QDMONK**.2da for your installation.

    Halcyon
  • HalcyonHalcyon Member Posts: 56
    Aquadrizzt wrote: »
    @Halcyon, feel free to email them to me if you want ([email protected]). They're just plain text files with a weird extension. The files I need to check are HPCLASS.2da and QDMONK**.2da for your installation.

    Thanks, I'm away from my computer for the holiday weekend but I'll email you the docs when I get home Saturday.

  • RangeltoftRangeltoft Member Posts: 82
    Quick question, is there anyway to prevent a Gnome Illusionist/Monk from turning invisible when equiping a mage robe? as soon as the robe goes on the character disapears and all i see is the selection circle.

  • AquadrizztAquadrizzt Member Posts: 982
    @Rangeltoft , I'm not super well-versed on animations, but what I suspect is happening is that the game tries to display an armor level for the Robe that it can't show because the custom Monk animations don't have the armor level animations assigned. The easy solution might be to just add Robes to the list of equipment Monks cannot use, but I'm sure that would ruffle some feathers. I'll look into possible animation fixes when I have a moment.

  • RangeltoftRangeltoft Member Posts: 82
    @Aquadrizzt though it might be something like that, remeber reading that the shortys were just shrunken human paperdolls. Worked fine on Rasaad, so for now he will be my Mage/Monk (and 10 times better for it :P )

  • lightbringer32lightbringer32 Member Posts: 19
    @Aquadrizzt I'm experiencing an issue regarding the monk animations. I selected an elven monk, and my paper doll looks right. My avatar looks like it might be correct, but I'm not sure.

    When I use the provided unarmed strike (I modified it in NI to be droppable and a "mace", to allow it to be moved around and equipped), I don't get kick animations. I get my character swinging an empty hand. Before anyone comments, I get the same result if I change the item type in NI back into "hand to hand attack" -- only it can't be equipped as a weapon if moved.

    Furthermore, when I equip a melee weapon -- say, a longsword -- the weapon hovers at wrist level while my arms hang down. It appears to swing properly when attacking, but the idle animation has the weapon appear to float beside me. This leads me to suspect I actually do NOT have the correct avatar, but I certainly do not know.

    I've attached my weidu log, in case it's an install issue.

  • lightbringer32lightbringer32 Member Posts: 19
    edited October 2019
    Follow up with a little more testing:
    Created a single classed Human Monk -- Swords are held normally. Still no kick animations -- same empty handed swing.
    Created a single classed elven monk (previous elven monk was a Sun Soul/fighter multi), in case the multi did it. Swords floated to the side. Empty handed swing, no kicking.

    Oddly, with the elven avatar, swords were held correctly in the OFF hand, but not in the MAIN hand.

    I think I have a discrepancy between the paper doll and the avatar. I think my paper doll is actually for the fighter. The avatar is not like the monk (Rasaad, or your "everyone gets animations" post earlier). This avatar has short sleeves, a vest, and kind of a belted tunic look -- not the long sleeved karate gi looking outfit.

    My guess is that something went wrong with assigning avatars/animations to the new Monastic Orders Monk, and all these issues are symptoms. Anyone know how to fix it? Everything else seems to function ok, just want it to look right :)

  • AquadrizztAquadrizzt Member Posts: 982
    @lightbringer32 , tbh I might make the non-human animations a separate component. They are 100% a quick hack to solve the issue of FIghter paper dolls being awful for unarmed combat for non-Human monks; in fact, the new animations in this mod are just rescaled human animations at various resolutions.

    I also really don't know what I'm doing with animations in general (I'm a technician not an artist), so if something is broken with the animations it's because I don't know what I'm doing x.x

  • lightbringer32lightbringer32 Member Posts: 19
    @Aquadrizzt Thanks for the followup. Don't worry about it on my behalf. I forgot that I usually use an avatar morphing script to use the elven mage avatar, anyway -- has a good "flowing robes" look.

    One thing I did discover that greatly surprised me: Sun Soul's Purifying Strike doesn't seem to be working right. I get the bonus to hit and damage -- it even shows up in my character sheet. I receive no extra bonus to hit when fighting evil creatures, though. I cannot confirm damage, as it's random, but I would assume the same holds true.

    I tried it in BG1 on the archaeological dig map with both fists (QDMFIST) and weapons (a +1 scimitar), on the Doomsayer (detect evil confirmed Lawful Evil) and later on an Ogre Berzerker and an ogrillon. Nothing extra. To compare, I punched Commander Brage and his cousin Laryssa -- both confirmed by the paladin to be non-evil. Exact same bonuses to hit.

    Is there some repair work I can do in NI?

  • lightbringer32lightbringer32 Member Posts: 19
    Huh.
    I reread the description of Purifying Strike from the readme, and noticed something I never had before:
    "Gain a +1 bonus to melee hit and melee damage. This damage bonus is doubled against Evil foes. "

    By plain reading, against evil foes the bonus to HIT isn't doubled, just the bonus to DAMAGE. Can I get a confirmation that's the intended effect?

  • AquadrizztAquadrizzt Member Posts: 982
    @lightbringer32 , yeah if I recall correct I had good reason for that. Damage bonuses can be thrown around much more casually than attack bonuses (IMO) so if that's what I wrote, that's probably what I intended as well.

  • lightbringer32lightbringer32 Member Posts: 19
    Fair enough, makes sense. Thanks for the confirmation :)

  • GnollGnoll Member Posts: 24
    edited February 23
    I really enjoyed this mod playing through BG1 and SoD, it made the monk class really fun. I am having some issues in BG2 though. Whether importing or starting a new game, the "unarmed strike" attack (even if it is displayed in the inventory and in EEKeeper) is treated as the default "fist" attack from any character. So it does 1d2 nonlethal damage rather than act as the monk weapon it did in BG1. Any suggestions? Thanks!

    Edit: uninstalled BG2, did a clean install, only installed this mod. When starting a new game, there is no unarmed strike icon at all. If I import from BG1, they are just a thief. If I set them to level 0 in EEkeeper and then have them level up to level 1, they get an unarmed strike, but it isn't registered. It is still treated as a regular fist.

    Post edited by Gnoll on
  • ThacoBellThacoBell Member Posts: 11,035
    @Gnoll I know this is kinda old, but you can't import you character if they use a modded class. BG1 and BG2 have slightly different kitlist tables. So when you import, the game is reading the kit data in the same plave it was in BG1, but a different kit is there in BG2.

    If you want to carry everything from your character over, you'll need to use a save editor to set any exra stats from tomes.

    Timbo0o0o0
  • BardetBardet Member Posts: 1
    edited April 22
    Hi @Aquadrizzt , can't install this mod in NWN:EE because Core Components won't install, as Rasaad stuff is missing. Any solution?

  • ThacoBellThacoBell Member Posts: 11,035
    This mod is for BGEE and IWDEE.

  • CahirCahir Member, Moderator, Translator (NDA) Posts: 2,404
    Hi @Aquadrizzt. I was installing Monastic Orders of Faerun v.0.42 on my EET installation using Project Infinity tool and it throws me a bunch of installed with warnings. Attaching debug file.

    And here's a possible reason provided by @argent77 at G3.
    Latest release of MOoF is from 2017 where ADD_KIT_EX didn't exist yet. The warning is most likely from Wisp's fl#add_kit_ee function. ADD_KIT_EX shared this restriction in earlier versions, but has been fixed in v0.4.

  • AquadrizztAquadrizzt Member Posts: 982
    @Cahir , when I have some time, I'll see if I can update to ADD_KIT_EX. No idea when that will be but I'll keep you posted.

    Cahir
  • neuroghastneuroghast Member Posts: 6
    edited May 19
    Hi there @Aquadrizzt.

    First of all, great mod!

    Long story short, I was really into the idea of making Hexxat a Long Death Monk for my current playthrough. However, when I change her class using the NPC customization from SCS the game crashes when entering her inventory or character screen. I thought this was an issue with her or the custom kits, but I had the same thing happening with Rasaad and other NPCs when I changed their classes to a monk using this feature.
    EDIT: This also happen when changing her class with EE Keeper, setting her level to 0 and then re-leveling.

    I've asked DavidW at the G3 forums (here) and he believes it could be a compatibility issue between the two mods. Do you have any idea of what it could be and if there's any way around it?

  • AquadrizztAquadrizzt Member Posts: 982
    @neuroghast , if I had to guess, the problem lies in how I move Monk kits to the Thief class. There's probably some SCS functionality that notices my hackery and throws an exception; I'll see what I can do to make it more stable with SCS when I have some time.

    Glad you're otherwise enjoying the mod. :)

    neuroghast
  • neuroghastneuroghast Member Posts: 6
    Thanks for your quick answer, @Aquadrizzt !

    I've talked with some people on G3 discord and a member was super nice and offered to take a look at the .dmp files. He said the engine is crashing when attempting to look up the ability of an item. Most likely the monk fist is screwed, but he can't say for sure. Hopefully this helps you when you have the time to work in the mod again! :)

    On a side note, a suggestion: I really don't see why monks can't use staff. Unless it's an engine limitation, I'd suggest that Monastic Orders made staff a weapon avaliable to monks.

Sign In or Register to comment.