Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

New versions of NearInfinity available

13468935

Comments

  • I have a serious problem getting NI to install. Any suggestions on how I should do that?

  • Seriously I have a problem. Yesterday it worked fine but due to another person coming in and uninstalling the game for me by mistake ...etc, and after re-installing the game, NI will not "Install" - It wont even open up - its like its dead to the world...I get no option to locate the chitin.key - and I have the latest Java installed . Any suggetions??

  • smeagolheartsmeagolheart Member Posts: 7,638
    NI doesn't install? It's a JAR file, it opens with java. reinstall java?

    jackjackCrevsDaak
  • smeagolheartsmeagolheart Member Posts: 7,638
    For some reason it always gives me a warning saying no infinity engine game found with IWDEE, but then it opens it. Not sure why, anyone else get this?

    jackjack
  • There must be a "glitch" in my brain - I would have sworn I tried using Java to open NI but evidently I didnt or else my computer decided all of a sudden to allow it to "work". Thank You for your suggestion - it worked.
    Everyone has the right to be "stupid" from time to time - today I think Ive exceeded my limit~!

    Wilburhook71jackjackCrevsDaak
  • argent77argent77 Member Posts: 2,864
    @smeagolheart‌ Can you tell me more about the warning of not finding an Infinity Engine game? Does the debug console show anything (open with Ctrl+D or menu Tools->Show Debug Console)?

  • smeagolheartsmeagolheart Member Posts: 7,638
    edited December 2014
    @argent77

    Dec 29, 2014 6:02:45 AM java.util.prefs.WindowsPreferences
    WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(...) returned error code 5.
    java.lang.NullPointerException
    at infinity.resource.key.ResourceTreeModel.addDirectory(Unknown Source)
    at infinity.resource.ResourceFactory.loadResources(Unknown Source)
    at infinity.resource.ResourceFactory.(Unknown Source)
    at infinity.NearInfinity.(Unknown Source)
    at infinity.NearInfinity.main(Unknown Source)

    image

    Bgee and Bg2ee work fine for me. The game (iwdee) does open but everytime I switch to it I get this message first.

  • Ok - Day b4 yesterday, I installed NI - then I downloaded the newest java version - installed it...then I opened the .jar with java....everything worked to perfection. Later that night, NI quit working ....Nada...wouldnt do anything. Like a dead mouse . I got it working early this morning by simply rechoosing java to open it with . around 7pm tonite NI quit working again ... what is Up With That??
    Got any clues as to what might be going wrong?

  • 4 hours later and NI still will not work...Grrrrr - it must be a problem with my comp - what that might be I have no idea...i defragged it, cleaned the temp files, ran a virus scan and malware scan....NI is still dead to the world.

  • WilburWilbur Member Posts: 1,173

    4 hours later and NI still will not work...Grrrrr - it must be a problem with my comp - what that might be I have no idea...i defragged it, cleaned the temp files, ran a virus scan and malware scan....NI is still dead to the world.

    I had a similar problem with my previous desktop, but I never solved it. Or I kind of did by buying a new PC :). I also had a laptop at the time so it really wasn't an issue as NI worked fine on it. I believe it was a problem with Java, but reinstalling it did nothing. IIRC NI originally worked on my desktop then suddenly ceased even opening giving no error message or anything.

  • argent77argent77 Member Posts: 2,864
    edited December 2014
    @smeagolheart‌ I've sent you a PM with more details how to solve your problem.

    @Borg_DealerOfDeath‌ From your description it sound like the file association for JAR files has been changed on your system. To make sure that NearInfinity itself isn't the culprit you can execute it directly from the command line and see if it starts or merely prints some kind of error message. To do this, open a command prompt, switch into the directory where you can find the NearInfinity.jar and enter:
    java -jar NearInfinity.jar
    If Java isn't in your path, then you have to enter the full path to the java application. On Windows it's usually installed somewhere into "C:\Program Files" or "C:\Program Files (x86)". For example:
    "C:\Program Files (x86)\Java\jre1.8.0_25\bin\java.exe" -jar NearInfinity.jar

  • smeagolheartsmeagolheart Member Posts: 7,638
    sorry I didn't get a chance to mess around with it yesterday I'll try to take a look at what you suggested today after work.

  • Ive discovered - My comp runs windows 7 64bit - so I assumed - yeah there goes that word and all it implies - that I needed the 64bit version of Java --only -- come to find out , NI doesnt "like" Java 64bit - it seems to prefer Java 32bit - ...at least on my machine - - for the time being. I had to completely un-install Java 64bit - re-install Java 32bit to get NI to even open up - I am using the Master-OX version - its working like a charm now. The real test will be if its still working tomorrow at this time with no "problems" in-between...crossing my fingers here.

  • Borg_DealerOfDeathBorg_DealerOfDeath Member Posts: 79
    Update: NI is working perfectly - on Java 32bit version. Thought someone else who is having a problem with NI might give my remedy a try...it might work for you --- it might not.

    HAPPY NEW YEAR to One And All ~~~!!!

    Wilburjackjack
  • argent77argent77 Member Posts: 2,864
    @Borg_DealerOfDeath‌ Great that it's finally working for you, but this is the first time I've heard that the 64-bit version of Java is causing any kind of trouble with NI. Have you tried to execute Near Infinity on the command line with 64-bit Java (see information how it's done in my previous post)? Did it print any kind of error message?

  • BelanosBelanos Member Posts: 968
    argent77 said:

    ...but this is the first time I've heard that the 64-bit version of Java is causing any kind of trouble with NI.

    I've always used the 64 bit version of Java and I've never had a problem with NI while using it. I'd say something else was causing the problem, not just that.

    CrevsDaakjackjack
  • CrevsDaakCrevsDaak Member Posts: 7,145
    I've been using NI on 64 bits Java for OSX and never got any problems like that.

    hook71
  • Borg_DealerOfDeathBorg_DealerOfDeath Member Posts: 79
    Im clueless as to why NI only works on 32bit Jave on my win 7 machine - but as long as its working, Im not gonna "fix it". I might try re-installing Java 64bit and see if it affects anything. Thanks for all the input guys...it helps.

  • AstroBryGuyAstroBryGuy Member Posts: 3,414
    For OS X users - I've updated NearInfinity-OSX to v1.35.0-snapshot-20150104

    https://github.com/AstroBryGuy/NearInfinity-OSX/releases

    jackjack
  • GraibanGraiban Member Posts: 6
    Thanks for this tool. I have a question. Let's say for example I would like to add a third pip to all the weapon styles other than dual wield. What would I need to do to do that? I see lots of tutorials on npc creation, item creation etc, but nothing when it comes to fiddling with the underlying game system. Thanks.

  • AstroBryGuyAstroBryGuy Member Posts: 3,414
    edited January 2015
    You can add more pips to the currently existing styles by editing the file STYLBONU.2DA in NearInfinity. Just add a new line for the style at 3 pips, e.g., "SWORDANDSHIELD-3". The available columns are: DAMAGE_RIGHT, DAMAGE_LEFT, THAC0_RIGHT, THAC0_LEFT, AC_BASE, AC_MISSILE, SPEED, CRITICALROLL.

    You also need to edit the max proficiency tables in WEAPPROF.2DA to allow classes to take 3 pips in those styles.

    jackjack
  • GraibanGraiban Member Posts: 6
    edited January 2015
    Thanks so much. Another question. If I make changes here how can I make them carry over to BG2 as well? Will I have to go through the whole process again or is there some way I can do it once? Copy some files over perhaps to that install directory?

    Also, backup on save is checked but I can't seem to find any backups. When I right click the tree or go to file the restore option is greyed out. Thanks.

    Post edited by Graiban on
  • argent77argent77 Member Posts: 2,864
    edited January 2015
    You may copy the STYLBONU.2DA and WEAPPROF.2DA over to BG2. You can find the files in the override folder of the game. To be on the safe side I'd suggest to manually add the changes to the respective files in BG2 instead.

    Concerning the backup feature, it works only if you modified non-biffed files, i.e. game files you have modified at least twice. In your case it is safe to use the "Delete" command instead to restore the original (don't worry, the original file can't be deleted so easily). I may change this behavior in one of the next NI releases to make it less confusing.

    AstroBryGuy
  • GraibanGraiban Member Posts: 6
    On WEAPPROF.2DA I am having a hard time understanding it. A number of classes have seemingly strange numbers. Fighters have 1s and 0s all over the place, clerics 5s, some classes who can have 3 in double weapon have 3 and some don't. Can anyone elaborate?

  • AstroBryGuyAstroBryGuy Member Posts: 3,414
    Sounds like the column headers are offset. What do you see under the MAGE column? It should be 0s and 1s. If its large numbers, that's the DESC_REF column. Just add some spaces to the column header line to get the columns correctly aligned.

    Graibanjackjack
  • GraibanGraiban Member Posts: 6
    Yup that's it, it lines up in what looks a perfect manner but it's actually offset one column. Much obliged.

    AstroBryGuyjackjack
  • I attempted to use NI with BG 1 ... it wont read the .BS script files. Is there anything I need to change to be able to read the in-game scripts and make changes to them?

  • argent77argent77 Member Posts: 2,864
    edited February 2015
    Did you see any error message or is there anything shown in the debug window (open via Tools->Show Debug Console)?

    Edit: Can you open BCS files? They are basically handled the same way as BS files.

Sign In or Register to comment.