Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Class/Kit Attempt: Warlock

123457

Comments

  • seraglioseraglio Member Posts: 103
    The Hungry darkness invocation in my installation is just WRLKLS9.SPL

    I'll run those tests shortly. Thanks a ton for helping!

  • seraglioseraglio Member Posts: 103
    I also included some screenshots.

    wrlkls9 casts 2 spells and does damage

    the cast spell casts wrlkdead....which doesn't exist in my install.

    the cast spell at point leads to wrlklt9a, which references a projectile by the same name, not the one you asked me to attach.

    Maybe some things didn't get named properly by weidu?

  • seraglioseraglio Member Posts: 103
    And by the way quite a few cast spells and sequencers refer to wrkldead and wrlkbess, neither of which exists, even in the downloaded install. So many in fact I just assumed they were purposeful "bit buckets" for reference purposes not intended do do anything. In case that helps....

  • kjeronkjeron Member Posts: 2,177
    @seraglio
    Okay, "PROJECTL.IDS" is clearly missing any reference to the warlock projectiles, that's not really a surprise except that WRLKLS9.spl does have a projectile number assigned to it, which it shouldn't if PROJECTL.IDS wasn't updated, since the number is taken from entry added to PROJECTL.IDS.

    So I copied your PROJECTL.IDS into my game then installed the warlock kit on top of it, and my Hungry Darkness spell has the same(correct) projectile value as yours does (#407). My PROJECTL.ids is being correctly updated, so at least here is what yours should have at the very bottom after the kit is installed:
    396 WRLKBS0
    397 WRLKBS5
    398 WRLKBS8
    399 WRLKBS7
    400 WRLKBSD
    401 WRLKBS2A
    402 WRLKLTA4
    403 WRLKLT04
    404 WRLKLT9A
    405 WRLKHP10
    406 WRLKLS9A
    407 WRLKLG1A
    408 WRLKLG1B
    409 WRLKLG3
    410 WRLKLG4A
    411 WRLKLG4B
    412 WRLKLG6
    413 WRLKLD1
    414 WRLKLD1A
    415 WRLKLD5
    416 WRLKBS9
    417 WRLKLD4B

    Since the spells are being correctly updated to use these projectile numbers, I can only suspect that PROJECTL.IDS is being restored from a point before the kit is installed, but I've no idea what would or even could be causing it. These values should work if you just copy/paste them to the end of the file(its just a plain text file, any plain text editor will work), if you would like a quick fix.

    If your willing, search your game folder for all files named "PROJECTL.IDS", if you can find one that "does" have these projectiles listed at the bottom, whatever mod's backup folder it is located in would be the culprit.

  • kjeronkjeron Member Posts: 2,177
    edited January 2017
    seraglio said:

    And by the way quite a few cast spells and sequencers refer to wrkldead and wrlkbess, neither of which exists, even in the downloaded install. So many in fact I just assumed they were purposeful "bit buckets" for reference purposes not intended do do anything. In case that helps....

    There will be sequencer references to non-existant spells, that's just how Near Infinity displays them. Sequencer activation matches a specific field in the file(which I manually set), not the filename.

    There should not be cast spell references to non-existant spells, and WRLKDEAD is indeed not getting copied, I will fix it in the next build, but its not causing the immediate problem. It feeds the Soulreaving Aura Invocation dead bodies.

    As for the Hungry Darkness spell, the other spell it casts is the part of the (normal) Darkness spell that creates the darkness "cloud", so what your seeing should be correct. I just needed the projectile to see if it was being altered/corrupted somehow during download or installation, which it wasn't.

  • seraglioseraglio Member Posts: 103
    I'm seeing visual effects now after fixing the projecl.ids file. So I think were in business, just have more tests to do. Is the hungry darkness pro kinda like chilling fog, pale blue, but about half the area? I definitely have effects now, just need a way of confirming they're the correct ones. Thanks so much for your quick response!

  • kjeronkjeron Member Posts: 2,177
    seraglio said:

    I'm seeing visual effects now after fixing the projecl.ids file. So I think were in business, just have more tests to do. Is the hungry darkness pro kinda like chilling fog, pale blue, but about half the area? I definitely have effects now, just need a way of confirming they're the correct ones. Thanks so much for your quick response!

    Yes, the darkness cloud is a pale blue color. The game uses a system where: White = Opaque, Black = Transparent, so trying to make it "darker" only resulted in the opposite.

  • TremontonTremonton Member Posts: 16
    So, I haven't played IWDEE before, and having just done a fresh install I tried to install this mod. Got this in the debug file:

    Copying and patching 1 file ...
    [WARLOCK\10_BLASTS\0_ELDRITCH\WRLK_B09.SPL] loaded, 8578 bytes
    ERROR: [WARLOCK\10_BLASTS\0_ELDRITCH\WRLK_B09.SPL] -> [override] Patching Failed (COPY) (Failure("Unknown function: wrlk_pro_BS9"))
    Stopping installation because of error.

    Sorry for coming to the party late, but any idea what the deal is?

  • kjeronkjeron Member Posts: 2,177
    edited April 2017
    Tremonton said:

    So, I haven't played IWDEE before, and having just done a fresh install I tried to install this mod. Got this in the debug file:

    Copying and patching 1 file ...
    [WARLOCK\10_BLASTS\0_ELDRITCH\WRLK_B09.SPL] loaded, 8578 bytes
    ERROR: [WARLOCK\10_BLASTS\0_ELDRITCH\WRLK_B09.SPL] -> [override] Patching Failed (COPY) (Failure("Unknown function: wrlk_pro_BS9"))
    Stopping installation because of error.

    Sorry for coming to the party late, but any idea what the deal is?

    Several functions were split due to game version differences(v1.4 / v2.0), that one wasn't, but should have been.
    That issue is fixed, new version in initial post, but I'm looking to see if there is another I need to fix yet.

  • kjeronkjeron Member Posts: 2,177
    @Tremonton I did find, and fix, some more issues for IWDEE, it should work now (_043017a).

    Tremonton
  • TremontonTremonton Member Posts: 16
    Very nice. Thanks so much for the swift response!

  • Kai50Kai50 Member Posts: 60
    @kjeron Hi sorry to bother you I am having trouble installing this mod. I haven't had trouble with it before its an awesome mod and I really enjoy a lot of the spells and stuff :P I had to wipe my folder clean and do a clean install and ever since I haven't been able to install this :/ it always happens. I end up wiping clean because I am having an issue with one mod, then I get that one working but it opens up a load of problems with other mods xD cant win. Anyway I just tried installing this mod first on a completely clean install so there are no other mods installed at the moment and I get this error:

    ERROR: cannot resolve trigger 0x40e0
    ERROR: [SPLSHMKN.BCS]->[Override\SPLSHMKN.BCS patching failed Not_Found>
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    ERROR Installing [Warlock kit / Cleric class -> BGEE. No Attribute requirements]
    , rolling back to previous state
    Will Uninstall 126 files for [WARLOCK.TP2] component 6.
    Uninstalled 126 files for [WARLOCK.TP2] component 6.
    ERROR Not_found
    Please email yada yada and that's it. I am on windows vista if that helps anything else you need to know let me know. Thanks in advance for any help you can give me with this xD

  • kjeronkjeron Member Posts: 2,177
    Kai50 said:

    ERROR: cannot resolve trigger 0x40e0

    What version/game are you running, because this trigger should already be present in all versions of the game supported by this mod.

  • Kai50Kai50 Member Posts: 60
    its bg 2 ee on steam using the most recent version of the mod that you have up. I have been messing around with near infinity a bit and editing a few weapons here and there..could that be a possible cause?

  • kjeronkjeron Member Posts: 2,177
    @Kai50 No, editing weapons wouldn't cause this, the file in question would be "TRIGGER.IDS". There is no reason or excuse for any mod to delete entries from this file, so I do not know why it would not have this trigger. The easiest way around this would be to open the file in Near Infinity and add this line to it:
    0x40E0 NextTriggerObject(O:Object*)

  • Kai50Kai50 Member Posts: 60
    kjeron said:

    @Kai50 No, editing weapons wouldn't cause this, the file in question would be "TRIGGER.IDS". There is no reason or excuse for any mod to delete entries from this file, so I do not know why it would not have this trigger. The easiest way around this would be to open the file in Near Infinity and add this line to it:
    0x40E0 NextTriggerObject(O:Object*)

    Ok I am pretty new to near infinity. So far I have worked out how to add spells to items and that's about it xD so where would I add this line?

  • kjeronkjeron Member Posts: 2,177
    edited May 2017
    @Kai50
    Just click the magnifying glass, type "TRIGGER" in that search box, and hit enter, and the file should come up. It's just a normal text file, scroll to the bottom and add that text on a new line.

  • Kai50Kai50 Member Posts: 60
    kjeron said:

    @Kai50
    Just click the magnifying glass, type "TRIGGER" in that search box, and hit enter, and the file should come up. It's just a normal text file, scroll to the bottom and add that text on a new line.

    @kjeron That doesn't seem to have worked :/ its still giving exactly the same error message. Thanks for the swift responses by the way.

  • kjeronkjeron Member Posts: 2,177
    edited May 2017
    @Kai50 Then I'm afraid I don't know why it is failing to install, but I will try to convert the mod to bypass checking that trigger during the installation, hopefully shouldn't take too long.done(_051117b). Hopefully it will work.

    Edit: Let me know if its throwing a ton of Warnings during the install - this will happen if that Trigger is not present during the installation, but it should not break installation. Either way, make sure that Trigger is still in TRIGGER.IDS once everything is installed, it is still necessary for the mod and is also used by the base game.

    I have looked around and some older (pre-EE) mods do overwrite the TRIGGER.IDS file with an outdated version, which may be causing the issue, but I don't know why it would persist on a clean install - though Steam has been shown to not fully "Clean" a re-install. If this is happening there are likely several triggers missing necessary for both this mod and the base game. If you find you can learn the same spell/invocation over and over, then this is very likely the problem, and there is another Trigger you will need for this mod:
    0x4102 HaveKnownSpellRES(S:Spell*).

    I have added these triggers to the mods separate "Update Mod" portion as well, so if you install it after all other mods you won't need to manually change anything yourself.

    Post edited by kjeron on
  • Kai50Kai50 Member Posts: 60
    kjeron said:

    @Kai50 Then I'm afraid I don't know why it is failing to install, but I will try to convert the mod to bypass checking that trigger during the installation, hopefully shouldn't take too long.done(_051117b). Hopefully it will work.

    Edit: Let me know if its throwing a ton of Warnings during the install - this will happen if that Trigger is not present during the installation, but it should not break installation. Either way, make sure that Trigger is still in TRIGGER.IDS once everything is installed, it is still necessary for the mod and is also used by the base game.

    I have looked around and some older (pre-EE) mods do overwrite the TRIGGER.IDS file with an outdated version, which may be causing the issue, but I don't know why it would persist on a clean install - though Steam has been shown to not fully "Clean" a re-install. If this is happening there are likely several triggers missing necessary for both this mod and the base game. If you find you can learn the same spell/invocation over and over, then this is very likely the problem, and there is another Trigger you will need for this mod:
    0x4102 HaveKnownSpellRES(S:Spell*).

    I have added these triggers to the mods separate "Update Mod" portion as well, so if you install it after all other mods you won't need to manually change anything yourself.

    kjeron said:

    @Kai50 Then I'm afraid I don't know why it is failing to install, but I will try to convert the mod to bypass checking that trigger during the installation, hopefully shouldn't take too long.done(_051117b). Hopefully it will work.

    Edit: Let me know if its throwing a ton of Warnings during the install - this will happen if that Trigger is not present during the installation, but it should not break installation. Either way, make sure that Trigger is still in TRIGGER.IDS once everything is installed, it is still necessary for the mod and is also used by the base game.

    I have looked around and some older (pre-EE) mods do overwrite the TRIGGER.IDS file with an outdated version, which may be causing the issue, but I don't know why it would persist on a clean install - though Steam has been shown to not fully "Clean" a re-install. If this is happening there are likely several triggers missing necessary for both this mod and the base game. If you find you can learn the same spell/invocation over and over, then this is very likely the problem, and there is another Trigger you will need for this mod:
    0x4102 HaveKnownSpellRES(S:Spell*).

    I have added these triggers to the mods separate "Update Mod" portion as well, so if you install it after all other mods you won't need to manually change anything yourself.

    @kjeron so there is a new install up is that correct? Thanks for trying to get to the bottom of this xD I really do enjoy this warlock mod :P

  • kjeronkjeron Member Posts: 2,177
    @Kai50 Yes, the initial post has an updated install.

  • Kai50Kai50 Member Posts: 60
    @kjeron That link seems to be invalid? nothing happens when I click on it and then like a minute later I get a delayed response saying "failed server problem" my internet connection is fine..

  • kjeronkjeron Member Posts: 2,177
    @Kai50 You might need to forcibly refresh the page before trying to download the attachment.

  • Kai50Kai50 Member Posts: 60
    @kjeron yeah thanks xD I downloaded it ok but its still not installing. tried all the above. now I am getting a lot of Parsing parse errors in dialog. I will post the exact stuff tomorrow maybe. Sigh All I wanted was to start a new game as a warlock xD maybe I will try clean installing again. maybe if I delete EVERYTHING in the folder before a new install that will work better. I dunno lol

  • kjeronkjeron Member Posts: 2,177
    @Kai50 sorry nothing has been working, but it does sound like the installation at least made it past that specific issue, only for another one to pop up. I will look at it again once you post the errors.

  • Kai50Kai50 Member Posts: 60
    @kjeron no worries Thanks for all your efforts to help me xD. so this is the next lot of errors I have:

    In State 931, I expected one these tokens:
    [0] EOF
    Parse Error at END

    [WARLOCK\v2 .0\SPLSHMKN\SPLSHMKN_BCS.tpa] PARSE ERROR at line 96 column 1-3
    Near text: END
    GLR parse error

    WARLOCK\v2 .0\SPLSHMKN\SPLSHMKN_BCS.tpa] PARSE ERROR at line 96 column 1-3
    Near text: END
    Parsing.parse_error
    ERROR: Parsing WARLOCK\v2 .0\SPLSHMKN\SPLSHMKN_BCS.tpa]: parsing.parse_error
    Stopping installation because of error
    Stopping installation because of error

    ERROR Installing [Warlock kit / Cleric class -> BGEE: No attribute requirements]
    rolling back to previous state
    Will uninstall 49 files for [WARLOCK/WARLOCK.Tp2] component 6.
    Uninstalled 49 files for [WARLOCK/WARLOCK.Tp2] component 6.
    In State 931, I expected one of these tokens:
    [0] EOF


    etc etc it basically repeats these lines again and says "Parsing parse" error A LOT and then asks me if I want to install again.

  • kjeronkjeron Member Posts: 2,177
    edited May 2017
    @Kai50 okay, that one is my fault, one of the files didn't update properly in the version that got uploaded. New version uploaded to first post.

  • GalactygonGalactygon Member, Developer Posts: 383
    Installation fails for me when attempting to install of BG2EE:
    ERROR: Failure("resource [#BONECIR.SPL] not found for 'COPY'")

    Contents of my WeiDU.log:
    // Log of Currently Installed WeiDU Mods // The top of the file is the 'oldest' mod // ~TP2_File~ #language_number #component_number // [Subcomponent Name -> ] Component Name [ : Version] ~FAITHS_AND_POWERS/FAITHS_AND_POWERS.TP2~ #0 #102 // Select an installation method below: -> all the new kits and the sphere system, but kits in menus: 0.63b ~TOMEANDBLOOD/SETUP-TOMEANDBLOOD.TP2~ #0 #0 // Revised Specialists: 0.7 ~TOMEANDBLOOD/SETUP-TOMEANDBLOOD.TP2~ #0 #1 // Revised Dragon Disciples: 0.7 ~TOMEANDBLOOD/SETUP-TOMEANDBLOOD.TP2~ #0 #2 // Sorcerer: Magus: 0.7 ~TOMEANDBLOOD/SETUP-TOMEANDBLOOD.TP2~ #0 #3 // Sorcerer: Favoured Soul: 0.7 ~TOMEANDBLOOD/SETUP-TOMEANDBLOOD.TP2~ #0 #4 // Sorcerer: Sylvan Disciple: 0.7 ~TOMEANDBLOOD/SETUP-TOMEANDBLOOD.TP2~ #0 #5 // Sorcerer: Revenant Disciple: 0.7 ~TOMEANDBLOOD/SETUP-TOMEANDBLOOD.TP2~ #0 #6 // Sorcerer: Amorphous Disciple: 0.7 ~TOMEANDBLOOD/SETUP-TOMEANDBLOOD.TP2~ #0 #7 // Innate Find Familiar: 0.7 ~TOMEANDBLOOD/SETUP-TOMEANDBLOOD.TP2~ #0 #9 // Arcane Crafting: 0.7 ~TOMEANDBLOOD/SETUP-TOMEANDBLOOD.TP2~ #0 #10 // Spell Tweaks: 0.7 ~TOMEANDBLOOD/SETUP-TOMEANDBLOOD.TP2~ #0 #11 // Metamagic: 0.7 ~TOMEANDBLOOD/SETUP-TOMEANDBLOOD.TP2~ #0 #12 // Cantrips -> Innate Cantrips: 0.7

  • kjeronkjeron Member Posts: 2,177

    Installation fails for me when attempting to install of BG2EE:

    Apologies and Fixed. This was BG2EE v1.3, yes? I didn't add that code to the v2.0 installs.

  • GalactygonGalactygon Member, Developer Posts: 383
    Yes. Thanks for the quick fix, I can now get it to install!

Sign In or Register to comment.