Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Faiths and Powers: Gods of the Realms (Kitpack and divine caster/spell tweaks)

1117118119120121123»

Comments

  • CharlestonianTemplarCharlestonianTemplar Member Posts: 855
    You can also see here for a more detailed readme like thing:

    https://github.com/UnearthedArcana/Faiths_and_Powers/issues/136

    Edit:
    @subtledoctor : One last question. I'm pretty sure I've read that you use all three - DoF, DR and F&P - in your massive install. What's the best order to do them in?

    Thank you. Ready to install later today.

    Wise_Grimwald
  • Mantis37Mantis37 Member Posts: 1,111
    @CharlestonianTemplar

    I would recommend this mod to you, it makes something like a party consisting of priests & champions of lawful gods quite viable and fun. To be honest if you haven’t played with it before I would suggest trying it in a ‘lighter’ installation than usual first time though as it makes some quite fundamental changes to how some classes work.

    CharlestonianTemplarBlackravenWise_Grimwald
  • CharlestonianTemplarCharlestonianTemplar Member Posts: 855
    Mantis37 wrote: »
    @CharlestonianTemplar

    I would recommend this mod to you, it makes something like a party consisting of priests & champions of lawful gods quite viable and fun.

    Looking forward to it. I am likely going to do parts of each F&P, DR & DoF (minus sphere system). I am really into Paladin's and Clerics and their relationship to their chosen deity, i.e., Clerics, Paladin's, Druids too.

    BlackravenWise_Grimwald
  • [Deleted User][Deleted User] Posts: 0
    edited February 23
    The user and all related content has been deleted.

    GrammarsaladCharlestonianTemplarWise_Grimwald
  • WeevilWeevil Member Posts: 2
    edited March 2
    The multiclass part of this mod fails to install on BGEE. The druid multiclass installs fine but the shaman and cleric part fails.

    Error for cleric multiclass install:
    #[C:\Games\Baldur's Gate Enhanced Edition backup - Copy\setup-Faiths_and_Powers_Multiclass.exe] WeiDU version 24600
    #Using Language [English]
    #Using .\lang\en_us\dialog.tlk
    #Installing [Multiclass Cleric kits (install AFTER all other kit mods!!)] [0.79.8]
    #Copying and patching 1 file ...
    #Copying and patching 1 file ...
    #Copying and patching 1 file ...
    #Defining Faiths and Powers info for kit clabshgs ...
    #Defining Faiths and Powers info for kit clabsh01 ...
    #Copying and patching 1 file ...
    #ERROR: cannot convert d5_spell_spontaneous or %d5_spell_spontaneous% to an integer
    #Stopping installation because of error.
    #Stopping installation because of error.
    #Stopping installation because of error.
    #Stopping installation because of error.
    #ERROR Installing [Multiclass Cleric kits (install AFTER all other kit mods!!)], rolling back to previous state
    #Will uninstall 0 files for [FAITHS_AND_POWERS_MULTICLASS/FAITHS_AND_POWERS_MULTICLASS.TP2] component 95.
    #Uninstalled 0 files for [FAITHS_AND_POWERS_MULTICLASS/FAITHS_AND_POWERS_MULTICLASS.TP2] component 95.
    #ERROR: Not_found
    #Please make a backup of the file: SETUP-FAITHS_AND_POWERS_MULTICLASS.DEBUG and look for support at: SubtleD and Grammarsalad
    #Automatically Skipping [Multiclass Cleric kits (install AFTER all other kit mods!!)] because of error.
    #
    #WARNING: Faiths_and_Powers_Multiclass : 95 has encounter errors durring installation, exited with ExitCode = 2
    #INSTALLATION FINISHED.
    #Using Language [English]
    #NOT INSTALLED DUE TO ERRORS Multiclass Cleric kits (install AFTER all other kit mods!!)

    Weidu log
    // Log of Currently Installed WeiDU Mods
    // The top of the file is the 'oldest' mod
    // ~TP2_File~ #language_number #component_number // [Subcomponent Name -> ] Component Name [ : Version]
    ~DLCMERGER/SETUP-DLCMERGER.TP2~ #0 #1 // Merge DLC into game -> "Siege of Dragonspear" DLC: 1.2
    ~FAITHS_AND_POWERS/FAITHS_AND_POWERS.TP2~ #0 #21 // Create a sphere system -> FnP: the Faiths & Powers original sphere system: 0.79.8
    ~FAITHS_AND_POWERS/FAITHS_AND_POWERS.TP2~ #0 #31 // Install Cleric kits: 0.79.8
    ~FAITHS_AND_POWERS/FAITHS_AND_POWERS.TP2~ #0 #33 // Install Druid kits: 0.79.8
    ~FAITHS_AND_POWERS/FAITHS_AND_POWERS.TP2~ #0 #35 // Install Paladin kits: 0.79.8
    ~FAITHS_AND_POWERS/FAITHS_AND_POWERS.TP2~ #0 #37 // Install Ranger kits: 0.79.8
    ~FAITHS_AND_POWERS/FAITHS_AND_POWERS.TP2~ #0 #75 // Alter weapon usability and proficiency: 0.79.8
    ~FAITHS_AND_POWERS/FAITHS_AND_POWERS.TP2~ #0 #80 // Apply sphere system: 0.79.8
    ~FAITHS_AND_POWERS/FAITHS_AND_POWERS.TP2~ #0 #85 // Apply FnP kits to NPCs: 0.79.8
    ~FAITHS_AND_POWERS_MULTICLASS/FAITHS_AND_POWERS_MULTICLASS.TP2~ #0 #91 // Multiclass Druids: 0.79.8

    There were also some warnings when installing some of the components of the main mod I don't know if that matters

  • The user and all related content has been deleted.

    ThacoBellWise_Grimwald
  • EndarireEndarire Member Posts: 421
    @subtledoctor
    In the ALWAYS block, I didn't see "INCLUDE" but I saw this:

    ACTION_IF NOT FILE_EXISTS ~override/d5_fnp_settings.ini~

    Is it safe to assume adding the LAM line will make this work the same way?

    Thankee!

  • The user and all related content has been deleted.

  • DrackolusDrackolus Member Posts: 9
    Installing the multiclass cleric kit always throws the same error and fails to install for me;
    #ERROR: cannot convert d5_spell_spontaneous or %d5_spell_spontaneous% to an integer

    Does this even on completely fresh installs.

  • [Deleted User][Deleted User] Posts: 0
    edited March 5
    The user and all related content has been deleted.

    ThacoBell
  • SmashingPlanetsSmashingPlanets Member Posts: 2
    Made an account to give thanks for creating this mod. I had already had a Thief/Cleric run through BG1, and I used this mod when I went to BG2. It's already changing who I'm considering taking with me in bg2 because of the myriad of possibilities it opens up.

    I have noticed that Jaheira - when shapeshifted - is occasionally invincible. She'll get knocked down to one hit point, and then stay at one hit point indefinitely. I noticed it with her snake form, and with her Black Bear form. I ...may have used this to my advantage...once or twice, since my party is just her, my PC, and Korgan to start. We had the fight in the upstairs of the Den of the Seven Veils, and Jaheira tanked it using...well, powers she didn't know she had.

    I'm using SCS as well, which I installed before this mod. Other mods are things like banterpacks, and I have no other kit mods installed. Oh, I also have the bg2fix pack. I don't think those other mods are responsible, but you never know. I'm fairly new to modding, so let me know if there's any other details you'd like to know.

    This isn't a big deal, since I was thinking of dropping Jaheira anyway, but I wanted to give you this bug report.

  • PenguinchachaPenguinchacha Member Posts: 1
    The Deception's HLA Mirrored Clones is Required Level 18, so when you learn it too early (cleric multiclass), it does not appear on the spell bar, and the game crashes when you rest. Just wanted to report it if it is a bug.

  • The user and all related content has been deleted.

    ThacoBell
  • Necromanx2Necromanx2 Member Posts: 1,194
    Speaking of Jaheira, she can't equip scimitars even though she has a pip in it. My North Druid can't use them either.
    BG2EE, with v79.9.2

  • The user and all related content has been deleted.

    Necromanx2
  • Wise_GrimwaldWise_Grimwald Member Posts: 2,945
    edited March 14
    Necromanx2 wrote: »
    Speaking of Jaheira, she can't equip scimitars even though she has a pip in it. My North Druid can't use them either.
    BG2EE, with v79.9.2
    The other option is to use EE Keeper to re-assign the pip.
    Do it in the saved game for your current game, but in ALL the cre files for subsequent games.
    You will then only have to change the proficiency once.

  • Necromanx2Necromanx2 Member Posts: 1,194
    edited March 17
    The Priest of Mystra starts BGEE with a wand that cast the cantrips. In BG2EE I don't get the wand so cannot cast any cantrips. Using v79.9.2.

    EDIT: Question. The Priest of Azuth Arcane weave spells, do they always cast at minimum level? (EX: Magic missile will only ever have 1 missile). If yes, does haste and improved haste last just one round?

    Edit 2: My priest of Azuth got to 5th level, but does not gain any ability to identify items per the kit description.

    Post edited by Necromanx2 on
  • SmashingPlanetsSmashingPlanets Member Posts: 2
    Based on the feedback I received, reinstalled my mods, making sure to do better on the mod install order. Jaheira works properly now, and I have to say, is a much more fun character thanks to this mod. I wasn't planning on taking her with, but her abilities are fantastic. The insect summons and shapeshifting are excellent in this mod. At first, I thought her armor restrictions were way too harsh (leather/hide armor only), but she can make it work. She's entirely frontline capable with her spell selection and shapeshifting. She's definitely my most interesting character, and it may make me roll a similar character on my next playthrough.

    Wise_Grimwald
  • zelurkerzelurker Member Posts: 155
    Lost between the releases with the disappearance of subtledoctor, there is the 0.79.9.2 linked to this thread, and some 0.80.3 there : https://github.com/UnearthedArcana/Faiths_and_Powers/tree/master/faiths_and_powers but dating from 2 months ago and without any recent archive in its releases.
    I guess the safest is to stay with the 0.79.9.2 then... !

  • CahirCahir Member, Moderator, Translator (NDA) Posts: 2,534
    @zelurker

    Here's detailed explanation of Faiths & Powers current versioning. I would suggest going to G3 for further questions regarding Unearthed Arcana mods. Subtledoctor deleted his account here and found his place there.

  • zelurkerzelurker Member Posts: 155
    So this version is what is called the "sd" branch, 0.79.9.2.
    Then the stable is 0.75.
    So the 0.80 found is super unstable then ! :)
    Thanks for the info anyway, the links are easy to find, but the topics are not super active for now...

  • ThacoBellThacoBell Member Posts: 11,901
    Links to subtledoctor's Github: https://github.com/subtledoctor


    And Unearthed Arcana, the modding group he's apart of: https://github.com/UnearthedArcana

  • EndarireEndarire Member Posts: 421
    On the sphere list, the spell should be "Negative Plane Protection" instead of "Plain."

  • ThacoBellThacoBell Member Posts: 11,901
    edited May 28
    This thread isn't supported anymore. If you have bug reports or questions, the new thread is over at G3's forums.

    *edit*

    Well, unless Grammarsalad comes back I suppose. But I haven't seen them around in awhile.

  • GrammarsaladGrammarsalad Member Posts: 2,556
    ThacoBell wrote: »
    This thread isn't supported anymore. If you have bug reports or questions, the new thread is over at G3's forums.

    *edit*

    Well, unless Grammarsalad comes back I suppose. But I haven't seen them around in awhile.

    I'm still here, more or less. Still, it's better to use the g3 thread:

    https://www.gibberlings3.net/forums/topic/30792-unearthed-arcana-presents-faiths-powers-gods-of-the-realms/#comments

    Wise_GrimwaldThacoBell
  • ThacoBellThacoBell Member Posts: 11,901
    @Grammarsalad If I were to desire using longswords as a Shaman multiclass, would I be able to do so with nearinfinity fairly easily?

  • GrammarsaladGrammarsalad Member Posts: 2,556
    ThacoBell wrote: »
    @Grammarsalad If I were to desire using longswords as a Shaman multiclass, would I be able to do so with nearinfinity fairly easily?

    ...I would have to look to see how SD did it (or ask him). It wouldn't be easy with nearinfinity, though. You would almost certainly need to change every longsword in the game. It's much easier with weidu. I'll see what I can do

    ThacoBell
  • ThacoBellThacoBell Member Posts: 11,901
    edited June 2
    Yeah, I uh, discovered that its changed a bit due some prof changes. Scales of Balance may have have altered how they work. Editing weaprof 2DA didn't change anything.

    Post edited by ThacoBell on
  • GrammarsaladGrammarsalad Member Posts: 2,556
    ThacoBell wrote: »
    Yeah, I uh, discovered that its changed a bit due some prof changes. Scales of Balance may have have altered how they work. Editing weaprof 2DA didn't change anything.

    Oh... lol, nothing SD does is simple (but he is extremely efficient). Is it possible to bring this up in the SoB thread on Gibberlings?

    ThacoBell
  • ThacoBellThacoBell Member Posts: 11,901
    I could, yes. I was hoping there'd be a quick edit I could do. In my experience, he doesn't really deviate from what he thinks the kits and classes should be. I remember asking if he could open up bard classes to Half Orcs a few times. I'm still using Near Infinity to swap races out after chargen. :D

Sign In or Register to comment.