Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

SCS with hotfixes - (EDIT: forget hotfixes, use the BWFixPack)

2

Comments

  • RelSundanRelSundan Member Posts: 917
    Skip that component, rest will install fine anyways IIRC

  • PalanthisPalanthis Member Posts: 283
    edited November 2016
    Well it's the first, core component so i guess i can't bypass it. I did try to install it one more time after the first error though, and it could install more files than before.

    The error i got wasn't the same :

    SFO: Cloning SPL file(s) %CLERIC_STORM_OF_VENGEANCE% => dw#vstor
    %WIZARD_INCENDIARY_CLOUD% => dw#trpin
    %WIZARD_METEOR_SWARM% => dw#trpms and applying patch(es)...
    Copying and patching 1 file ...

    ERROR locating resource for 'COPY'
    Resource [%CLERIC_STORM_OF_VENGEANCE%.SPL] not found in KEY file:
    [./chitin.key]
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.

    ERROR Installing [Initialise mod (all other components require this)], rolling back to previous state
    Unable to Unlink [stratagems_external/backup/stratagems/1000/OTHER.1000]: Unix.Unix_error(1, "unlink", "stratagems_external/backup/stratagems/1000/OTHER.1000")
    [stratagems_external/backup/stratagems/1000/UNSETSTR.1000] SET_STRING uninstall info not found
    Will uninstall 32 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 1000.
    Uninstalled 32 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 1000.
    Unable to Unlink [stratagems_external/backup/stratagems/1000/READLN.1000]: Unix.Unix_error(20, "unlink", "stratagems_external/backup/stratagems/1000/READLN.1000")
    Unable to Unlink [stratagems_external/backup/stratagems/1000/READLN.1000.TEXT]: Unix.Unix_error(20, "unlink", "stratagems_external/backup/stratagems/1000/READLN.1000.TEXT")
    ERROR: Failure("resource [%CLERIC_STORM_OF_VENGEANCE%.SPL] not found for 'COPY'")
    Detailed error information can be found in the file SETUP-STRATAGEMS.DEBUG . For help troubleshooting installation problems, go to the Sword Coast Stratagems forum at forums.gibberlings3.net.
    Using Language [English]
    [English] has 1 top-level TRA files
    [stratagems/tra/english/english.tra] has 949 translation strings


    I tried to install this one more time, and couldn't get more files installed. Seems this last error is really fatal...

    Versions 2.0 + of these games are really not ready for SCS.

  • RelSundanRelSundan Member Posts: 917
    edited November 2016
    I did bypass it before. I got a new computer where it worked. However installing that compent, and the after failing skipping it, it did work. My guess is that not all the files would install. It worked for me, try it.

    Re-install the game? Do you have any other mods or anything to lose if you do a clean install? Note that saves are unaffected.

  • PalanthisPalanthis Member Posts: 283
    edited November 2016
    well if i try to install, then skip it on the second time, it says all other components need this core component (which make sense).

    I'll guess i'll try to reinstall everything, as you say. Even though i don't have any other thing installed, so i'm not sure it will change anything.

    Thx for the help anyway.

  • PalanthisPalanthis Member Posts: 283
    edited November 2016
    I reinstalled everything, tried again, same error log. Bypassing it didn't work.

    Seems i can't use SCS on 2.3 EE for now. From what i could see on forums i'm not the only one. It's really a pity Beamdog broke so much one of the best mods.

    I hope Davidw will come back someday...

  • PalanthisPalanthis Member Posts: 283
    edited November 2016
    I decided to give another try by installing, besides my SOD version, BGEE without SOD expansion ( although not recommended on the Beamdog launcher, because BGEE is supposed to be included in SOD, you can install the "BGEE alone" version if you want.)

    Oddly enough, i CAN install SCS with the hotfix on this BGEE version. No error or bug at the moment.

    Since BGEE and BGEE + SOD share the same saves folder location, i guess i could possibly run the entire saga by playing BGEE with SCS, importing the save in the BGEE + SOD component to play SOD without SCS, and then importing this save in BG2EE (i didn't try installing scs on BG2EE for now, but i guess it would work just like it does on BGEE).
    I just hope there won't be any any bugs while transfering the saves.

    I'm not sure what's going on here.
    SOD is supposed to be identical to the "BGEE alone", as far as i know, concerning IA and other stuff that SCS modifies.
    I really don't know why SCS would be working with the BGEE alone version, if it's not working with the SOD version. But it does.
    If someone can find why, it would be nice to have another hotfix for SCS, which could allow us to install it on SOD. Installing the BGEE alone version like i did, is normally NOT necessary (if i didn't need scs) and is just a waste of hard disk space.

    NOTE : this concerns only people who, like me, own the games on the Beamdog launcher (or just purchased them through Beamdog's store).

    brunardo
  • brunardobrunardo Member Posts: 508
    I'll be doing the same set up soon @Palanthis so this is good info and didnt think about BGEE with scs then adding SOD after and using saved game to SOD after like your saying...hope it works

  • PalanthisPalanthis Member Posts: 283
    Note that some people who have bought the games on Beamdog seem to not have any problem installing SCS on SOD. Again, not sure about what's going on !

  • agb1agb1 Member Posts: 249
    edited December 2016
    Duplicate post.

    Post edited by agb1 on
    inethDeltharis
  • Grond0Grond0 Member, Moderator Posts: 4,870
    agb1 said:

    The Big World Fixpack (click here to download) is now all you need for SCS, with or without EET, with or without Spell Revisions:

    @agb1 I tried installing this preparatory to adding SCS to a fresh BGEE installation. However, when clicking on the BiG World Fixpack batch file I just see a command window open for a fraction of a second before closing again without doing anything. I've disabled UAC and virus protection - are you aware of anything else that might cause this problem?

  • agb1agb1 Member Posts: 249
    @Grond0 - Did you put the contents of the "master" folder directly in your game folder? The _ApplyPatches.tp2, weidu.exe and BiG World Fixpack folder must all be in the game directory, not inside a containing folder.

  • chimaerachimaera Member Posts: 801
    @Grond0
    I had that happen when the weidu.exe got overwritten by an older version from another mod.

  • agb1agb1 Member Posts: 249
    There should be an _ApplyPatches.debug file with more info as well.

  • Grond0Grond0 Member, Moderator Posts: 4,870
    agb1 said:

    @Grond0 - Did you put the contents of the "master" folder directly in your game folder? The _ApplyPatches.tp2, weidu.exe and BiG World Fixpack folder must all be in the game directory, not inside a containing folder.

    I did put the contents of the master folder into the Beamdog sub-folder 00766, yes. The debug file shows the following:
    WeiDU v 23700 Log

    weidu --nogame --no-exit-pause --logapp --log _ApplyPatches.debug _ApplyPatches.tp2
    WARNING: parsing log [WeiDU.log]: Sys_error("WeiDU.log: No such file or directory")

    [_ApplyPatches.tp2] PARSE ERROR at line 99 column 24-99
    Near Text: "BiG World Installpack\Big World Smoothpack"
    GLR parse error

    [_ApplyPatches.tp2] ERROR at line 99 column 24-99
    Near Text: "BiG World Installpack\Big World Smoothpack"
    Parsing.Parse_error
    ERROR: parsing [_ApplyPatches.tp2]: Parsing.Parse_error
    ERROR: problem parsing TP file [_ApplyPatches.tp2]: Parsing.Parse_error

    FATAL ERROR: Parsing.Parse_error

    WeiDU Timings
    stuff not covered elsewhere 0.000
    Parsing TP2 files 0.016
    TOTAL 0.016
    chimaera said:

    @Grond0
    I had that happen when the weidu.exe got overwritten by an older version from another mod.

    I had a fresh installation with no mods, so that shouldn't have been an issue. I did though try downloading Weidu v236 again just in case - that made no difference though.

    Thanks both for the help.

  • agb1agb1 Member Posts: 249
    edited December 2016
    Looks like an error in my script -- not accounting for the lack of a weidu.log file. Will fix.

    Oh - that parse error is actually due to using an older version of WeiDU, as chimaera said. DIRECTORY_EXISTS is a newer feature in WeiDU.

  • Grond0Grond0 Member, Moderator Posts: 4,870
    edited December 2016
    Hmm. I tried it last night with both the version of Weidu that came bundled with the Fixpack and with a freshly downloaded version from Weidu.org. Interestingly the download links from that site for Weidu are not working this morning, so perhaps something was wrong with the version downloaded yesterday - I'll look for an alternative source.

    Edit: that looks more promising - the Fixpack appears to run properly now and recognises that Strategems is present in the folder.

    Edit 2: and given that I don't normally expect Carbos to poison his weapon and then disappear into the shadows it would appear that SCS has successfully installed as well :D. Thanks again for the help.

    Post edited by Grond0 on
  • agb1agb1 Member Posts: 249
    www.weidu.org/~thebigg/weidu.exe is the latest.

    Grond0brunardo
  • AstroBryGuyAstroBryGuy Member Posts: 3,414
    edited December 2016
    @agb1 -

    I saw this thread in the Troubleshooting section, and I thought it would be useful for FixPack: https://forums.beamdog.com/discussion/62725/mirror-in-glints-inventory#latest

    It looks like the new SoD joinable NPCs are getting "marker items" from SCS. It's failing to ID them as joinable NPCs. SCS identifies joinable NPCs using the entries in PDIALOG.2DA (the code is in always.tph). For the original NPCs, the entries in PDIALOG.2DA matched the NPCs script names (i.e., death variables). This isn't true for the SoD joinable NPCs.

    Glint's entry in PDIALOG.2DA is "BDGLINT", but his script name is just "GLINT". So, SCS doesn't realize he's a joinable NPC and gives him the marker for some purpose (EDIT: it was the "has potions" marker).

    The file always.tph in SCS needs to have entries for the new SoD joinable NPCs to manually add them to the "/// Array to identify PCs" section (except Corwin).

    After the line,

    SPRINT $script_name_pdialog(~osprey~) ~~

    Insert the following:
    // SoD Joinable NPCs
    SPRINT $script_name_pdialog(~glint~) ~~
    SPRINT $script_name_pdialog(~mkhiin~) ~~
    SPRINT $script_name_pdialog(~voghiln~) ~~

    Post edited by AstroBryGuy on
    JuliusBorisov
  • agb1agb1 Member Posts: 249
    Thanks @AstroBryGuy. This has been added to the BWFixpack.

  • ArunsunArunsun Member Posts: 1,581
    edited December 2016
    It still doesn't work for me when I'm trying it on SoD, I guess these errors:



    Error one:

    ERROR Installing [Initialise mod (all other components require this)], rolling back to previous state
    Unable to Unlink [stratagems_external/backup/stratagems/1000/OTHER.1000]: Unix.Unix_error(1, "unlink", "stratagems_external/backup/stratagems/1000/OTHER.1000")
    [stratagems_external/backup/stratagems/1000/UNSETSTR.1000] SET_STRING uninstall info not found
    Will uninstall 0 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 1000.
    Uninstalled 0 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 1000.
    Unable to Unlink [stratagems_external/backup/stratagems/1000/READLN.1000]: Unix.Unix_error(20, "unlink", "stratagems_external/backup/stratagems/1000/READLN.1000")
    Unable to Unlink [stratagems_external/backup/stratagems/1000/READLN.1000.TEXT]: Unix.Unix_error(20, "unlink", "stratagems_external/backup/stratagems/1000/READLN.1000.TEXT")
    ERROR: Failure("Unknown function: check_ini")
    Detailed error information can be found in the file SETUP-STRATAGEMS.DEBUG . For help troubleshooting installation problems, go to the Sword Coast Stratagems forum at forums.gibberlings3.net.
    Using Language [English]
    [English] has 1 top-level TRA files
    [stratagems/tra/english/english.tra] has 949 translation strings

    Error two:

    ERROR Installing [Initialise mod (all other components require this)], rolling back to previous state
    Unable to Unlink [stratagems_external/backup/stratagems/1000/OTHER.1000]: Unix.Unix_error(1, "unlink", "stratagems_external/backup/stratagems/1000/OTHER.1000")
    [stratagems_external/backup/stratagems/1000/UNSETSTR.1000] SET_STRING uninstall info not found
    Will uninstall 3 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 1000.
    Restoring backed-up [stratagems_external/backup/stratagems/1000/CHITIN.KEY]
    stratagems_external/backup/stratagems/1000/CHITIN.KEY copied to CHITIN.KEY, 776244 bytes
    [.\CHITIN.KEY] loaded, 776244 bytes
    [.\CHITIN.KEY] 95 BIFFs, 55250 resources
    Uninstalled 3 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 1000.
    Unable to Unlink [stratagems_external/backup/stratagems/1000/READLN.1000]: Unix.Unix_error(20, "unlink", "stratagems_external/backup/stratagems/1000/READLN.1000")
    Unable to Unlink [stratagems_external/backup/stratagems/1000/READLN.1000.TEXT]: Unix.Unix_error(20, "unlink", "stratagems_external/backup/stratagems/1000/READLN.1000.TEXT")
    ERROR: Sys_error("stratagems/sfo/general/LIB_ITERATE.TPA.tpa: No such file or directory")
    Detailed error information can be found in the file SETUP-STRATAGEMS.DEBUG . For help troubleshooting installation problems, go to the Sword Coast Stratagems forum at forums.gibberlings3.net.
    Using Language [English]




    Anyone can help me with that?

  • subtledoctorsubtledoctor Member Posts: 10,705
    Sounds like you have some cruft lying around. Make sure your weidu.log does not think any of SCS is installed, then delete all SCS-related folders and files, get a clean copy of SCS v30, then run BWFixPack, thenrun SCS.

  • brunardobrunardo Member Posts: 508
    Hey @Arunsun & @subtledoctor Im having a similar issue above as used BWS and SCS skipped alot of components from Bg1/SOD and saw it was set up under BG2 folder so I downloaded SCS V.30 to that folder 806 but get the initialise error as well...Really just trying to get the improved battles for BG1 but dont want to mess up my BWS modded game which took forever to set up...any help

    [I]nstall, or [N]ot Install or [Q]uit? i

    Installing [Improved Cloakwood Druids] [v30]
    Copying 1 file ...
    Appending to files ...



    Install Component [Improved Bassilus]?
    [I]nstall, or [N]ot Install or [Q]uit? i

    Installing [Improved Bassilus] [v30]
    Copying 1 file ...
    Appending to files ...



    Install Component [Improved Drasus party]?
    [I]nstall, or [N]ot Install or [Q]uit? i

    Installing [Improved Drasus party] [v30]
    Copying 1 file ...
    Appending to files ...



    Install Component [Improved Red Wizards]?
    [I]nstall, or [N]ot Install or [Q]uit? i

    Installing [Improved Red Wizards] [v30]
    Copying 1 file ...
    Appending to files ...



    Install Component [Improved Undercity party]?
    [I]nstall, or [N]ot Install or [Q]uit? i

    Installing [Improved Undercity party] [v30]
    Copying 1 file ...
    Appending to files ...



    Install Component [Tougher chapter-two end battle]?
    [I]nstall, or [N]ot Install or [Q]uit? i

    Installing [Tougher chapter-two end battle] [v30]
    Copying 1 file ...
    Appending to files ...



    Install Component [Tougher chapter-three end battle]?
    [I]nstall, or [N]ot Install or [Q]uit? i

    Installing [Tougher chapter-three end battle] [v30]
    Copying 1 file ...
    Appending to files ...



    Install Component [Tougher chapter-four end battle]?
    [I]nstall, or [N]ot Install or [Q]uit? i

    Installing [Tougher chapter-four end battle] [v30]
    Copying 1 file ...
    Appending to files ...



    Install Component [Tougher chapter-five end battle]?
    [I]nstall, or [N]ot Install or [Q]uit? i

    Installing [Tougher chapter-five end battle] [v30]
    Copying 1 file ...
    Appending to files ...



    Install Component [Improved final battle]?
    [I]nstall, or [N]ot Install or [Q]uit? i

    Installing [Improved final battle] [v30]
    Copying 1 file ...
    Appending to files ...



    Install Component [Improved minor encounters]?
    [I]nstall, or [N]ot Install or [Q]uit? i

    Installing [Improved minor encounters] [v30]
    Copying 1 file ...
    Appending to files ...



    Installing [Main installer] [v30]

    Press ENTER to install your chosen Sword Coast Stratagems components

    (This may take a while)

    Copying and patching 1 file ...



    SUCCESSFULLY INSTALLED Initialise mod (all other components require this)

    SUCCESSFULLY INSTALLED More consistent Breach spell (always affects liches and rakshasas; doesn't penetrate Spell Turning)

    SUCCESSFULLY INSTALLED Initialise AI components (required for all tactical and AI components)

    SUCCESSFULLY INSTALLED Smarter general AI

    SUCCESSFULLY INSTALLED Better calls for help

    SUCCESSFULLY INSTALLED Smarter Mages -> Mages only cast short-duration spells instantly at start of combat if they are created in sight of the PC

    SUCCESSFULLY INSTALLED Smarter Priests -> Priests only cast short-duration spells instantly at start of combat if they are created in sight of the PC

    SUCCESSFULLY INSTALLED Improved Spiders

    SUCCESSFULLY INSTALLED Smarter sirines and dryads

    SUCCESSFULLY INSTALLED Slightly harder carrion crawlers

    SUCCESSFULLY INSTALLED Smarter basilisks

    SUCCESSFULLY INSTALLED Improved doppelgangers

    SUCCESSFULLY INSTALLED Tougher Black Talons and Iron Throne guards

    SUCCESSFULLY INSTALLED Improved deployment for parties of assassins

    SUCCESSFULLY INSTALLED Dark Side-based kobold upgrade

    SUCCESSFULLY INSTALLED Relocated bounty hunters

    SUCCESSFULLY INSTALLED Improved Ulcaster

    SUCCESSFULLY INSTALLED Improved Balduran's Isle

    SUCCESSFULLY INSTALLED Improved Durlag's Tower

    SUCCESSFULLY INSTALLED Improved Demon Cultists

    SUCCESSFULLY INSTALLED Improved Cloakwood Druids

    SUCCESSFULLY INSTALLED Improved Bassilus

    SUCCESSFULLY INSTALLED Improved Drasus party

    SUCCESSFULLY INSTALLED Improved Red Wizards

    SUCCESSFULLY INSTALLED Improved Undercity party

    SUCCESSFULLY INSTALLED Tougher chapter-two end battle

    SUCCESSFULLY INSTALLED Tougher chapter-three end battle

    SUCCESSFULLY INSTALLED Tougher chapter-four end battle

    SUCCESSFULLY INSTALLED Tougher chapter-five end battle

    SUCCESSFULLY INSTALLED Improved final battle

    SUCCESSFULLY INSTALLED Improved minor encounters

    SUCCESSFULLY INSTALLED Main installer
    [setup-stratagems] WeiDU version 24000
    ERROR: Cannot perform auto-update, going ahead anyway!
    Sys_error("setup-stratagems: No such file or directory")
    Using Language [English]

    Using .\lang\en_us\dialog.tlk

    Installing [Initialise mod (all other components require this)] [v30]
    loading 1 tra file
    loading 1 tra file
    Creating 1 directory

    Reading in data: spellcodes

    ERROR Installing [Initialise mod (all other components require this)], rolling back to previous state
    Will uninstall 4 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 1000.
    Uninstalled 4 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 1000.
    ERROR: Not_found
    Detailed error information can be found in the file SETUP-STRATAGEMS.DEBUG . For help troubleshooting installation problems, go to the Sword Coast Stratagems forum at forums.gibberlings3.net.
    Automatically Skipping [Initialise mod (all other components require this)] because of error.
    Using Language [English]

    SKIPPING: [More consistent Breach spell (always affects liches and rakshasas; doesn't penetrate Spell Turning)]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Initialise AI components (required for all tactical and AI components)]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Smarter general AI]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Better calls for help]
    This component requires the core "initialise" component to be installed
    Skipping [Smarter Mages -> Mages only cast short-duration spells instantly at start of combat if they are created in sight of the PC] because it fails its requirements.
    Skipping [Smarter Priests -> Priests only cast short-duration spells instantly at start of combat if they are created in sight of the PC] because it fails its requirements.

    SKIPPING: [Improved Spiders]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Smarter sirines and dryads]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Slightly harder carrion crawlers]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Smarter basilisks]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Improved doppelgangers]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Tougher Black Talons and Iron Throne guards]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Improved deployment for parties of assassins]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Dark Side-based kobold upgrade]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Relocated bounty hunters]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Improved Ulcaster]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Improved Balduran's Isle]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Improved Durlag's Tower]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Improved Demon Cultists]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Improved Cloakwood Druids]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Improved Bassilus]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Improved Drasus party]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Improved Red Wizards]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Improved Undercity party]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Tougher chapter-two end battle]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Tougher chapter-three end battle]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Tougher chapter-four end battle]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Tougher chapter-five end battle]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Improved final battle]
    This component requires the core "initialise" component to be installed

    SKIPPING: [Improved minor encounters]
    This component requires the core "initialise" component to be installed

    NOT INSTALLED DUE TO ERRORS Initialise mod (all other components require this)

    Press ENTER to exit.

  • AerakarAerakar Member Posts: 644
    @brunardo did you ever figure this out? I just did a clean install of SCS with the hotfixes in BG2EE and am able to install everything but the first component (core component initialize).

    All the other components installed fine, even without the first core component.

  • AerakarAerakar Member Posts: 644
    Aerakar said:

    @brunardo did you ever figure this out? I just did a clean install of SCS with the hotfixes in BG2EE and am able to install everything but the first component (core component initialize).

    All the other components installed fine, even without the first core component.

    In the end installation worked by breaking it into pieces, i.e. first initialize mod and AI enhancements, later all of the other components except spell tweaks, and finally spell tweaks by itself. @subtledoctor suggested this approach earlier in this thread also.

    Not sure why installing by sections worked. It would be great to see SCS31 come out after 2.5!

  • subtledoctorsubtledoctor Member Posts: 10,705
    Apparently the Detectable Spells library breaks a couple things on 2.5. Lots of mods use DS, some if which are not actively maintained (like SCS). Wisp is updating the version bundled with Rogue Rebalancing, hopefully someone will be able to fo the same at G3 for SCS. Or maybe kreso can update his version of 'Revised SCS.'

    It will take time to figure things out.

    Aerakar
  • argent77argent77 Member Posts: 2,697
    edited May 2018
    For anyone having trouble with "out of memory" errors while installing SCS, the recently released WeiDU 245 comes with native 64-bit binaries for both Windows and macOS, which should prevent these errors from triggering.

    Luke93Aerakar
  • MacilrilleMacilrille Member Posts: 6
    I get this message

    This component requires the core "initialise AI" component to be installed

    Any advice?

  • ALIENALIEN Member Posts: 781
    @Macilrille Forget about this topic, cet the last release from here https://github.com/Gibberlings3/SwordCoastStratagems/releases and reinstall mod.

    subtledoctor
  • ALIENALIEN Member Posts: 781
    @subtledoctor SCS doesn't really need BWFixpack anymore, can you edit this post?

Sign In or Register to comment.