Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[MOD] Lefreut's enhanced UI (for BG1EE, SoD, BG2EE and EET)

11213141517

Comments

  • AlonsoAlonso Member Posts: 608
    lefreut wrote: »
    @Alonso on the right it's only the dexterity modifier.

    What would be the purpose of listing the Dexterity modifier there? At first sight it seems that it belongs in Combat stats or a similar section.

  • lefreutlefreut Member Posts: 1,360
    @Mr_Salty you need to install SCS after LeUI to see the changes made by SCS to the UI.

    @Alonso it has always been there and I don't see where else to put it. The only differences with my mod and the defaults UI (vanilla, 1.3 or 2.5) is that the category is called Abilities instead of Ability Bonus. I only notice this today, I can check if I can change it.

    Alonso
  • Mr_SaltyMr_Salty Member Posts: 187
    lefreut wrote: »
    @Mr_Salty you need to install SCS after LeUI to see the changes made by SCS to the UI.

    @lefreut

    when i install SCS after LeUI i get this (Note that i only tried installing the AI part of the SCS since i know the error is there
    ERROR: error loading [stratagems/caster_shared/resource/bg2_button_resized.bam]
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.

    ERROR Installing [Initialise AI components (required for all tactical and AI components)], rolling back to previous state
    Will uninstall 3324 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 5900.
    Uninstalled 3324 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 5900.
    ERROR: Unix.Unix_error(20, "stat", "stratagems/caster_shared/resource/bg2_button_resized.bam")
    Please make a backup of the file: SETUP-STRATAGEMS.DEBUG and look for support at: For help troubleshooting installation problems, go to the Sword Coast Stratagems forum at forums.gibberlings3.net.
    Using Language [English]

    Install Component [Initialise AI components (required for all tactical and AI components)]?
    nstall, or [N]ot Install or [Q]uit?

    Without the AI components i dont get that fine tune button

  • AmmarAmmar Member Posts: 795
    Mr_Salty wrote: »
    lefreut wrote: »
    @Mr_Salty you need to install SCS after LeUI to see the changes made by SCS to the UI.

    @lefreut

    when i install SCS after LeUI i get this (Note that i only tried installing the AI part of the SCS since i know the error is there
    ERROR: error loading [stratagems/caster_shared/resource/bg2_button_resized.bam]
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.

    ERROR Installing [Initialise AI components (required for all tactical and AI components)], rolling back to previous state
    Will uninstall 3324 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 5900.
    Uninstalled 3324 files for [STRATAGEMS/SETUP-STRATAGEMS.TP2] component 5900.
    ERROR: Unix.Unix_error(20, "stat", "stratagems/caster_shared/resource/bg2_button_resized.bam")
    Please make a backup of the file: SETUP-STRATAGEMS.DEBUG and look for support at: For help troubleshooting installation problems, go to the Sword Coast Stratagems forum at forums.gibberlings3.net.
    Using Language [English]

    Install Component [Initialise AI components (required for all tactical and AI components)]?
    nstall, or [N]ot Install or [Q]uit?

    Without the AI components i dont get that fine tune button

    Yes, with RC10 I have the same problem (so I am still using RC9). This has already been reported by two other people on the SCS forum, but @DavidW has not gotten around to fix it yet. So we need to either use an older version or be patient for a while longer.

  • AlonsoAlonso Member Posts: 608
    lefreut wrote: »
    @Alonso it has always been there and I don't see where else to put it. The only differences with my mod and the defaults UI (vanilla, 1.3 or 2.5) is that the category is called Abilities instead of Ability Bonus. I only notice this today, I can check if I can change it.
    OK, I get it. But I agree that a more descriptive title would be helpful.

  • AmmarAmmar Member Posts: 795
    @lefreut
    You asked on the SCS forum about the issue with having to scroll up to see the dialogue.

    I have that issue from time to time; it occurs sometimes after playing a bit and goes back when I quick-load. What happens is that the new dialogue starts a bit above the window, e.g. I have to scroll up to see the first few sentences. The bottom half and the response options are usually still visible.

    As said, this goes not happen right away, only after playing for some time. Once the issue is there, it persists until I reload. With quick save & quick load hot keys this makes it a very minor issue.

    I wasn't able to find out what triggers it exactly. When I play on I will try to check what happened before the issue started. It might have been preceded by some blank lines in the dialogue window.

  • d2freakd2freak Member Posts: 16
    edited March 22
    @lefreut

    I think on EET the spellbook UI changes you have created are not visible. It looks like vanilla bg2ee.

    I tried on normal bg2ee and your changes show up so it's something to do with an EET installation.


    I was mistaken.

    Post edited by d2freak on
  • HubalHubal Member Posts: 25
    edited March 16
    @lefreut Mine problem is exactly the same as Ammar 's but it does not go away so easily and every dialogue is affected. I wish I could give you more details. I took your advice, I am the guy from gibberlings forum.
    After reading couple pages it seems MedianAura has the same problem.
    Changing Font Size in game options to far left side looks to work ok though.

    Post edited by Hubal on
  • AlonsoAlonso Member Posts: 608
    I just installed several components of this mod using EE UI Tweaks, and the scrollbars look quite funny:
    t90mlejkjcvu.png
    ngg0ihq7ca8c.png

  • lefreutlefreut Member Posts: 1,360
    @Alonso it's a regression from patch 2.5. But I have updated EEUITweaks to workaround this, which version do you use?

  • AlonsoAlonso Member Posts: 608
    Version 2.6, according to installation.txt. The one linked in the EE UI Tweaks thread. Is there another version?

  • lefreutlefreut Member Posts: 1,360
    Latest version is 3.0 (and soon 3.1 as the next version is almost ready). The newest versions can be found here.

    Alonso
  • DavidWDavidW Member Posts: 574
    That install bug is on the SCS end, and easily fixed (I just haven’t had a chance yet).

    lefreut
  • AlonsoAlonso Member Posts: 608
    Looking great now. Thanks!

  • kungfuhobbitkungfuhobbit Member Posts: 132
    edited April 7
    lefreut wrote: »
    @Mr_Salty you need to install SCS after LeUI to see the changes made by SCS to the UI.

    On EET manual install is the order Lefreut UI then SCS then "eet end" and can eet's own component for "eet gui" be omitted?

  • kevin36kevin36 Member Posts: 3
    Hello, I do use your mod but, everytime npc talks in some actions the dialogue gets doubled in journal. On a journal without that mod it doesn't happen but with this mod it does. Can you do anything about it or is there any fixes? Thanks and for sorry for english.

    2pbg6msh9lyo.png

  • AlonsoAlonso Member Posts: 608
    I've found a minor glitch with the item comparisons. When you compare ranged weapons and have magical ammunition equipped the values displayed are incorrect. For example, I have a sling +3 equipped and bullets +2 selected. When I pick a sling +4 to compare their stats, the values displayed in the comparison are THAC0 +1, damage -1. If I do the same comparison but with normal bullets selected, the values displayed are correct (THAC0 -1, damage +1). It looks like this happens with all the ranged weapons that use ammunition.

  • kjeronkjeron Member Posts: 1,834
    @Alonso when you pick up a launcher (bow/xbow/sling) it's comparison values will always use the first viable ammo slot, not the currently selected ammo slot, because equipping the launcher will automatically switch to the first viable ammo slot.

    Alonso
  • AlonsoAlonso Member Posts: 608
    Yep, you're right. The glitch does not depend on the type of ammunition selected, it depends on the quiver slot selected.

  • lefreutlefreut Member Posts: 1,360
    It's the engine that does the item comparisons, I only display the information. I don't think I can choose which ammo slot to use.

    It makes more sense to use the currently selected slot instead of the first one so I guess I could open a bug report about this, but I don't know if I will spend the time to do it as I already have so many tickets opened that will probably never be looked at.

    Alonso
  • AlonsoAlonso Member Posts: 608
    I hear you. I myself have some tickets I opened three years ago and their state is still "Submitted". Thank you for clarifying that, anyway.

  • lefreutlefreut Member Posts: 1,360
    kevin36 wrote: »
    Hello, I do use your mod but, everytime npc talks in some actions the dialogue gets doubled in journal. On a journal without that mod it doesn't happen but with this mod it does. Can you do anything about it or is there any fixes? Thanks and for sorry for english.

    2pbg6msh9lyo.png

    @kevin36 I have never encounter this problem. I tried with the same event as your screenshot and I get only one entry in the journal.

  • HaHaCharadeHaHaCharade Member Posts: 1,524
    edited April 29
  • HaHaCharadeHaHaCharade Member Posts: 1,524
    Can someone click Baeloth's ring (the one that can't be removed) and see if they get an "Invalid: 70122" error? I want to see if its the UI before reporting as a bug, and I'm too lazy to uninstall the UI and reinstall it right now :)

  • lefreutlefreut Member Posts: 1,360
    @HaHaCharade it's 36946. It happens when you have BG1EE but not SoD.

    HaHaCharade
  • HaHaCharadeHaHaCharade Member Posts: 1,524
    lefreut wrote: »
    @HaHaCharade it's 36946. It happens when you have BG1EE but not SoD.

    Thanks!

  • AlonsoAlonso Member Posts: 608
    lefreut wrote: »
    v3.9 is out \o/
    Is EEUITweaks already updated with this new version?

  • kungfuhobbitkungfuhobbit Member Posts: 132
    What do I modify to change the colour of screen headers please?
    eg 'Journal' currently in yellow/gold
    2pbg6msh9lyo.png

Sign In or Register to comment.