Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Aielund Saga Enhanced Edition

145791013

Comments

  • Savant1974Savant1974 Member Posts: 225
  • echooechoo Member Posts: 14
    edited February 2018
    Any tips on how to get Alternate Combat Animations and Customize Character Override running in Aielund? It works in other mods without issue using my patchhak / overrides. x0_skill_ctrap seems to be vanilla in Part IV, so I'm unsure as to why it's not working...

    Post edited by echoo on
  • shadguyshadguy Member Posts: 143

    I've found a couple of problems. First, when casting spell breaches I get these error messages and apparently no effect on the target:

    Script NW_S0_LsSpBrch, OID: ffffffff, Tag: ERROR: TOO MANY INSTRUCTIONS

    Script NW_S0_GrSpBrch, OID:80004e38, Tag: GypsySorceress, ERROR: TOO MANY INSTRUCTIONS.

    Script NW_S0_MordDisj, OID: ffffffff, Tag: ERROR: TOO MANY INSTRUCTIONS

    Have you tried tweaking these Enhanced Edition settings in your .ini files?

    New nwnplayer.ini Options

    Specifies the maximum number of scripting instructions available to run within a given script before the script is assumed to be in an infinite loop and terminated (was 131042 in NWN 1.69, minimum = 131042, maximum = 16777216)

    [Script Options]
    Instruction Limit=524288
    Source of info: https://www.beamdog.com/files/nwnee_release_notes.pdf

    -Dave

    voidofopinion
  • Savant1974Savant1974 Member Posts: 225
    @echoo I've tried getting those working with the series but that convo does appear to be getting in the way. I didn't realise I'd missed act 4 with the crafting script update, I'll fix that but yeah, it's very difficult to integrate the crafting scripts.

  • CometchaserCometchaser Member Posts: 3
    I've heard great things about the Aielund Saga, so I wanted to give it a try for myself!

    However, I am having an issue with parts of the armors being missing. The starting traveller's gear is missing the arms, and some of the other clothes in the starting armoire are missing pieces as well. I would assume this means I have installed something incorrectly or I am missing a file. I have installed CEP v2.63, the Aielund Hakpak, as well as all the other required files listed in the neverwinter vault download page. I've even tried reinstalling a fresh copy of NWN and reinstalling Aielund, CEP, and all the required files and still get the same issue. I have also tried downgrading to previous versions of CEP 2.6 (I've tried 2.62 and 2.60).

    I'm on NWN Diamond Edition from GOG.

    Here are screenshots of what I'm talking about: https://imgur.com/a/qn3Ds

    Can anyone offer any advice?

  • arQonarQon Member Posts: 6
    @thucydides_jones

    those TMIs are surprising - those spells do have to do a lot of work, but mork (which does far more than the other two) actually splits the load across multiple invocations of the script engine already. the amount of work basically comes down to how many creatures there are and how many spell buffs they have, but breaches are single-target and i don't see how it would be possible for those to EVER overflow. (especially since they'll stop after n buffs anyway).

    also, given the "OID -1", it looks like Something Else is going on, since it should be running on the PC.

    a few things to try, though they're all a stretch:
    * re-download the HAK, in case it's damaged in some way.
    * go into Debug Mode (~, DebugMode 1), hit ~ again, and type "dm_modulevarint EMS_BREACH_LISTSize". (case is important). it should be 46.

  • arQonarQon Member Posts: 6
    Andarian said:


    I don't know why, but I have observed that encounter triggers will sometimes disregard their own rules like this. I've been burned by it enough to stop trusting that I can rely on the kind of thing you're describing: an encounter with two unique spawns and a minimum of two creating one of each creature. I try to use a trigger script with explicit creature creation calls when I need to be sure a specific mix of creatures results.

    this is unfortunately correct. the "unique" checkbox flat out doesn't work ( pretty much "ever" on linux servers, though it's puzzlingly much more likely to on win32 ones) - you need separate encounters at 1 char each if you want it to be reliable.

    Savant1974Andarian
  • Savant1974Savant1974 Member Posts: 225
    Hi arQon! Hope you're doing well. Thanks for pointing out how broken the encounter trigger is, I'll replace it with 2 separate triggers.

    @Cometchaser That is just bizarre. Diamond is notorious for random issues but I've never seen that one before. That starting costume is a robe, so it's a one-piece skin - to see it missing arms is weird! I'm using CEP 2.62 at the moment, but if that's not helping either I have no choice but to chalk it up to Diamond :neutral:

  • DwayneDwayne Member Posts: 62
    I have seen the missing parts bug many times in many modules for NWN. It seems to only happen when a module uses a hak and you load a save game while you are already playing. It never happens when you first load a save just when you reload a save. The only fix I have seen is to shut NWN down and then start again. That seems to fix it. I don't think it has anything to do with The Aielund Saga. Just a NWN problem with hak files.

    Savant1974
  • Sylvus_MoonbowSylvus_Moonbow Member Posts: 982
    That issue has nothing to do with improper hak order but your NVidia driver. The last screen you posted the character is wearing a robe and there are posts on the neverwinter vault site discussing this. 390.77 is the latest driver that fixed this.

    AndarianZwerkules
  • ronaldoronaldo Member Posts: 246
    Hi @Savant1974 found a very minor item during my current playthrough.
    In the elven city the palace is labeled as the smithy and the smithy isn't labeled at all.
    Really enjoying my time in Aielund!

  • Savant1974Savant1974 Member Posts: 225
    Oops, thanks I'll fix that for the next update!

    ronaldo
  • HeathenbotHeathenbot Member Posts: 5
    I've been running into a very frustrating problem. I recently started playing through Aielund on the NWNEE, and I got to act four part two and can't progress. Half of the time the module crashes when I try to load into it, and when I do load in I can't get the commander's tent transition to work, so I am still stuck. Has anyone run into this problem before, or know a work around?

  • Savant1974Savant1974 Member Posts: 225
    That's a new one. Working here at my end - are you on a Mac?

  • Savant1974Savant1974 Member Posts: 225
    Me too. I have no idea why that mod isn't working for you :neutral:

  • ronaldoronaldo Member Posts: 246
    @Savant1974 I am having an issue with the quest "The Count's Lost Love" I cant find this secret door that Saffron mentions. She says it's in her bedroom. Is that the bedroom in the fort? There doesn't seem to be a bedroom in the house you talk to her in. All I can find there is a basement with a door I can't get through. I searched all around the bedrooms in the fort and didn't find anything either. Can you point me in the right direction?

  • Savant1974Savant1974 Member Posts: 225
    You might need to turn on your search mode to spot it, it's definitely in the same building as her. :wink:

    Notabarbiegirl
  • ronaldoronaldo Member Posts: 246
    edited February 2018
    Never mind just found it

  • Savant1974Savant1974 Member Posts: 225
    edited February 2018
    How do you do the spoiler text? Never mind, found it :smile:

  • ronaldoronaldo Member Posts: 246
    The very minute after I posted that I found it. I think what threw me off is that she says the secret door is in her bedroom. I was searching for a bedroom to search in.

    Savant1974
  • Savant1974Savant1974 Member Posts: 225
    edited February 2018
    On the lower level of her house (she sleeps downstairs as shes a vampire) on the north wall. You might need to walk around a bit to make it check more often.


    Ah, problem solved :)

    ronaldoNotabarbiegirl
  • HeathenbotHeathenbot Member Posts: 5
    Yeah, when I try to load it half of the time it gives me an error that says 'Module could not be loaded, module file may be corrupt'. I downloaded it from the vault again, but no dice. I can't figure out what would be causing this unless the file itself got messed up somehow.

  • Savant1974Savant1974 Member Posts: 225
    I just downloaded act 4 pt 2 from the vault to make sure, and it all appears to be working. It's got me stumped :neutral:

  • HunterRayder93HunterRayder93 Member Posts: 265

    Yeah, when I try to load it half of the time it gives me an error that says 'Module could not be loaded, module file may be corrupt'. I downloaded it from the vault again, but no dice. I can't figure out what would be causing this unless the file itself got messed up somehow.

    Do you have any antivirus activated by chance? usually the problem is linked and maybe it revealed something unusual and then blocked you files.

  • echooechoo Member Posts: 14
    edited February 2018
    I just finished Aielund EE today. Wow, that last part was a doozy! Thanks for such a great series @Savant1974

    Just as a note: the mountain snow tileset seems to cause an infinite load screen / missing doors in my EE install. Was able to navigate around them using console commands, or just skipping the areas outright (all of the Twilight areas in pt. 3). My guess is that my patch hak was breaking things.

  • Savant1974Savant1974 Member Posts: 225
    Glad you enjoyed it! You had a patch hak of your own? Of course that would break things :smiley:

    Andarian
  • ronaldoronaldo Member Posts: 246
    @Savant1974 I need some help. I can't get through the siege. My druid eventually runs out of spells and I don't have a weapon that can hurt the golems. After my spells run out all I can do is stand there and watch my guys get slaughtered. I turned the game down to easy and I'm still being slaughtered. To add to the grief somehow I lost Robert and Criossa along the way. They just disappeared. I think they got left behind on a map somehow and when I try to go back to get them I cant get past the golems in the other maps.
    It's frustrating that I have gotten this far and am hitting a wall.
    I have an earlier save but its way back.

    Any help or hints?

  • Savant1974Savant1974 Member Posts: 225
    If you've lost both companions you're still playing it on hard mode! If you tried holding back the golems at the bridge it's quite possible they were both killed there. If you don't have a weapon capable of hurting them by now, you've missed a LOT. I'm guessing you gave the good stuff to Robert and now he's missing. Sounds like a lost cause, you might have to go back to that last save, make sure you've got the best weapon you can use, give Robert decent gear and make sure they're with you at the end. Either that or turn on God Mode ;)

  • ronaldoronaldo Member Posts: 246
    Yeah that's what I figured. The problem is as a druid my weapon selection is limited. I'm using a sling and I can't get through the golem damage resistance. I'll go back to the earlier save because I am also in a romance with Robert and want to see how it ends.

145791013
Sign In or Register to comment.