Skip to content

Android 12 Save files location and access


I can't locate the save files on my phone. I know that the save files are supposed to be in Android/data/com.beamdog.baldursgateenhancededition/files/save. But when I open the com.beamdog.baldursgateenhancededition folder its empty. I tried using the default file explorer, Total Commander, X-plore and Solid explorer and still nothing ( I have given all the required permissions). I also tried to access them with a PC when I connected the phone via USB and still the same, the folder is empty ( I have set hidden folders to be visible). I searched the issue online the for the past week with no solution found. The issue seems to be only in Android 11 and 12. Something to do with said files being accessible only to the game and not to the user. Seems to be kinda common but a bit weird because there seems to be people on android 11 with no issue at all.

This is kinda big deal for me because I want to transfer the saves from phone to pc and vice versa.

If it matters my phone is the Samsung S22 ultra running Android 12.

Thanks allot :smile::smiley:


  • Bruce_VenneBruce_Venne Member, Moderator, Developer Posts: 4

    Unfortunately, I have been unable to reproduce the issue on my device. But it a different device than yours, so I looked into if the Samsung S22 Ultra and there are reports of the same issue with other apps. Here's a link:

    I also found a thread suggesting other file mangers that have helped.

    I hope this helps.
  • b0b3rmanb0b3rman Member Posts: 2
    Thank a ton for the reply.

    Well it seems it's an issue with samsung devices maybe after the S21 line. No luck with a solution though :'( .

    Thanks again though for the detailed reply! :)
  • nenjihnenjih Member Posts: 1
    I have the same problem with s22 ultra. Basically, I can't access anything in the android/data/com.beamdog.baldursgateenhancededition folder (same for SOD and BGII). So I can't transfer saves between phone and PC or to a new phone if I upgrade down the track. Also means I can't add edited files into the override subfolder. It really sucks.
  • BlueLagoonBlueLagoon Member Posts: 2
    S21 and I have that too. I would like to enable the debug console or use mods but no read or write access to com.beamdog folders inside. However nwn ee will show files in the data folder, but no read or write to just the user folder where save data or modules go. Bg1,2, Sod, and iwd all do it to me.
  • CazaboCazabo Member Posts: 1
    edited July 2022
    Post edited by Cazabo on
  • tdkjessetdkjesse Member Posts: 2
    This is demonstrably a problem with Beamdog specifically, and it is unacceptable how long this has gone unaddressed!

    Your common practice is to point to years old articles about how file managers can solve the issue. Well, newsflash, there's a whole new issue since then.

    You could easily recognize this at any point by using a file manager yourselves. Navigate to Android/data. Try to access Beamdog folders. You'll be denied or see nothing. Then try to access ANY other data folder. Let's use MTG:A for example. Hey, there's all my files...

    If this was an Android problem, then ALL folders in Android/data would have the same problem.

    For record I am using a Pixel 6 Pro.
  • deedrewdeedrew Member Posts: 1
    I nave the same problem with a Lenovo tablet with Android 12. I'm able to read/write Android/data folder and subfolders, but as soon as I start one of the Baldur's Gate saga games the relevant folder becomes likes empty and I loose the possibility to write into It. Quite annoying as I would like to import saves from another older Android tablet.
  • ReavesReaves Member Posts: 3
    edited November 2022
    It's crazy that this still isn't fixed. Come on beamdog. At least give us the export save function like IOS has!!
  • cloudsatcloudsat Member Posts: 25
    I reported the same issue a few months before in another post. But I am using a Samsung so not stock Android 12. If Pixel is having the same problem, it's more likely a beamdog issue. Now, there is no way to get saves from my old device or use any mods at all.
  • hkanshkans Member Posts: 6
    Same issue on a Samsung Galaxy Fold 4. An export/import character file function that doesn't use the Android/data folder would be great!!!
  • leviathanjonleviathanjon Member Posts: 2
    Beamdog come on you guys should fix this. Its just annoying that the problem is obvious and affects everyone playing your games yet there is no acknowledging the problem or saying you will fix it. Come on you are better than this :(
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 22,712
    The studio is closed for the holidays, so you won’t hear much from the team until January.
  • FalconXC4FalconXC4 Member Posts: 7
    Hi, same problem for me on a blackview tab 15 with Android 12. Please do something...
  • JingizuJingizu Member Posts: 6
    Some months ago i could copy and use saved files in android (android 11) but now my data file appears empty, something has changed....
  • PyrotechnicalPyrotechnical Member Posts: 4
    edited January 2023
    We're up to Android 13 and this appears to be a problem across many devices at this point. This has been reported for the better part of a year, and the official response has consistently been to ignore/deny it and point to years-old threads about file managers.

    I've been unable to move my save to my new device for nearly a year now. I previously was able to access the data/com.beamdog.X/ folder and do this.

    Not super confident that Beamdog is actually interested in fixing this pretty major issue.
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 22,712
    We want to fix this issue and we're sorry it's taking so long. The long acquisition process in 2022, multiple projects we have to support at the same time & limited resources/staff, and the lack of in-house mobile developers led to numerous delays.
  • PyrotechnicalPyrotechnical Member Posts: 4
    edited January 2023
    Thank you for your response. I'm glad Beamdog is aware of the issue.

    Here are a few examples of the same issue dating back into 2021:

    It appears that beginning with Android 11, Google has taken steps to lock down access to files in the data folders. However there are a number of workarounds and file managers that can overcome those limitations. In some cases and for many programs besides bg1/2/
    SoD, users are still able to access the subfolders of sdcard/data/com.XXX/. I have been able to use file managers, ADB (console via pc), etc to access data folders, subfolders and files of many other programs on my phone.

    However it would appear that specifically in the case of BG1, SoD and BG2 this access has been completely cut off to users. I haven't tried with other beamdog games.

    This appears to be so absolute that even using ADB to attempt to directly push folders and files to the appropriate directories is impossible. It specifically results in being notified that I do not have permission to push files to pretty much any beamdog subfolder. The only way around this that I am aware of would be to root my phone, which would void my warranty. I am not very knowledgeable technically so this is about as far as I can go. If anyone knowledgeable about android wants to correct me I'd definitely appreciate it as I'm sure I'm getting some things wrong here!

    As transferring saves, modding and generally messing around with the game is a pretty core component of many fans' experiences, the prospect of being specifically locked out of these features potentially permanently is quite frustrating.

    I'm glad Beamdog is aware of these restrictions and I am hopeful that we will have a fix in the future.
    Post edited by Pyrotechnical on
  • SevreiSevrei Member Posts: 6
    I returned to these boards hoping to install NPC project on my Android 11 S20FE but it sounds like I may be out of luck.

    I do still have an S2 tablet on Android 7 so at least I can try to get mods setup on this hopefully.
  • SeiSei Member Posts: 18

    Any news on this front?
    If I could, Id buy a tablet specifically for this, it's just that not that many android tablets with Android 9 or below are on the market, there's risk of auto-update at launch and tablets with Windows are quite pricey.

    Please help us.
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 22,712
    There is still a plan to release an update. A new hire, a legacy programmer, starts this month.
  • FalconXC4FalconXC4 Member Posts: 7
    Good to know! We are looking forward for this update.
  • UlfgharUlfghar Member Posts: 2
    I have the same issue on my Galaxy tab A8 with Android 12.
    Good to hear that you are planning on fixing it.
    But I'm a little impatient, so I'm wondering if it would help to root the device...?
  • UlfgharUlfghar Member Posts: 2
    I'll answer myself then.
    I learned that rooting could wipe all data from the tablet, so my saves might be lost anyway...
    Maybe if I had done it before starting BG1...

    So I resigned and decided to go through BG2 with my longsword wielding fighter.
    Without magically changing grand mastery to warhammers...😳🙄

    But when I tried importing an old SoD save or my exported character, BG2 SoA crashes...

    If I choose "single player" -> "import game"
    It shows the import screen for a few seconds (without anything to import) and then crashes.

    Same thing if I choose "single player" -> "new game" -> "import" -> "saved game"

    Sometimes it crashes immediately, without showing the import screen.

    And If I choose "single player" -> "new game" -> "import" -> "character file"
    I can only see the default pregenerated characters.
    And not the character I exported from SoD.

    Sorry if this ended up in the wrong place,
    I thought that it might be related to the accessibility issue...
    (With BG2 SoA not having access to BG1 or BG SoD save folders...?)
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 22,712
    Thanks for sharing your frustrating experience.
  • ryancryanc Member Posts: 7
    please give us the opportunity to open the console on android or allow us to take our save files to a computer to be edited and then added back to our devices. this is honestly quite frustrating I am very upset that we cannot have access to our saves or the debug menu. please fix this.
  • ryancryanc Member Posts: 7
    really hoping that we get an update on having the ability to access the debug menu on the new android version. please and thank you
  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 22,712
    This will take more time, but we'll do it. Sorry that you have to wait longer.
  • DeathOfNamesDeathOfNames Member Posts: 40
    So... it's been a year since this was pointed out and you don't have any kind of ETA?

    This isn't a request for a massive new feature, but a bug that prevents all modding of the game, which as pointed out earlier, is an expected part of the experience for anyone even a little familiar with Infinity Engine gaming.

  • JoshXJoshX Member Posts: 1
    edited July 2023
    Hey everybody! I just finished BG1 on Android and wanted to see if there's been any progress on this? I would love to be able to continue on PC!

    EDIT: Also, thanks Julius for your help so far with this issue!
  • sincerossinceros Member, Mobile Tester Posts: 6
    Are there any updates on this? Just got a new Pixel Tablet and want to complete a series run.
Sign In or Register to comment.