Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

EE Keeper, Updated to v1.0.4

1313234363766

Comments

  • JokkersJokkers Member Posts: 2
    Hey there! i dont know if this is the right place to ask but correct me if im wrong

    Ive played for acouple of hours now with icewind dale enhanced and come to the conclusion that my Druid shapeshifter is boring as all hell. And now i want to use the EEkeeper to change his druid kit to standard druid. Is there an easy way to create a new character using the EEkeeper and have it lvl up to the apropiate level ingame or to easly modify my current character to change his kit.

    Ive found that i can change his Kit to Base class but that dosent change his kit spells. i know how to remove his kit spells "shapeshift warewolf" but i have no idea how i find / add his normal Druid kit spells.

  • SgthawkerSgthawker Member Posts: 31
    AJokkers You can use EEKeeper to reset his level to 1, and with the same experience points, this will allow you to level up to current level while selecting the spells and abilities as usual.

  • PythonerPythoner Member Posts: 4
    Troodon80 said:

    @Pythoner, I did try it myself. I'm getting a crash when trying to load the game on either Android or Windows. DLTCEP also doesn't want to open it, and neither does NearInfinity.

    Right you are Troodon. Turns out that when I connected my tablet to my PC; the save files aren't at their proper lengths in the file system, and don't copy fully.
    I solved the issue by uploading the save files to my Google Drive from the tablet's file manager app, and then opening them up in EE Keeper on the PC. Worked just fine! Thanks for your help.

    Troodon80jackjack
  • filpanfilpan Member Posts: 31
    I'm using the latest Keeper version for IWD EE. Now, the only thing I need this editor for is for more spell slots for my mage. But it looks like I can't edit "Type" field under Effects tab. In the older version (I played BGII with it) there was "Affects" tab not "Effects" tab. Now there is no "Spell Memorization Mage" in "Type" field under "Effects" tab and I can't edit it like in BGII. So, is there a way to edit this or it doesnt work for IWD EE? I know that i can choose as much spell slots as i want under "Memorisation" tab but I have to do that every time I level up. So is there a way to permanently increase number of spell slots in IWD EE?
    Thanks a lot for understanding and keep playing these best RPGs ever.

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    @filpan,

    Since I implemented elements in the GUI to display the better described IESDP DAT files, Wizards use "Spell: Wizard Spell Slots Modifier [42]" and Priests use "Spell: Priest Spell Slots Modifier [62]".

  • filpanfilpan Member Posts: 31
    edited November 2014
    I'm sorry i dont understand you. Where do I go to add the number of desired spell slots?

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    @filpan,

    Similar to the original method: Go to the Effects tab and press Add. In EE Keeper, next to Type, select "Spell: Wizard Spell Slots Modifier [42]" from the list.

    image

    Enter the desired level and the number by which you want to increase by.

    jackjack
  • filpanfilpan Member Posts: 31
    edited November 2014
    I found the problem. It wasnt in the directory with that .dat file, thats shy i didnt have anything under Type tab, only 0x000. Thank you a lot!

    Troodon80
  • KingHiram33KingHiram33 Member Posts: 3
    I need some help. Everything is properly configured in my version of EE Keeper(v.1.0.2.6), or so I believe, but the save files refuse to show up in the Open Saved Game window.

    Installation path is
    >C:\Program Files\Steam\steamapps\common\Baldur's Gate Enhanced Edition\

    Language is set to English

    Save Data Directory is
    >C:\Users\Robert\Documents\Baldur's Gate - Enhanced Edition\save\

    These are the proper configurations, are they not?

  • AstroBryGuyAstroBryGuy Member Posts: 3,414

    I need some help. Everything is properly configured in my version of EE Keeper(v.1.0.2.6), or so I believe, but the save files refuse to show up in the Open Saved Game window.

    Installation path is
    >C:\Program Files\Steam\steamapps\common\Baldur's Gate Enhanced Edition\

    Language is set to English

    Save Data Directory is
    >C:\Users\Robert\Documents\Baldur's Gate - Enhanced Edition\save\

    These are the proper configurations, are they not?

    Try >C:\Users\Robert\Documents\Baldur's Gate - Enhanced Edition\

    KingHiram33jackjack
  • KingHiram33KingHiram33 Member Posts: 3
    that was indeed the problem, thank you!

    jackjackAstroBryGuy
  • kingcrowleykingcrowley Member Posts: 23
    I used this to catch Neera up a bit and it removed her Kit and Wild Mage cannot be added back to her for some reason....

  • Swifty_MageeSwifty_Magee Member Posts: 222
    edited November 2014
    @kingcrowley I also noticed that the Wild Mage kit cannot be put on a character, but I found out with IWDEE. A tried to use EEKeeper to make a Wild Mage/Thief, and while I could multi-class my Thief to any other type of Mage, I couldn't get my Thief character to have the Wild Mage kit.

    I found out that if you ever plan to have a Wild Mage/Any other class, you have to make the character a Wild Mage first, through the game's character creation process. You don't have to do that with any other Mage kit, but you do with the Wild Mage for some reason. Trying to add the Wild Mage kit on any of my characters through EEKeeper just makes them a standard Mage. Maybe a bug with EEKeeper, or just the way the game is coded?

    I don't know how you'd fix Neera in your situation...maybe roll back to a save before you started to tweak her and try again. If all you're doing is giving her exp or something, there really shouldn't be a problem.

    kingcrowleyjackjack
  • kingcrowleykingcrowley Member Posts: 23
    When you open a saved game with any Wild Mage it sets them to just a Mage... =(

  • Swifty_MageeSwifty_Magee Member Posts: 222
    edited November 2014
    @kingcrowley I don't know how it is in the other EE games, but at least when I open a saved game in Icewind Dale EE, my Wild Mage remains a Wild Mage. When I open my Wild Mage in EEKeeper, in the "Characteristics" tab, the "Class" drop down list will say "Mage", but in-game the character will still be a Wild Mage. The "Kit" drop down list will be grayed out, however.

    When I multi-classed my Wild Mage to a Wild Mage/Thief, all I did in EEKeeper was change the class drop down list to "Mage Thief", went to the "Abilities" tab and gave the character enough exp to level, saved the save file, and closed out EEKeeper. When I entered the game, my Wild Mage was labeled "Wild Mage/Thief" in her character record sheet, and was a level 1 Wild Mage and a level 0 Thief. I was then able to level up the character to lvl1 Wild Mage and lvl1 Thief.

    kingcrowleyjackjack
  • kingcrowleykingcrowley Member Posts: 23
    UPDATE: I fixed it somehow... set her to level 0 and then leveled her and the kit showed up.

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    @kingcrowley @Swifty_Magee, can either of you upload a save game, please? Wild Mage appears fine on my end and the kit drop-down is not disabled/greyed out.

  • Swifty_MageeSwifty_Magee Member Posts: 222
    edited November 2014
    @Troodon80 I'm not actually having a problem with anything right now; I was just talking about what it takes to multi-class a Wild Mage using EEKeeper.

    While the Kit drop down list is grayed out by default, I can click on the "Set Value" button for Kit and then from the box that pops up, I can select the "Wild Mage" option. And the Kit drop down box is normally not grayed out; it only seems to be grayed out whenever your character starts out as a Wild Mage.

    The issue is (at least whenever I have tried in the past), whenever you have a character that starts out as another class and then you try to turn them into a Wild Mage, your character in-game will just be classified as a standard Mage. If you look at the character in EEKeeper, their class will still say "Mage" and the kit will still be "Wild Mage", but in-game you will just be a normal Mage.

    Kingcrowley says that he set his character to level 0, leveled the character, and then the character became a Wild Mage. I've tried that a few times before and it never works for me...the character still gets classified as a standard Mage and doesn't receive any of the benefits or penalties being a Wild Mage brings.

    I just create a Wild Mage normally at the begining of the game and then use EEKeeper to multi-class. That way, I can stay a Wild Mage while multi-classing with something else.

    I figured it was mainly just a limitation of EEKeeper. It's a situation that has happened with multiple save files, so I don't think a specific save game is borked or anything. And Wild Mages aren't even supposed to multi-class, so I figure I'm lucky to even hack in the option.

    If I am the only one who has this issue, where you can't change a character into a Wild Mage using EEKeeper, I will say that I have a couple of mods installed (IWDEE Kitpack and Scales of Balance). Nothing that changes the Wild Mage class, but they may be a consideration if it's just me.

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    edited November 2014
    @Swifty_Magee, so you can replicate the greyed out drop-down when starting a new game as a Wild Mage?

    Edit: Keeper is picking up the kit and calling it 0xFFFF8000, which is not right. Do not pick Wild Mage from the list from the Set Value option.

    Swifty_Mageekingcrowleyjackjack
  • Swifty_MageeSwifty_Magee Member Posts: 222
    @Troodon80 I can confirm that when starting a new game as a Wild Mage, the "Kit" drop-down list will be grayed out for me in the "Characteristics" tab.

    kingcrowley
  • kingcrowleykingcrowley Member Posts: 23
    edited November 2014
    I have no mods installed, is there a fix or a way around this? If 0xFFFF8000 isn't right what is the right number?

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    @Swifty_Magee, I'll have a fix up as soon as possible. I'm right in the middle of some unfinished stuff right now, so a quick fix will need to wait until I get some text translated.

    kingcrowleyjackjack
  • kingcrowleykingcrowley Member Posts: 23
    I "Fixed" it but if i open the editor again for any reason it drops the kit again and not sure if the level 0 trick will work again.

  • kingcrowleykingcrowley Member Posts: 23
    Ok cool thanks. Ill just have to remove her from my party before i edit anyone else.

  • Swifty_MageeSwifty_Magee Member Posts: 222
    @Troodon80 Hey, take your time with all this. Like I said, this isn't really a big deal for me as I found a workaround to all this, but I understand the need to stamp out any bugs or odd behaviors.

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    @Swifty_Magee @kingcrowley,

    I'm attaching a quick fix here since the editor requires text to be translated. I'm including updated language DLLs here as well, just to avoid no text being displayed (new strings will be displayed in English for now).

    There are a couple undocumented additions here, I'll wait until I've finalised them and gotten the text updated before actually adding them to the change log. :-)

    CrevsDaakkingcrowleyjackjack
  • geekgirlgeekgirl Member Posts: 4
    edited December 2014
    Where is the installation directory and savegames for steam on mac ? It looks like it would be at /Users/$USER/Library/Application Support/Steam/SteamApps/common/Icewind Dale Enhanced Edition/IcewindDale.app/Contents/Resources but that (and paths above it) don't show any of the save games!

  • geekgirlgeekgirl Member Posts: 4
    Nevermind, I found it! /Users/$USER/Documents/Icewind Dale - Enhanced Edition/save and click custom save location.

    Sjerrie
Sign In or Register to comment.