Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

NWN Toolset: Enhanced Edition. Try the new updates and share your feedback



  • PaphjortPaphjort Member Posts: 24
    Thank you, virusman

    The new version of the toolset is great and I haven't met any errors yet. Good work! Especially the rotating/scaling of placeables and creatures.

    The only bad is thing is that I now have to uninstall it again to be able to continue my mod, since I changed to the development branch while building it.
    Can't see a way to make it work in the updated toolset. Even tried changing min. req. version in module.ifo from 1.78 to 1.77, but the toolset still insists it needs a newer version to be able to open my mod :-(

    Anybody know how to change a module from development (1.78) to stable (1.77) ?

    I hope the wait is not too long before the updated toolset is released properly. :-)

  • EurgigaEurgiga Member Posts: 8
    edited June 2019
    I'd like to see a "flip" option (button? hotkey?) that flips the selected object in the toolset along the X, Y or Z plane, as selected. If multiple objects are selected, the flip option will instead flip the objects as a group.

    If possible, another useful function would be the ability to manipulate the spacing of a selected group of objects via click-dragging, perhaps by drawing a box around the group when selected with a grabbable corner.


  • SquidgetSquidget Member Posts: 15
    Thank you Virusman. This is a huge help for builders!

  • TheCapuletTheCapulet Member Posts: 43
    Any chance we'll get a key remap in these builds? Would be amazing to switch the numpad keys over to the more useful and modern wasd group of keys. Even a simple toggle would do the trick.

  • TarotRedhandTarotRedhand Member Posts: 1,127
    edited June 2019
    @TheCapulet Ye gods NO!. I hate the antiquated wasd. I only use the arrow keys and remap those games that allow it. Those that don't I drop. It's a matter of touch. I can instantly feel the arrow keys without looking whereas I have to take my eyes away from the screen to find wasd.

    My guess is that you are on a laptop and don't have a full keyboard with separate arrow keys. That's the price you pay for portability.


  • dunahandunahan Member Posts: 122
    @TheCapulet @TarotRedhand I think it would be better, if we could specify the controls ourself, or not?

    Like a addition to nwtoolset.ini:

    And if they are missing, the usual controls are used.

    That would help Capulet and wouldn't disturb you ;-)

  • TheCapuletTheCapulet Member Posts: 43
    @TarotRedhand Not at all. In fact, I have a separate number pad, just so I can keep my hands in a natural position. Which is the whole benefit of the WASD location. Obviously proper keymapping would be ideal, but making a simple toggle would be far easier than adding an entirely new menu to handle keymapping.

    And the reason the arrow keys wouldn't be ideal is because there's only 4 keys there. 9 keys are needed to make use of all of the available hotkey functions, which the WASD location would provide.

    q & e for camera rotation, z and c for camera zoom (or better yet, for camera tilt, since zoom is already on the mouse wheel), and X for recentering.


    Definitely ideal, but I was suggesting the easiest route, hoping virusman would be more likely to pick up a smaller project like that.

  • TheCapuletTheCapulet Member Posts: 43
    Another thing I'd like to request again, since it's been over a year since I've mentioned it, is object rotation tied to a hotkey.

    Since we're getting all these fancy object manipulation hotkeys, it'd be the one of the last, if not the actual last hotkey we're missing. Select object, hold alt (or any other key), and move mouse in the direction to rotate the object.

    Only other thing I could think of is a key to toggle the static flag at selection or multiple selections.

  • TarotRedhandTarotRedhand Member Posts: 1,127
    Just a thought but seeing as the toolset is being actively worked on are there any plans to fix this issue with the conversation editor, while you're at it? It appears that it doesn't affect everybody but does affect quite a few people as others reported it too.



  • NotsonobleNotsonoble Member Posts: 6
    Late to this but very very thankful for toolset updates.

    Hope someday to see a linux build of the toolset. Too, but for now will take what I can get.

  • TressetTresset Member, Moderator Posts: 8,205
    edited July 2019
    virusman wrote: »
    Talime wrote: »
    Just a headsup:

    Even the old toolset stops working correctly after the nvidia update.
    Means, it crashes on start up.
    Gets random access violation errors.
    Or freezes on loading the module.

    So looks like I have to put my whole project on hold now till this gets fixed, since downgrading a whole system because of a toolset of one game stops working, is not a practival solution. Especially if the driver update fixes general performence issues.

    As mentioned earlier in the thread, going to the driver settings and disabling Threaded Optimization for nwtoolset.exe should fix the driver issue.

    @virusman I have tried disabling Threaded Optimization for the toolset, but it still wont start for me. I have an Nvidia Quadro M4000 and I tried both the latest driver and rolling back to the previous one.

  • LeoArcticaLeoArctica Member Posts: 1
    My toolset closes for no reason when I try to load an area.

  • TheCapuletTheCapulet Member Posts: 43
    How difficult would it be to make objects with blank names in the pallete show their tag instead?

  • RananRanan Member Posts: 34
    Here to report a bug

    When renaming areas, the text field defaults to blank after I type in the new name of the area. I can remedy this by opening the area properties tab and the name I input there will stick. While not game breaking, I don't believe that the function is working as intended

  • KaapeliKaapeli Member Posts: 1
    After Feature update to Windows 10, version 1903. Advanced and normal NWN tools stopped working. You can run the program but after you open an area it crashes.

  • Pixel_MayhemPixel_Mayhem Member Posts: 61
    One little thing that bugs me with this toolset update is when adjusting the placment of a placeable with the Adjust Location dooby if you click either up or down arrow for what ever axis and at fist it does nothing, click it a second time and the number increases or decreases in the opposite direction you are actually clicking. Only after the third click does it work as intended. It a minor thing but darn a bit annoying :/

  • TarotRedhandTarotRedhand Member Posts: 1,127
    @Kaapeli do you have an nvidia card? I do and that sounds like a problem that there is a workaround for.

    Open the nvidia control panel.
    Select Manage 3D settings
    In the Manage 3D settings panel select the Program Settings tab
    Under "Select a program to customize" there is a drop-down box. Open it
    Scroll Down/Up until you see Neverwinter Nights (nwtoolset.exe). Select that.
    Turn Threaded Optimization to off.

    Close the nvidia control panel. And thats it.


  • TressetTresset Member, Moderator Posts: 8,205
    edited August 2019
    Well, Having tried disabling threaded optimization for the toolset, I am now at a loss as to what to do about this. It still won't work. Right now I am browsing downloading, and installing old nvidia drivers somewhat randomly in the dying hope that one of them will actually be compatible with the toolset... Sigh...

    Edit: Well, that didn't work either... I guess this will just ruin NWN for me unless I some day get a new video card...



    Post edited by Tresset on
  • TomRotflTomRotfl Member Posts: 24
    edited August 2019
    I Hope this can help, i had the same issue.
    Since after i have updated my driver to the Nvidia Driver 419.67 i started having this issue.
    Instead of trying to find a solution, i have simply reverted the driver to the previous version, Nvidia Driver 419.35, that was working before and it's working fine even now.
    Haven't tried to update yet. I mostly use the pc for programming into the toolset.

    My GPU is a GeForce GTX1070.

  • TressetTresset Member, Moderator Posts: 8,205
    OK! So apparently this either disabling threaded optimization or a driver rollback works for EVERYONE ON THE PLANET EXCEPT ME!!! I am just... UGH!!!

  • TomRotflTomRotfl Member Posts: 24
    Did you make clean installs?
    Do you have an Integrated graphic on you CPU as well?

    You might want to try to completely uninstall nVidia driver, reboot, try the toolset with the integrated card, then if thats working, try again by installing the old working driver i mentioned

  • TressetTresset Member, Moderator Posts: 8,205
    So, here is something odd... Unlike others in this thread, the non-EE toolset does work for me for some reason... Except I can't use that to edit EE modules... Hmm...

    I am currently going to try a clean install of the game, waiting on the download.

    @TomRotfl I appreciate that you are trying to help me with this. I really hope I can get this issue sorted...

  • TressetTresset Member, Moderator Posts: 8,205
    So bizarre... I think I found the problem! There was a file in my documents directory called nwn.ini that was causing the abnormal program termination. When I removed the file from the directory the crashing stopped! Hell, I can even run it with the latest driver and threaded optimization turned on now!

    Now that the issue is solved I am just dying to know what the hell is in this file that caused the issue. This was such a pain in the butt to me that I just HAVE to know what happened, so I am uploading the faulty file in hopes that someone more knowledgeable can tell me what is wrong with it.

  • TressetTresset Member, Moderator Posts: 8,205
    edited August 2019
    So bizarre... I think I found the problem! There was a file in my documents directory called nwn.ini that was causing the abnormal program termination. When I removed the file from the directory the crashing stopped! Hell, I can even run it with the latest driver and threaded optimization turned on now!

    OHHHHHHH!!!! I just figured it out!!!

    I recently got a new computer that has a slightly different HD setup than the old one. When I transferred my files over from the old computer, I simply copy/pasted the files to their appropriate places on my new computer. I failed to realize, however, that my user libraries were now on a different HD with a different name. The nwn.ini was trying to direct the toolset and game files to the documents library on Drive C, while they are now located on Drive D! This must have caused an error that crashed the Toolset.

    Post edited by Tresset on
  • Pixel_MayhemPixel_Mayhem Member Posts: 61
    Has anyone else noticed this bug? When you open an area and select something on the drop down list on left window and then right click it and select "Focus on Object" the entire filter button menu at the top grays out and is no longer to be selected. Only way to get them active again is to open another area. Not a huge issue but kind of odd ;)

  • grom56grom56 Member Posts: 100
    I've been reading through all of this thread and saw that some others had had the same issue I'm now having. My toolset keeps going into "not Responding" and locking up. However everyone else seems to have this problem with a nVidia video card. Looks like my video card is a AMD Radeon HD 6570. So not at all sure what the work around would be. I've reported my problem to Beamdog support.

  • TheCapuletTheCapulet Member Posts: 43
    Have the same issue on the same series of card. It seems like it's triggered most often by viewing placables on the preview window that have light emitters. Also when switching between area tabs that are already open (Switching automatically to a newly opened area seems to work).

  • grom56grom56 Member Posts: 100
    After working with it a bit, looks like my issues all happen when trying to set a transition on a door. I can place doors just fine, but when I try to have the door lead somewhere, it locks up.

  • SurekSurek Member Posts: 9
    This issue is not new. I have had this issue since the start of EE, Makes the toolset unusable. You can find mine and other reports here.

Sign In or Register to comment.