Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

NWN Toolset: Enhanced Edition. Try the new updates and share your feedback



  • Old_GithOld_Gith Member Posts: 109
    I discovered this bug today. Reported it and also posted an example of it here.

  • ShadowMShadowM Member Posts: 566
    edited January 1
    Z positon and Z translation are exactly off by .1 ( I tested this with a item/placable, It be nice if they perfectly match) Testing place an item on the ground in toolset and set it to 0.91 for Z Translation and set a placable that the same model to 0.91 Z postion in the toolset. They look the same height in the toolset, but when you go into the game the placable will be .1 lower. When you adjust the placable 0.1 up more they match when in game. I have not tested other directions / axis. Love the Z translation, great for putting items on tables and stuff that can be grabbed. Seem height is off by .1 in game vs toolset.

    Post edited by ShadowM on
  • PstemariePstemarie Member Posts: 190
    Dungeon Tileset has some issues in the new toolset...

    EE Toolset


    v1.69 Toolset


  • Old_GithOld_Gith Member Posts: 109
    Yes, I've reported that one awhile ago. That video glitch actually began with a patch back in 2018. When you introduce the lava tilegroups it gets even more pronounced. I was hoping they would fix that one by now. It's not confined to the toolset either. It also appears like that in game.

  • PstemariePstemarie Member Posts: 190
    So much for using that tileset for anything.

  • ZwerkulesZwerkules Member Posts: 106
    Up until 1.69 to make meshes appear black people used two different methods, either by giving them a black texture (which causes no problems) or by using any texture or none and setting ambient and diffuse to 0.0 0.0 0.0. Maybe what you see there is a mesh that doesn't use a black texture and just black ambient instead and somehow the colour is affected by shaders now.
    I'll have a look at the tiles when I have some time to see if they use a black texture or not.

  • ZwerkulesZwerkules Member Posts: 106
    Here are a few lines of that corner tile model you used:
    node trimesh Rectangle74
    parent TDE01_A01_01
    ambient 0 0 0
    diffuse 0 0 0
    specular 0 0 0
    shininess 26
    shadow 0
    tilefade 2
    bitmap NULL
    verts 15
    -1.2500000 -0.5000000 0.0000000
    1.2500000 -0.5000000 0.0000000
    1.2500000 0.5000000 0.0000000

    This shows the problem. This clearly is a mesh that should be black, but it uses no texture and sets ambient and diffuse to 0 instead.
    This can be solved by setting the bitmap to a black texture, but there's a huge amount of Bioware content as well as custom content that does exactly the same to make a mesh black and it would take far too much work to fix all that, even more to find all those problems in the first place.

  • ShadowMShadowM Member Posts: 566
    Pstemarie wrote: »
    So much for using that tileset for anything.
    I'm messing with it, might have it fixed by today.

  • ShadowMShadowM Member Posts: 566
    Ok done with first pass, I think I got most of them. If I missed a few I sure you guys will give me a list and quickly update it. I post it on the vault tomorrow.

  • PstemariePstemarie Member Posts: 190
    edited January 4
    While I know you mean well @ShadowM , an outside "fix" for a vanilla asset is moot. EE changed something that affected the way the texture (or lack of) on the model is rendered. Therefore, the onus is on Beamdog to fix it.

    Issues created by EE that were NOT present in v1.69 need to be addressed at the top level. Since this has already been reported some time ago, I'm not going to bother submitting another ticket.

  • ShadowMShadowM Member Posts: 566
    edited January 4
    Pstemarie wrote: »
    While I know you mean well @ShadowM , an outside "fix" for a vanilla asset is moot. EE changed something that affected the way the texture (or lack of) on the model is rendered. Therefore, the onus is on Beamdog to fix it.

    Issues created by EE that were NOT present in v1.69 need to be addressed at the top level. Since this has already been reported some time ago, I'm not going to bother submitting another ticket.

    Oh I know what they did that caused it, the engine is not defaulting to black when no texture or not rendering setting the ambient/diffuse colored mesh as Zwerkules said, but I been around since nwn started and I just got to the point where I will not wait on thing I can fix. They will fix it, but this is a nice temp fix until then.
    LINK to vault fix

  • virusmanvirusman Member, Developer Posts: 169
    @Pstemarie Is there a report with a test module? I just tried creating an empty area with the Dungeon tileset and I don't see any lighting being applied to the empty areas (it is similar to your 1.69 screenshot).

  • PstemariePstemarie Member Posts: 190
    edited January 7
    New report made. My earlier report is NWNS-903 and the new one is NWNS-924. Someone else told me they had reported this on Redmine months ago.

    Maybe its because I'm on an AMD system now?

  • SorenSoren Member, Developer Posts: 36
    @Pstemarie Could you try putting these files into your override and see if that helps:


    Thanks :)

  • DazDaz Member Posts: 82
    Soren wrote: »
    @Pstemarie Could you try putting these files into your override and see if that helps:


    Thanks :)

    Seems to fix it for me, fwiw

  • PstemariePstemarie Member Posts: 190
    Soren wrote: »
    @Pstemarie Could you try putting these files into your override and see if that helps:


    Thanks :)

    That fixed it.

  • ShadowMShadowM Member Posts: 566
    Soren wrote: »
    @Pstemarie Could you try putting these files into your override and see if that helps:


    Thanks :)

    Add BD fix to the Vault fix page I mentioned.

  • AdolinAdolin Unconfirmed, Member Posts: 2
    edited January 14
    With the 8193.6 build that came out today. I tried to make a arcane caster class that uses domain but it wouldn't let me. Is it possible to get this unlocked. The new features are great, but a few more would be awesome!

    Also a note on some of the settings i tried:
    So I told the classes.2da that for sorcerer, they don't memorize spells (like the cleric or wizard does), their spellbook is restricted, they can pick domains (doesn't work), they can learn from scrolls (apparently is freezing the game and i have to use task manager to get out), they are an Arcane class, they have Arcane Spell Failure, their casting ability is Charisma, and they can Cast Spontaneously (haven't tested yet).

    Also unrestricted the spellbook for sorcerers. The spellbook shows all the spells, but it doesn't show up in the radial menu as available to cast (only the ones selected at levelup do). After clicking and dragging from the spellbook to the quickbar, the spell looks like it can be case and has the correct amount of usages, however when I attempt to use it I get a server message that says "No uses or preparations left for that spell."

    Post edited by Adolin on
  • VogelensVogelens Member Posts: 1
    edited January 20

    I am one of the (main) builders for the online NwN Server The Dragon's Neck, and I would like to offer some feedback in regards to the toolset and a change that happened recently.

    This is regarding placables and their position on the Z-axis. Previously, when you selected a placable or a group of placables and tried to move them, they all shifted to the ground level of the terrain. Now, I noticed, they do not do this. If you have placables stacked on top of each other, they stay stacked and locked into place. This is not neccesarily a bad thing in itself, as it has some niche uses I find when building but, after building and playing around some with this feature, I find myself not liking it at all.

    The reason for this is, is that the server I build for is big with dressing areas up with placables. We think the visial is important and I myself, as well as the other builders do make heavy use of placables. Sometimes in these cases, placables end up stacking, something that is hard to see in the toolset at times and it can be missed even when testing in the actual game. A very good solution was to select all those placables and gave it a wiggle to restore them to ground level. This can be done with the Adjust Location option but this runs into problems when you have elevation differences in the terrain and the tileset is not fully flat. Even with just small patches of placables and just a handful of them at a time, it becomes really tedious to manually adjust each one individually, or to adjust it through the Adjust Menu setting. (Where even possible, not all patches are the same Z axis)

    I found myself using this to reset placables to ground level much, much more than moving a stacked bunch (Which I still do, it has a niche use, but adjusting a stack of placables is less time consuming that setting over hundreds of placables to ground level manually).

    Building areas to feels much more time consuming as a process, with more chance of the ugly "floater" placables in game that may be missed, and it feels more like a chore than fun, and while I get this QoL improvement for moving placables, it is a change that affects maybe 1 out of 10 scenarios, if that. (it could easily be 1 out of 20. I know the other builders on the server I build for are much the same with this)

    Ideally, a toggle for this would be great, so you can choose which QoL improvement you want to use at a given time. But right now, it feels like we actually -lost- Quality of Life in the toolset, and I feel myself having to resort to an older version of the toolset because it feels so much smoother and to me, much more intuitive when it comes to using a good amount of placables.

    Post edited by Vogelens on
  • Ugly_DuckUgly_Duck Member Posts: 98
    Any idea on when the toolset will get a full-release with all of these new features?

    Also, any idea on when the new renderer will be released?

  • Sfera_RojaSfera_Roja Member Posts: 9
    edited February 5
  • PstemariePstemarie Member Posts: 190
    The globes around sound objects no longer render in the toolset...


  • DokhtorVeeDokhtorVee Member Posts: 4
    Echoing the post by @Pstemarie , facing the same problem in the toolset.

    It's happening since updating to Development Build 8193.6

  • badstrrefbadstrref Member Posts: 124
    edited February 18

    Post edited by badstrref on
  • TalimeTalime Member Posts: 71
    edited March 3
    Great ....

    I recently found out that one guy in here who appearently has no clue at all what he talked about suggested to "fix" the Z axis reset of placeables if you move them around.

    With that "fix" you completely and totally destroyed the ONLY way to be able to align placeables with uneven ground structures like small hills or some other uneven objects.

    It is now completely impossible to set a bunch of placeales to the lowest possible attachmentpoint of a tile.

    f5 doesn't work because that causes placeables to stack atop of each other so they build towers, which you can't reset to groudnlevel by moving anymore.

    A stupid workaround which doesn't really work either is to mark a bunch of placeables , rightclick and set the z axis manually to 0 or whatever the tile hight is.
    This however doesn't take into account that some tiles have wobbles and hills that are ignored and the placeble sinks into the tile since not every place on a tile has teh same z axis ratio and of course it resets the direction of the placebales.

    Sooooo ... tl:dr: you broke one and ONLY the ability to align more than one placeable with the ground level by moving them around which is a FAR greater issue now than that they intentioinally reseted the z axis. Which has been teh case since the game was released and was NECESSARY to be able to place placeables correctly onto the grounds.

    Would be really cool if you could let someone, who at least has build with the toolset for more than 5 mins, test those critical changes before you implement them and bascally screw everything over.

    This is such a gamebreaking thing ... it makes mapping on a higher level than rooky lever impossible now ... thanks.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 20,955
    I hear you're upset, but please don't go personal in your comments. People who participate in this discussion deserve more respect.

  • TalimeTalime Member Posts: 71
    edited March 4
    What told you I am upset? Why should I?

    That would imply you guys would do completely stupid things and errors, break promises and pull off one scam after the other.

    So yes by that logic I would need to be upset ...
    I wonder where all the hate comes from ... probably totally undeserved and unfair.

    But of course pissing off the few remaining people who still are not yet conviced now should be your priority number 1.
    You have so much lost the touch but that is something I have told you before allready. Just another example .

    Gosh I can't believe what a trainwreck of incompetence this company is. I really didn't want to believe it. Should have listened to the people, why should anyone waste his time for fake negative reviews if they didn't just want to warn other people.

    Fix this horrendous thing! And possibly within the next century or before the "new renderer" is ready. Whatever happens first. My guess is the century to be honest.

    And then by the love of all what is holy, keep your hands better off this game and let it be done by someone who cares and has a clue.
    Unbelieveable what an abuse you have done to this game by now.

  • virusmanvirusman Member, Developer Posts: 169
    @Pstemarie @DokhtorVee I can't reproduce this. The spheres render just fine for me. What's your computer/OS configuration?

  • ShadowMShadowM Member Posts: 566
    How about the height bug? Where the height of object/placables in toolset are not matching in-game height. I already have sent in a bug report on this also.

Sign In or Register to comment.