Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Sword Coast Stratagems now available for BG:EE

11214161718

Comments

  • PalanthisPalanthis Member Posts: 283
    edited November 2013
    @DavidW have you any idea what could cause the SCS prebuff spells not appearing on the combat log in BGEE 1.2 ?

    EDIT : i just checked stratagems.ini, it has the variable "Conceal_Prebuff_Spell_Names" set to 0... so this shouldn't be happening, right ?

    Post edited by Palanthis on
  • PalanthisPalanthis Member Posts: 283
    Nevermind, i reinstalled only the AI component of SCS on itself, and it now works like a charm. Again, I really don't see what could have messed up my first installation.
    Maybe it's some other component of BGTweaks (that i installed after SCS) that was the cause of the problem.

  • DavidWDavidW Member Posts: 740
    Any chance you installed with the game open?

  • PibaroPibaro Member, Translator (NDA) Posts: 2,989
    Ok, I think I resolved my problem.
    Thanx to @Palanthis and @Wisp
    I only need to test it against a Mage but it seems OK.

  • PalanthisPalanthis Member Posts: 283
    DavidW said:

    Any chance you installed with the game open?

    Hmmm, i don't think so. Not my style...

    I have a feeling it's rather linked somehow to BGTweaks, though i don't have a clue to which component could be involved, or if it could be related to the fact that it doesn't uses the same Weidu version.

    When i reinstalled the AI component, Weidu warned me it couldn't keep the "remove XP limit" of BGTweaks. I had to reinstall this lone component after, but now everything is fine. Not sure if it could help.

    I could post tonight my Weidu log if you want.

  • IsayaIsaya Member, Translator (NDA) Posts: 743
    @Palanthis If you installed BG2 Tweaks after SCS, then decided to reinstall SCS without uninstalling yourself BG2 Tweaks, weidu has actually done the following, as far as I know:
    1. uninstall all mods and components installed after the component from SCS you asked it to reinstall
    2. reinstalled the SCS component
    3. reinstalled all the components and mods you have previously, in the same order and with the same options
    So, basically, it should have applied things exactly as before, unless you changed the component setting in SCS (provided the component involved has options). This could trigger a change when WeiDU reinstalled BG2 Tweaks afterwards because the new settings would make a BG2 Tweaks component you formally installed incompatible with the new SCS setting.
    In any case, I fail to see how a BG2 Tweaks component could have an impact on SCS display of prebuff the first time and not now.

  • PalanthisPalanthis Member Posts: 283
    Well @Isaya, i see your point.
    Still, i can assure the bug i had just disappeared when i reinstalled the AI component of SCS.
    Maybe it was some error in the first SCS installation that was the source of the bug, but i did nothing special in the first place that could mess up SCS. I really don't know ...

  • IsayaIsaya Member, Translator (NDA) Posts: 743
    I guess there's no point wondering too much why things are working when they do. ;-)
    Have fun.

    Palanthis
  • BerconBercon Member Posts: 486
    So far the only bug I've encountered with 1.2 + SCS v24 is that Mulahey (the guy at the bottom of Nashkel) loops the "help me minions" or whatever when he is low on heatlh, spawning infinite amount of mobs. I avoided this by incapacitating him so he couldn't call for help.

    JuliusBorisovPibaro
  • PhyraxPhyrax Member Posts: 198
    @Bercon, that is a great tip! I had so much trouble reaching him with my party, I ended up resorting to CTRL-Y just to get to Mulahey and be able to hit him. I try that the next time.

  • DavidWDavidW Member Posts: 740
    Mulahey looping minions is the Bug that Won't Die for some reason. I'll have another look at it.

    DexterJuliusBorisovPibaro
  • KingGhidorahKingGhidorah Member Posts: 200
    Much like @Deefje im also encountering "invalid #insert number#" messages where I would normally expect a line such as *quaffs a potion* or *precast spell: Mirror Image*. Nevertheless, besides those messages everything seems to be running fine.

    I've used the newest version of Weidu to install the mod and the installation didn't give me toruble.
    Im awaiting eagerly to see if this is solved in v25.

  • ComplyOrDieComplyOrDie Member Posts: 41
    Does anyone know if the following could be due to SCS?:

    "An Assertion failed in CGameAIBaseActions.cpp at line number 2096"

    Appears when I summon a beholder at the tome of monsters on second area of Spellhold maze. I'd ignore it and move on if a one off but have a horrible feeling it will happen with all beholders?

    Install is Ascension, BG2Fixpack, BGT, SCSv24, Widescreen.

  • DavidWDavidW Member Posts: 740
    Can you use the console? If so (or if you can look it up), do CLUAConsole:CreateCreature("behold01")

  • ComplyOrDieComplyOrDie Member Posts: 41
    Hi David, thanks for replying. I created one on my save at the very start of the maze and the same error occurred.

    I managed to work round another crash I was experiencing outside at D'Arnise hold:

    "An Assertion failed in ObjCreature.cpp at line number 12162"

    My install last year was the same except with SCSv21 and these things didn't happen.

    In the short term, if it's even SCS, would a fresh install with v21 potentially allow me to continue the save game and potentially solve the issues or does it not work like that?

    Thanks again.

  • DavidWDavidW Member Posts: 740
    D'Arnise Hold is a known problem with v24 (as I've warned people, it's a beta). I honestly don't know if you could safely swap to v21. Probably.

  • ComplyOrDieComplyOrDie Member Posts: 41
    edited November 2013
    Thanks for your help will give it a go and again for the fantastic mod. I have option 1 installed for beholders if thats relevant. D'arnise hold was fine if I sent a summon into the fog ahead of where I needed to go first.

    Edit: Rolling back to v21 has indeed solved the beholder issue.

    Post edited by ComplyOrDie on
  • YgramulYgramul Member Posts: 1,059
    Could someone please advise on how to install SCS on Mac OSX?

    There are some tutorials on how to install Weidu based mods on the Mac forums but it seems useless for an .exe file [stratagems-v24.exe].

    (Now that 1.2 patch is out; all I need is to get SCS install. Using Mac OS 10.7.5)

  • SirK8SirK8 Member Posts: 527
    @Ygramul - I can't speak to Mac install specifically since I don't own one. However, the stratagems-v24.exe is an archive and can be unpacked (not sure what to use on Mac). Once you've done that, normal instructions for installing a WeiDU based mod should apply.

  • AstroBryGuyAstroBryGuy Member Posts: 3,414
    @Ygramul - Use Unarchiver to open the archive.

    https://itunes.apple.com/us/app/the-unarchiver/id425424353?mt=12

    You'll probably also need to get a Mac WeiDU binary if you don't have one. I would assume there isn't a Mac binary in the Windows self-extracting archive.

  • lordkimlordkim Member Posts: 1,063
    edited November 2013
  • EtaminEtamin Member Posts: 795
    I have problem with installing SCS. I have downloaded latest version from here: http://forums.gibberlings3.net/index.php?showtopic=25546 installed it in 00766 folder, but when i click at stratagems.exe it tells "unable to find dialog.tlk". Any idea?

  • StoneSwordsStoneSwords Member Posts: 178
    you have to create a hard link to your dialog.tlk file. Don't remember exactly how to do it, but one of the pinned topics in the modding section has instructions on how to do it

    Etamin
  • PibaroPibaro Member, Translator (NDA) Posts: 2,989
    It was explained (to me) few post ago.

  • DexterDexter Member Posts: 253
    and it's also explained in the readme

    Wilbur
  • EtaminEtamin Member Posts: 795
    edited November 2013
    And it was explained by @StoneSwords just 3 posts above

  • WilburWilbur Member Posts: 1,173
    Is there a list of bugs somewhere? I'm dying to start a new game with SCS, but I'm under the impression there are at least some problems with scripts related to casting/prebuffs. Or maybe I'll just wait for the next version.

  • DavidWDavidW Member Posts: 740
    No promises, but it'll probably be a short wait.

    Wilburmackos
  • TvrtkoSvrdlarTvrtkoSvrdlar Member Posts: 353
    edited November 2013
    @DavidW
    Getting this when I try to install:

    Installing file(s) nashkelwolf_ee.d
    Compiling 1 dialogue file ...
    WARNING: internal label [2] not found in processed DLG [SHOPKN]
    ERROR: processing .D actions [tb#compile_patches/stratagems/initial\dlg/nashkelw
    olf_ee.d]: Invalid_argument("index out of bounds")
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    Stopping installation because of error.
    ...

    I have no idea what to make of it :/

    EDIT: Forgot to add that my installation is *not* under Program Files!

    EDIT2: Ok, I have no idea what I'm doing wrong; the game is installed under "E:/Games" (so it's not a matter of it being the "Program Files"), I've successfully created the hard link to the dialog.tlk, my Override folder is where it should be, and I'm running the .exe from the main installation directory. Oh, and I'm using the Weidu version which came packed with the SCS, as I've read that the newest one makes SCS go bonkers. So... what the heck am I doing wrong? :'(

    Post edited by TvrtkoSvrdlar on
  • AkuroAkuro Member Posts: 93
    @DavidW
    Since patch 1.2 finally brought back the German sound files and (almost all) missing translations, I'm using the German language tlk.-file right now.
    So far I installed BG Tweaks first and afterwards SCS 2.4.

    Now every time the mod "does" something with strings, the game crashes.
    Some examples:
    1) When I install the "Skip Candlekeep component", the game crashes as soon as the "special" guard initiates his dialogue.
    2) I installed "enemies use poisons - 3/4 change of breaking".
    For testing purposes, I attacked Reevor in Candlekeep. He goes red, quaffs a potion of speed and immediately the game crashes. The last thing I see before the screen freezes is the German translation of "gulp" ("schluck") when an enemy quaffs a potion.

    Since the game always crashes when some form of string or (modded) dialogue is involved (can attack Lydia without a crash since there is no string involed in the "battle" and I can talk to anybody without problems) I figured out it must be something with (modded) strings and the dialogue.tlk file.

    Do you have any advice/help for me?
    Thank you very much!

Sign In or Register to comment.