Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Sword Coast Stratagems now available for BG:EE

191012141518

Comments

  • DexterDexter Member Posts: 253
    Tarnesh trick is disrupting his mirror image, you got the wand of magic missiles right?
    And you are not supposed to kill silke with level 1 - 2 characters, she's a lvl 10 bard (same as vanilla). Just wait a few levels

  • DavidWDavidW Member Posts: 743
    You can take her, but probably not without a little luck.

    Dexter
  • lunarlunar Member Posts: 3,408
    DavidW said:

    You can take her, but probably not without a little luck.

    Or maybe drop maximum number of traps at her feet before accepting Garrick's offer. Really, 'neutral but possible to become hostile soon' npcs should be aware of pc setting traps nearby and should act accordingly. ^^

    Dexter
  • DavidWDavidW Member Posts: 743
    That sounds like a deliberate exploit to me, and I have a policy of not blocking them.

    Dexter
  • lunarlunar Member Posts: 3,408
    DavidW said:

    That sounds like a deliberate exploit to me, and I have a policy of not blocking them.

    I guess you're right. Setting a trap near a suspicious and powerful looking figure (Silke) is one thing, but setting ten traps by resting in the inn is cheesy. I did that, still she managed to kill me. :p

    Dexter
  • JarlealeJarleale Member Posts: 114
    Seems like there is a bug with battle sounds.

    Some times, lines from The Black Pits are played instead of the intended sound track. There's even on screen subtitles.

    I have no other mods (except for xp cap remover). Using newest version.

  • DavidWDavidW Member Posts: 743
    I'd need very solid evidence to believe this is SCS, since I don't touch music.

  • JarlealeJarleale Member Posts: 114
    edited October 2013
    Here's a screenshot.

    I have no evidence of anything, but I only use SCS, the version in the first post here. Installed it yesterday on the current version of BG:EE, Beamdog version.

    Also, this bug didn't occurr before I installed SCS yesterday, although I haven't been playing much since before summer.

  • lunarlunar Member Posts: 3,408
    @Jarleale it seems your dialog.tlk folder is wrong, did you swap the edited dialog.tlk with the one in the language-eng folder?

    The game tries to state the mage's prebuffs and it has a wrong line referenced so it shows a random dialogue line instead of saying: 'mirror image(previously cast)' etc.

    Jarleale
  • JarlealeJarleale Member Posts: 114
    Thanks @lunar

    Copying dialog.tlk from game dir to eng lang folder seems to have solved the problem. :-)

    lunar
  • SedSed Member Posts: 789
    Time to update the first post to reflect latest version? @DavidW

  • PibaroPibaro Member, Translator (NDA) Posts: 2,989
    edited October 2013
    LOL I think I'm the winner here, I have en error message when I try to download the .exe.
    I tried 5-6 times and I can't download the file :(

    One question.
    Should I wait for the 1.2 patch or can I go with the open beta (when I'll be able to get the .exe of course)?

    edit: Ok, I did it, but I had to log in (I had no idea I was supposed to log in to download the .exe)

  • DavidWDavidW Member Posts: 743
    Pibaro said:

    edit: Ok, I did it, but I had to log in (I had no idea I was supposed to log in to download the .exe)

    You don't. That's a straight link to my dropbox public folder; your BGEE login shouldn't have anything to do with it. (If you can log in to my dropbox account, I want to know!) I don't know what your problem was, but it's something else.

    (Version 25, which will be non-beta, will be on the G3 download site as per usual for Gibberlings 3 mods.)

    PibaroDexter
  • PalanthisPalanthis Member Posts: 283
    edited October 2013
    Wait ! i didn't know you were confident to get a non beta version soon ! That's excellent news !

    Any idea if it will be available either for the next patch or for BG2EE ?

  • PibaroPibaro Member, Translator (NDA) Posts: 2,989
    DavidW said:


    You don't. That's a straight link to my dropbox public folder; your BGEE login shouldn't have anything to do with it. (If you can log in to my dropbox account, I want to know!) I don't know what your problem was, but it's something else.

    Don't worry, I didn't login in your dropbox account, I merely login in the gibberling site.
    I'm quite sure it was just a temporary problem of the server because now I'm in a different PC and I could download it without any problem (and without logging anywhere).
    Tnx for the advice too :)

  • DavidWDavidW Member Posts: 743
    Palanthis said:

    Wait ! i didn't know you were confident to get a non beta version soon ! That's excellent news !

    Don't get too excited. It's all relative: a mod just isn't going to have the testing cycle of a proper game. "Non beta" just means that I'm cautiously optimistic that there are no really crippling bugs. I haven't been thus confident for v22-24 because of the major changes. As of v25 I'm back to my baseline level of confidence.
    Any idea if it will be available either for the next patch or for BG2EE ?
    Pass. (As in: yes, I have an idea, but not one I'm confident enough to share.)


    EudaemoniumDexter
  • PalanthisPalanthis Member Posts: 283
    Well i'm really pleased by your work quality, so i'd say it's really fine if you're back to your "baseline level of confidence".
    And it's fair enough to pass on my second question !

    But then could you confirm that we can start a playthrough with the next patch + SCS 24, and then update SCS to v25 later and continue the same playthrough, without any big incompatibility, if we keep the same options of SCS ?

    Likewise, would it be fine to update the game with a new patch when SCS is already installed ?

  • SedSed Member Posts: 789
    edited October 2013
    Sed said:

    @DavidW
    Seems Icharyd is very bugged at the moment. All that happens is that you get teleported around in a very "jumpy" way. I had to Ctrl+Y him to make it stop.


    @DavidW
    Is the bug with Icharyd been fixed? Haven't seen any patch notes about it.

  • DavidWDavidW Member Posts: 743
    Then you would probably be well advised to assume that it hasn't...

  • DavidWDavidW Member Posts: 743
    Palanthis said:

    Well i'm really pleased by your work quality, so i'd say it's really fine if you're back to your "baseline level of confidence".
    And it's fair enough to pass on my second question !

    But then could you confirm that we can start a playthrough with the next patch + SCS 24, and then update SCS to v25 later and continue the same playthrough, without any big incompatibility, if we keep the same options of SCS ?

    Likewise, would it be fine to update the game with a new patch when SCS is already installed ?

    Updating mid game from v24 to v25 should be fine - it's never a completely safe thing to do with a mod but I don't foresee difficulties.

    Updating the patch will wipe SCS. You probably can't do that and safely continue your game, even if you then reinstall SCS.

    JuliusBorisov
  • PalanthisPalanthis Member Posts: 283
    edited October 2013
    Ok, thanks for taking time answering this. I think i'll get a full playthrough of BGEE before installing the next patch ( i mean, the patch after the one who's coming), just to be sure i'm not breaking anything.

    It's good to know I can start a game and still being able to upgrade SCS in the middle of it.

  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 20,507
    Thanks for the answers but there're still some things I don't understand.

    I have the .2014 version of BGEE now with SCS 24 installed. When the patch is out what should I do to have both the 1.2 version of BGEE and the latest SCS? Will I have to uninstall the game completely, then install the 1.2 version of BGEE and then install the latest SCS? Is there any other way?

    Am I right I will have to download the game completely again if I uninstall it (I use the stand alone launcher)?

  • DavidWDavidW Member Posts: 743
    SCS works like any other mod here, so I advise checking the general mod thread

  • DexterDexter Member Posts: 253
    bengoshi said:


    I have the .2014 version of BGEE now with SCS 24 installed. When the patch is out what should I do to have both the 1.2 version of BGEE and the latest SCS? Will I have to uninstall the game completely, then install the 1.2 version of BGEE and then install the latest SCS? Is there any other way?

    Am I right I will have to download the game completely again if I uninstall it (I use the stand alone launcher)?

    You just need to unistall the mods. Updating the game will always wipe them out anyway. The upcoming patch is a major update so it means downloading the game whole game again. Then install SCS, last version is of course recommended, but you can install v24 and then update SCS to v25 in the middle of a game and it should be fine.

    JuliusBorisov
  • PalanthisPalanthis Member Posts: 283
    I just installed v24 and was prevented to install the component "Cosmetic change: stop Stoneskins from changing the caster's colour".
    The program said "it could be done only on Windows installations"... but... i'm on windows, and it has always worked before on my previous versions of SCS. I'm really not sure of what could caused it.

    All other options i chose were installed without any problems.

  • yaballayaballa Member Posts: 41
    edited November 2013
    Can i use version 24 with patch 1.2? Or should I wait for version 25?

    jethro
  • DavidWDavidW Member Posts: 743
    Palanthis said:

    I just installed v24 and was prevented to install the component "Cosmetic change: stop Stoneskins from changing the caster's colour".
    The program said "it could be done only on Windows installations"... but... i'm on windows, and it has always worked before on my previous versions of SCS. I'm really not sure of what could caused it.

    All other options i chose were installed without any problems.

    Are you on BGEE?
    yaballa said:

    Can i use version 24 with patch 1.2?

    Yes.

    Or should I wait for version 25?
    Entirely up to you. V25 has the benefit of many bug fixes. V24 has the advantage of actually existing. What's your discount rate for future benefits?

    AstroBryGuyJuliusBorisov
  • BerconBercon Member Posts: 486
    This is perhaps Weidu related question, but can I save the options I selected when installing SCS? So when I update from v24 to 25v by uninstalling v24 and installing v25 I wouldn't have to input all choices again.

  • PalanthisPalanthis Member Posts: 283
    DavidW said:



    Are you on BGEE?

    Yes, the latest patch of BGEE 1.2.0, and i'm on Windows 7.

Sign In or Register to comment.