Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Neverwinter Nights: Enhanced Edition has been released! Visit nwn.beamdog.com to make an order. NWN:EE FAQ is available.
Soundtracks for BG:EE, SoD, BG2:EE, IWD:EE, PST:EE are now available in the Beamdog store.
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

[MOD] Lefreut's enhanced UI (for BG1EE, SoD, BG2EE and EET)

1789101113»

Comments

  • GreenerGreener Member Posts: 334
    @lefreut I found a possible bug in the most recent version of Lefreut's enhanced UI

    I installed all components and when I hover my cursor over the "show highlight button" on the right hand side the following string appears "She did. She gave it to me, in fact...I have the deed here." (see picture)

    I'm running v2.5.16.6 update on a MacBook Pro (Retina, 15-inch Late 2013) with macOS High Sierra v10.13.6 Beta (17G62a)


  • GreenerGreener Member Posts: 334
    Seems like this has already been identified a few pages back, my apologizes for the double post!

  • MordekaieMordekaie Member Posts: 64
    edited July 7
    @lefreut

    I am with BGEE2.3.67.3B/SoD/modmerge.

    Let's try to explain clearly this annoying "bug" i have : each time a new message/feedback is displayed in the feedback/message box located at he Bottom of the screen, all the already displayed message are "scrolling over".


    ATM this is not happening with the vanilla game; but i have the problem with the main component of Lefreut's enhanced UI 3.4


    Post edited by Mordekaie on
    lefreut
  • John_DoeJohn_Doe Member Posts: 9

    Hey, I am having a slight issue with your mod. Specifically, the SoD version. I am playing on EET and yet I am given only the options to start a game in either SoA or ToB. I can't seem to figure out how to change it so I have the option to start from any game. I'd appreciate any help you can offer!

    If I understand the problem correctly, see my post earlier in this thread here:

    https://forums.beamdog.com/discussion/comment/970603#Comment_970603

    lefreut
  • lefreutlefreut Member Posts: 1,025
    John_Doe said:

    Hey, I am having a slight issue with your mod. Specifically, the SoD version. I am playing on EET and yet I am given only the options to start a game in either SoA or ToB. I can't seem to figure out how to change it so I have the option to start from any game. I'd appreciate any help you can offer!

    If I understand the problem correctly, see my post earlier in this thread here:

    https://forums.beamdog.com/discussion/comment/970603#Comment_970603

    It seems to be the same problem, yes, but I still don't understand how this setting can be missing after an EET install (unless you manually edit the baldur.lua file).

    I can add another check (documents path containing 'Enhanced Edition Trilogy') to be more robust if the setting is not there.

  • John_DoeJohn_Doe Member Posts: 9
    It is easy for baldur.lua to get rewritten for a variety of reasons. It is of course not the fault of your mod in the slightest, but if you could enable a more robust check it would nip this issue in the bud. Again I have to thank you for this wonderful UI. I doubt I could even play EE without it.

    lefreut
  • lefreutlefreut Member Posts: 1,025
    Mordekaie said:

    @lefreut

    I am with BGEE2.3.67.3B/SoD/modmerge.

    Let's try to explain clearly this annoying "bug" i have : each time a new message/feedback is displayed in the feedback/message box located at he Bottom of the screen, all the already displayed message are "scrolling over".


    ATM this is not happening with the vanilla game; but i have the problem with the main component of Lefreut's enhanced UI 3.4

    @Mordekaie I'm looking to see if I can do something, but I'm unable to replicate with BG2EE 2.5 nor with BGEE 2.3. Does it always happens for you? Do you have a way to reproduce?

  • megamike15megamike15 Member Posts: 1,008
    i was getting this very weird error when i tried using leui in the current version of bg1 ee. 2.3. it says it can't find characters and i get a whole lot of message boxes until it finally starts the game. don't have this issue with bg 2 ee but that may be due to it being 2.5 already.

  • lefreutlefreut Member Posts: 1,025

    i was getting this very weird error when i tried using leui in the current version of bg1 ee. 2.3. it says it can't find characters and i get a whole lot of message boxes until it finally starts the game. don't have this issue with bg 2 ee but that may be due to it being 2.5 already.

    @megamike15 all versions of LeUI should work with 2.3. Do you still have the UI.menu so I can look at what's wrong with it?

  • megamike15megamike15 Member Posts: 1,008
    edited July 9
    i keep getting an invalid token in menu error. like i said this is only for bg 1. 2 is fine.

    one says 70 the rest say scale to clip.

    edit
    ;
    i then tried it with the bgee skin and i just got an error. i also noticed in eetweaks your portrait picker is not showing up at all when using bg1ee. i never had these issues before leui used to install fine before the last update to the mod.

    edit 2: scratch the thing about eetweaks now it's working must have been a broken install. leui is still broken for bgee tho but atlest i got the tweaks working as i just wanted the portrait picker and the old journal.

    Post edited by megamike15 on
  • lefreutlefreut Member Posts: 1,025
    @megamike15 scaleToClip is indeed a new keyword from 2.5.

    The mod installs the UI depending on the game version (it overrides UI.menu with UI_25.menu if it detects the file OHTEMPUS.2DA which should be only in 2.5). The 2.3 UI.menu does not use scaleToClip.

    So unless the I mess up the check, you should not get the 2.5 UI when installing on 2.3.

  • megamike15megamike15 Member Posts: 1,008
    when i checked the override folder i notice there were two ui files. the normal one and one that had 2.5 on it. could that be what caused the issue?

    this was after installing the mod mind you.

  • lefreutlefreut Member Posts: 1,025
    @megamike15 it's normal if both are there. The game only read from UI.menu. The thing to check is if both have the same content, in that case it means that the installer incorrectly detects 2.5 and override the 2.3 file with the 2.5.

    You can manually fix it by copying the UI.menu from the LeUI\copy folder.

  • megamike15megamike15 Member Posts: 1,008
    that fixed it now it's working. thank you.

  • MordekaieMordekaie Member Posts: 64
    edited July 12
    lefreut said:

    Mordekaie said:

    @lefreut

    I am with BGEE2.3.67.3B/SoD/modmerge.

    Let's try to explain clearly this annoying "bug" i have : each time a new message/feedback is displayed in the feedback/message box located at he Bottom of the screen, all the already displayed message are "scrolling over".

    ATM this is not happening with the vanilla game; but i have the problem with the main component of Lefreut's enhanced UI 3.4

    @Mordekaie I'm looking to see if I can do something, but I'm unable to replicate with BG2EE 2.5 nor with BGEE 2.3. Does it always happens for you? Do you have a way to reproduce?

    @lefreut
    The problem is happening every time (even with the new 3.5 version). I can reproduce it at will. I haven't tryed yet your last update, the 3.5 version. Could it be related to my "graphic" setup ? (i had to add SetPrivateProfileString('Graphics','Backend','1') in the baldur.lua file).

    In the feedback/dialog box there is a vertical bar with a cursor to move the text. Each time a new text is added to this box, the cursor (not set at the Bottom) is going down along with the text (what i call the scrolling text).



    Post edited by Mordekaie on
  • lefreutlefreut Member Posts: 1,025
    @Mordekaie I'm not sure I understand your problem. Maybe a few screenshots or a video can help.

  • GreenerGreener Member Posts: 334
    @lefreut

    I've noticed some interesting behaviour of the scroll bar with your UI mod installed (see attached video)

    Every time I leave the main screen for the inventory or character record screen upon returning to the main screen my scroll feed rapidly replays 10-20 items...

    I've narrowed it down to your mod tested on a an install with only your mod versus a clean install of BG2EE v2.3.67.3

    lefreut
  • lefreutlefreut Member Posts: 1,025
    @Greener can you try this UI.menu to see if it fixes the bug?

    @Mordekaie it looks like similar to your problem, can you also try it?

    Greener
  • GreenerGreener Member Posts: 334
    lefreut said:

    @Greener can you try this UI.menu to see if it fixes the bug?

    @Mordekaie it looks like similar to your problem, can you also try it?

    Thank you, thats seems to have resolved my issue, I'll keep testing and let you know.

    lefreut
1789101113»
Sign In or Register to comment.