Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

Aielund Saga Enhanced Edition

1101112131416»

Comments

  • rashkaerashkae Member Posts: 157
    edited April 2020
    A platform/Driver/chiptset issue would have been one of my first suspects for the kind of crash you described, but I passed over that thought since you had multiple players crashing, I presume when they enter the area independently of you. (Unless everyone was on the same / similar hardware.)


    You could try to open the game in the standalone server and see if the other players are able to move to the problem area. Not sure why your game would be drawing triangles when another player is going to the area in question, but the standalone server should not be having that issue.

  • ZazuZazu Member Posts: 8
    edited April 2020
    Only a couple of the other players tried and at least one was also using a mac which may have had the same GPU as mine.

    How do I start a game using the standalone server, rather than hosting the game myself? I had a look on the wiki but it isn't clear to me: https://nwn.fandom.com/wiki/Dedicated_server



    Also, @Savant1974 do you have the area code for the elven city when using the dm client/console commands? I am thinking that if I can get most of the players into Cairnwood forest and they talk to the druid, I can then use console commands to teleport myself to the city?

    As I was able to use commands to get myself to the Lake, then enter the Southern Slope from there, I only had issues when entering the "Cairnwood Forest" Area.

  • ZazuZazu Member Posts: 8
    If I have the "nwsever-macros" .exe file running and setup a game will it automatically use the standalone server?

  • Savant1974Savant1974 Member Posts: 245
    The tag is NewAcadia for the elven city.

    Zazu
  • ZazuZazu Member Posts: 8
    Thanks, that worked!

    Quick general question regarding the console commands - is there a way to get the "dm_" commands to work for any of the players and not just the host?

    We had another issue in act 2 where we couldn't receive the key to go underneath the dwarven mine from the foreman guy. I was able to use console commands to get to the next level, but it wouldn't work for any of the other players. Luckily we realised you could push eachother through the big door anyway without opening it.

    Is it possible for players who aren't hosting the game to use the "dm_movetoarea" command?

    Savant1974
  • Savant1974Savant1974 Member Posts: 245
    No idea, give it a shot!

  • DirichletPDirichletP Member Posts: 2
    edited May 2020
    Hi Savant,

    Thanks a lot for your support. I am in the very same situation of Zazu. I started playing the Aielund saga during the lockdown using NWN EE. Everything was going pretty well until I reached the "Cairnwood Forest" Area in Act III. When I enter that area the game crashes, no matter what.

    I am using a MacBook Pro with Catalina 10.15.4. Let us know if you have any clues :-)

    Savant1974
  • Savant1974Savant1974 Member Posts: 245
    I don't know what it is about that area that some (probably Intel) machines don't like. If someone ever figures it out, let me know and I'll fix it :D As for getting around that bit, I think Zazu had the right idea using the console to move to the NewAcadia area. I think you might want some co-ordinates on that too, never figured out how to do it myself :)

    DirichletP
  • AndarianAndarian Member Posts: 171
    I've recently become aware of some backward compatibility issues with non-Windows (e.g Mac and Linux) clients for EE that are causing crashes with specific tilesets. I've had similar reports of that on Sanctum of the Archmage as well. This might Here are some links related to it, which could be related to the problem you're seeing.
    https://forums.beamdog.com/discussion/comment/1126819/#Comment_1126819
    https://forums.beamdog.com/discussion/comment/1095206/#Comment_1095206
    https://neverwintervault.org/comment/52809#comment-52809

    Savant1974ZazuDirichletP
  • DirichletPDirichletP Member Posts: 2
    Hi,

    Sorry for being the one who comes with bad news. It seems that also the module "Act IV, Pt 2" is affected by the issue described above. However, this time the incriminated area is the first one and therefore it is not possible to play the module at all. The first area is called "Tusonite Camp, West of Brackford".

  • Savant1974Savant1974 Member Posts: 245
    That's a shame, but it's working for me and I'm guessing anyone else with an AMD machine. :(

  • FiarynFiaryn Member Posts: 1
    This is most likely not an issue related to this specific campaign, but I thought I'd ask if anyone has had a similar problem:

    A friend and I were on Act 4 Part 2, we took a couple weeks off, an update for NWN EE was released and we tried to pick back up. Now when I open up the game none of our save files are actually showing up in load game/load LAN game anymore, despite the save files still existing. I tried reverting to an older build of NWN EE and nothing changed. Anyone have any idea what might cause something like this?

  • chevalierchevalier Member Posts: 44
    Hi, Savant. I'm really looking forward to playing this. You mentioned there's something extra for paladins and bards, and I'm probably going to play as a paladin.

    The thing is, you can only play a vanilla paladin so many times. I'd like to multiclass or make a non-standard build. Here are some ideas I'm sporting:

    1. Paladin/WM/CoT, dual-wielder. As few Paladin levels as possible.
    2. Paladin/WM/CoT, two-hander. As few Paladin levels as possible.
    2. STR-based Paladin with 14 CHA but raising STR instead, like before DM/DS. Possibly Half-Orc just for the sake of it.
    3. Paladin/Rogue to handle traps (to be able to travel without a rogue and not be gimped/awkward) and UMD and perhaps Tumble.
    4. Some sort of Purple Dragon Knight in a module justifying the use of this class, obviously in some sort of combination with any 1–2 of: Paladin, Fighter, CoT, WM.
    5. Something paladin-y with Harper Scout in a module where this class would make particular sense.
    6. Non-paladin CoT.
    7. Something with both Paladin and Ranger, probably dual-wielding.
    8. Some sort of Neutral Good plain fighter to just see the difference (being good and doing the right thing while not strictly lawful or beholden to a strict code or burdened with the whole paladin-y business, also more worldly, as in more 'allowed' to just admit he likes the gold and glory and the opportunity to rise to noble titles or get to rule something).

    Would any of these be more fitting for Aielund, or more rewarding?

    Will Persuade pop up often and will it have difficult DCs? Any other skills (or stat levels) to not want to miss out on? What would make the most sense to pick Weapon Focus in if taking CoT or WM levels early?

  • Savant1974Savant1974 Member Posts: 245
    Theres a longsword holy weapon so weapon focus on that. There are lots of persuade opportunities too so dont neglect it. I designed the campaign to be friendly to any class build so do what feels right for you :)

  • dirtyhippydirtyhippy Member Posts: 2
    Hello, hopefully someone can help with a problem in the early part of act 4. I've just met King Osric but I must rest and buy some equipment first, so off I go. When I come back Osric is missing and I can't get the story to continue. I've tried resting up stairs but he still doesn't appear (this is the Palace in MYRFELL).

    Otherwise - what a adventure this Mod has been, thoroughly enjoying it (I'm on vanilla NWN, bought nearly 20 years ago!). Though the end battle in Act 3 nearly made me lose my marbles it was so hard - took about 20 re-runs - no kidding.

  • dirtyhippydirtyhippy Member Posts: 2
    Its ok found out I needed to do all the sub quests in the town first, even though dialogue says come back in a few hours.

  • DonCzirrDonCzirr Member Posts: 158
    In Act I, is it possible for Nellise to restore me after being level drained by a Wraith Spider?

    I was fiddling with her "series of healing / buffing spells" but was not happening.

    I guess the same applied to slow / neutralize poison.

  • ZaxaresZaxares Member Posts: 1,200
    If Nellise is high enough level to cast Restoration, then yes. If not, then try finding a scroll of Restoration somewhere. Maybe getting the church NPC to "I need healing" you might also work. In a last ditch resort, I believe that if you reduce the difficulty setting, resting will get rid of level drains as well.

  • DonCzirrDonCzirr Member Posts: 158
    Ok thanks Zax.

    I had done what you suggested - left the mine and went to the Priestess and she fixed me up.

    It just seemed to me that Nellise may only be doing straight heals since she did not cure poison either - but perhaps she was still too low level for that as well.

    I'll see what happens when she gains a few levels. In the mean time, I got some scrolls for Restoration etc.

    A nice addition to the sub-menu system might be to have a choice for removing negative effects instead of lumping it with the Heal request menu.

    Not sure if this very good module is still being supported though ?

  • ZaxaresZaxares Member Posts: 1,200
    Neutralize Poison is a 4th level spell, but usually you only need it in the very rare situations where the poison is so deadly that leaving it untreated would result in the party member dying (usually through CON loss). In most cases, it's much easier just to let the poison run its course and then use a Lesser Restoration (2nd level, I believe) spell to treat the stat loss.

    Savant1974 (the mod's author) definitely does check this thread from time to time, so I'm fairly sure it's still supported, yes.

    Savant1974
  • DonCzirrDonCzirr Member Posts: 158
    Thanks for the additional info Zax.

    Big hats off to you Savant1974 - this is outstanding work.

    I appreciate the effort that must have gone into this project.

    Cheers

    Savant1974
  • BohuntinBohuntin Member Posts: 4
    @Andarian @Savant1974
    I recently played through the saga and ran into the same crashes reported above. All 3 players are running linux (fedora) with AMD cpu and NVidia graphics cards (very latest drivers because fedora+rpmfusion is bleeding edge :-)

    I was able to "fix" it and avoid the crash by flattening all the raised areas. IIRC, this was Tusonite Camp at the start of Act III, Cairnwood Forest in ActIV-Pt2, and Assumption - The Blessed Vale in Act IV-Pt3.

    I have also run into tileset-inducing crashes in other modules that could be fixed by either flattening raised areas or (in one case) removing a specific tile.

    I have reported bugs and provied crash report and details to Beamdog's service desk. Silence.
    I looked at the CEP forums but no posts more recent than 2018 there.
    Not sure what else to do.

    Bohuntin

  • IseweinIsewein Member Posts: 355
    edited December 2020
    I've never played multiplayer in NWN before, but what with the long lockdown winter ahead I thought it might be an interesting idea to gauge interest for a forumite co-op run through Aielund? Say a weekly or biweekly session, flexible time slot - I'm on GMT personally, but my Circadian rhythm has been thoroughly wrecked by now anyway. I'm an exiled P&P gamer, so it might be nice to do some light RP as well, although I have no idea how well that translates to the screen yet. Modules don't require a DM as far as I understand.

    StummvonBordwehr
  • Fleur_de_LysFleur_de_Lys Member Posts: 1
    I just registered while playing Aielund Saga now for the 3rd time solo - this time as a monk/fighter - and expierienced the same gamebraking bug again like in all the other playthroughts with the EE.

    In Fort Highmarch the "Counts lost love" quest is broken for me as after the conversation with the captain i cannot enter Saffrons house because the door "is jammed from the other side".

    The only way i found to continue was the following console command

    dm_movetoarea safhouse

    After this console command i opened the door from inside and entered again, further play worked out fine every time.

    Maybe this helps someone who faces the same issue.

Sign In or Register to comment.