Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Categories

Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

*IMPORTANT* Regarding Intel Hardware! Driver issues, slow game performance

17810121324

Comments

  • JoeWalkerJoeWalker Member Posts: 75
    I'm using Intel Pentium P6200, 2.13 GHz , 3MB L3 cache, Intel HD Graphics, 3GB DDR3 Memory, 500 GB HDD and my game lags very badly as do the videos making them unwatchable. The sound also makes a static sort of sound. The upside is that it doesn't crash and so far, with a lot of patience, I've been able to reach the FAI.

    Does anyone have any ideas for me to get it to work properly? I saw something about a directX thing, how long until something like that would be available?

    Any help would be appreciated
    Thanks

  • ibitatoibitato Member Posts: 64
    compa

    ibitato said:

    ibitato said:

    also, I did change:

    x and y res to my laptop res,
    use full screen = 0
    window maxmized = 1
    max frames to 60 (this one pretty sure it does nothing (yet) but hey just in case)

    this seems to help a little bit on the lag, aside from the win95 trick
    so i play on a maximized window on the laptop, plus:
    opengl to 1
    compat mode to w95, all the desktop/erc gizmos utrned off
    cpy affinity to 0
    process priority to high

    I got lost at cpy affinity and process priority. I can't find these options, where are they?

    you need to run the game, alt-tab
    open process manager (right click on the task bar and choose)
    in processes look for baldur.exe right click and you have both options there
    they will stick every time you run the game you only need to do it once
    Thanks! I have also had some success with turning down the graphics options in the baldur.ini

    Set the following in the ini file to improve performance slightly:

    'Game Options', 'Always Dither', '0',
    'Game Options', 'Weather', '0',
    'Game Options', 'Area Effects Density', '10' ,
    'Program Options', 'Translucent Shadows', '0',
    'Program Options', 'Sprite Mirror', '1',

    I have also tried

    'Program Options', 'Backwards Compatible 3d', '1',

    but I'm not sure if this last one makes any difference. Note that with Area Effects Density you can set any number from 0-100 I think (it is a percentage, I believe) so a lower number makes for faster performance when area effect spells are in play.
    compatible 3d among with other values revert to default once you fire the game

  • PhoenixDownPhoenixDown Member Posts: 38
    edited November 2012
    Oh btw I tried those custom drivers "Sherry". They work and all, but don't change a thing in BG:EE performance on msi u130. I don't think they will change anything on other hardware also so don't bother yourself with them.

  • RawiRawi Member Posts: 7
    jhart1018 said:

    Just read Gateway's email and it was moderately helpful. They gave me generic instructions on how to install a new driver, so after some trial and error, my wireless works again. Yay. Presumably, I have to do something similar with my graphics driver, but I don't know what I'm looking for or at or whatever. Am I looking to install a new driver for the chipset or the vga (don't even know what that is) or something else entirely?

    Windows says my driver is all the way updated, but I don't think I believe it. The number string after the driver (which is just Intel HD graphics) is 8.15.10.2119. I have no idea whether that's anything helpful, and Gateway's website is written for people who know what they're looking for.

    What's your laptop and processor model ?

    If you have 2nd generation of intel i3/5/7 then you should download and install
    http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Graphics&ProductLine=Laptop+graphics+drivers&ProductProduct=2nd+Generation+Intel®+Core™+Processors+with+Intel®+HD+Graphics+3000/2000&ProdId=3319&LineId=1101&FamilyId=39

    If you have 1st generation of intel i3/i5/i7 then download
    http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Graphics&ProductLine=Laptop+graphics+drivers&ProductProduct=Intel®+Core™+Processors+with+Intel®+HD+Graphics&ProdId=3231&LineId=1101&FamilyId=39

  • RawiRawi Member Posts: 7
    JoeWalker said:

    I'm using Intel Pentium P6200, 2.13 GHz , 3MB L3 cache, Intel HD Graphics, 3GB DDR3 Memory, 500 GB HDD and my game lags very badly as do the videos making them unwatchable. The sound also makes a static sort of sound. The upside is that it doesn't crash and so far, with a lot of patience, I've been able to reach the FAI.

    Does anyone have any ideas for me to get it to work properly? I saw something about a directX thing, how long until something like that would be available?

    Any help would be appreciated
    Thanks

    For Penium P series processors try downloading and installing this driver
    http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Graphics&ProductLine=Laptop+graphics+drivers&ProductProduct=Intel®+Pentium®+Processors+with+Intel®+HD+Graphics&ProdId=3524&LineId=1101&FamilyId=39

  • JoeWalkerJoeWalker Member Posts: 75
    I'll try that and see if anything happens, thanks

  • danefitchdanefitch Member Posts: 22
    Mobile Intel 4 Express Chipset, Fujitsu Laptop, Windows 7 Home Premium 64bit

    VERY IMPORTANT FOR ANYONE USING WINDOWS 95 COMPATIBILITY FIX:

    Make sure you edit the Baldur.exe file (C:\Program Files (x86)\Baldur's Gate Enhanced Edition\Data\00766\Baldur.exe) - editing any other file, launcher or otherwise, will not affect gameplay.

    Thanks for everyone's help with this. Working smoothly now. Will update if any errors occur.

  • MoiraMoira Member Posts: 173
    @pablomni
    Master technical FAQ mentions blurry text problem ("The fonts are extremely blurry."), check it out. I remember it's covered in one of the other problem threads as well, look through them if the FAQ doesn't help you.

    @jamie241 @JoeWalker
    Check out the Master technical FAQ. Fiddle around with the compatibility mode settings as well (see here).

  • jttm80jttm80 Member Posts: 3
    Desktop PC
    Intel i7 3.2G
    nvidia GTX480 (latest drivers)
    Win 7 64bit

    Problem: Game crashes at start. Only a black screen and nothing else.
    Not even Ctrl-Alt-Del works.

  • ibitatoibitato Member Posts: 64
    jttm80 said:

    Desktop PC
    Intel i7 3.2G
    nvidia GTX480 (latest drivers)
    Win 7 64bit

    Problem: Game crashes at start. Only a black screen and nothing else.
    Not even Ctrl-Alt-Del works.

    try running baldur.exe directly with admin rights and 95 comaptibility enabled

  • CronerullCronerull Member Posts: 1
    hello ok i see many people have the same problem but what about laptops with 2 graphic cards?i got intel and radeon and the laptop itself is only 2 years old and i tried with catalyst to change the graphic and it still has the same fps lag issues and the game is rly slow.anybody else have this problem?if not how the fuck dou you fix it???

  • RawiRawi Member Posts: 7
    Cronerull said:

    hello ok i see many people have the same problem but what about laptops with 2 graphic cards?i got intel and radeon and the laptop itself is only 2 years old and i tried with catalyst to change the graphic and it still has the same fps lag issues and the game is rly slow.anybody else have this problem?if not how the fuck dou you fix it???

    I have intel + nvidia cards and my solution was to update intel drivers from http://downloadcenter.intel.com to the latest drivers.
    Having old intel drivers I had perf issues even if I forced nvidia card to work.
    After updating intel drivers both cards work fine in BGEE

  • Boston1112Boston1112 Member Posts: 19
    Has anyone with a Mobile Intel(R) 965 Express Chipset Family managed to find a solution yet? I've updated by driver via Vaio because my driver is a "custom one" and not a general Intel chip, but that didn't solve my problem. I've made the changes to my ini file, but that didn't get rid of the lag. I've changed the compatibility to run on Windows 95, which did reduce the lag but nevertheless didn't bring the combat/spellcast lag down to a playable level. I also download the Scitech GL Dirct application, but that proved to be a dead end because when I'm running that application BGEE doesn't run at all.

    Thoughts? Needless to say, I'd greatly appreciate any and all help that I may receive: I really do love the BG Trilogy and would love to have the chance to return to Baldur's Gate.

  • stadros83stadros83 Member Posts: 16
    Ok just for info, I have a Lenovo T510 with Intel HD (core i3 M380, I think it is HD 3000).

    It wasn't smoothy ... I uninstalled the lenovo graphic driver, and install this one :

    http://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=21776

    And it's working !

    Even the intro !

  • JoeWalkerJoeWalker Member Posts: 75
    Acer Aspire 7741Z
    Intel Pentium P6200 (2.13GHz, 3MB L3 cache)
    Intel HD Graphics
    3GB DDR3 Memory
    500Gb HDD

    When I play the game it lags very badly and so do the videos making them both rubbish. I haven't had any crashes or white screens and am able to play the game just not at the proper speed. I checked on the intel website for any updates for my drivers etc but I am up to date so I changed the baldur.exe file to compatibility mode win95 and there was a significant decrease in lagging making gameplay a little better.

    Does anyone have any suggestions to stop the lagging any more?

  • SagrariusSagrarius Member Posts: 11
    Hi, everyone. I am passing through the same problem many people are: I have a Intel graphic card and it doesn't support the game properly. The game was lagging and chopping constantly, until I do the baldurs.ini thing, set the compatibility to Win95 and update the Intel Graphic Card – though, the videos are bad and, at gameplay, areas where there are many sprites or animation effects make baldurs very slow again. Now, the game is better and playable, but I hope a definitive cure to this problem, no just a temporary curative... I can't realize the graphics improvements yet because the adjustment needed to make it possible to experience Baldur's again. So, Nathan, are there news about a real solution for us?

  • stadros83stadros83 Member Posts: 16
    Check my post just before.

    Sagrarius
  • SagrariusSagrarius Member Posts: 11
    stadros83, my graphic card is Mobile Intel 4 Series Express Chipset Family, so this driver doesn't have use for me.

    Anyway, thanks.

    Nathan, tell me you have news os a miraculous patch that will solve our problems, please.

    Quaestor
  • stadros83stadros83 Member Posts: 16
    Did you check on intel website the last driver ?

    Quaestor
  • SagrariusSagrarius Member Posts: 11
    Yes. I downloaded the last update there.

  • legopaidilegopaidi Member Posts: 6
    Mobile Intel 945 Chipset family with the latest updates. Game doesn't open and / or crashes immediately.
    Anyone with 945 Chipset found a solution?

  • RedGuardRedGuard Member Posts: 672
    I've tried a lot of the options in this thread and I'm getting marginal improvements at best. There's just no way I can realistically play this game since even just walking is so laggy and spells or battles just make it worse. I experience severe slowdown when I'm outside the main library at Candlekeep and the ambush scene with Gorion vs Sarevok as well, not that the game isn't especially laggy when not in those areas.

    Here are my specs if anyone has any ideas.

    Advent Roma 2000

    Processor: Intel Celeron C900

    OS: Windows 7 Home Premium (32 bit)

    Memory: 3072MB DDR2 RAM

    Graphics: Integrated Intel Mobile 4 series

  • MoiraMoira Member Posts: 173
    @RedGuard
    To help you work on your problem, we'd need to know what you've already tried and if any of it made any difference.

  • stepbergstepberg Member Posts: 16
    Hey guys! I also had a lot of lagging and choppy videos. My fix was simply to force my Nvidia graphics card to be used with the baldur.exe (as has already been mentioned in this thread). Didn't need to use any compatibility mode or stuff like that. Thanks for the tip btw!

  • pablomnipablomni Member Posts: 94
    edited November 2012
    Moira said:

    @pablomni
    Master technical FAQ mentions blurry text problem ("The fonts are extremely blurry."), check it out. I remember it's covered in one of the other problem threads as well, look through them if the FAQ doesn't help you.

    @jamie241 @JoeWalker
    Check out the Master technical FAQ. Fiddle around with the compatibility mode settings as well (see here).

    .....

    The fonts are extremely blurry: SOLVED! THANK YOU "Moira"!!

    "The fonts are extremely blurry.
    Disable FXAA in your video card options. AMD users that experience the same problem might have a similar option in their video card options (MLAA?).

    There is constant full-screen flickering, or parts of previous screen show on a new one (it doesn’t clear properly)
    Disable triple buffering in your video card options.

    Text overlays (tooltips) are flickering.
    Disable adaptative VSync in your video card options."

  • AnduinAnduin Member Posts: 5,745
    As stated earlier I have an Aspire 5738
    Intel Core 2 Duo Processor
    Intel GMA 4500 MHD

    Very choppy and laggy, even with win 95 compatibility put on.

    Tried to update to latest intel driver but the download would not allow me as I have some kind of computer manufacture kit in the way... Making me go to acer... That informs me I have latest drivers... I have tried to go round this, but I get flagged that the wrong driver is trying to be installed... Any other ideas?

    Not giving up, I have downloaded 3D-Analyze, but I am not sure what I am doing... I was hoping to trick the game into thinking I had a nvidia card... Lots of settings but I am not very good at this...
    I can teach kids to read if that helps? I am also good a t following instructions :)

    Gosh... I so wish to be able to play this game... It looks brilliant... But I would so like to see some of the people move...

    I have windows 7... Do I need to download that blast from the past directX... (them were the days...)

  • ibitatoibitato Member Posts: 64
    Anduin said:

    As stated earlier I have an Aspire 5738
    Intel Core 2 Duo Processor
    Intel GMA 4500 MHD

    Very choppy and laggy, even with win 95 compatibility put on.

    Tried to update to latest intel driver but the download would not allow me as I have some kind of computer manufacture kit in the way... Making me go to acer... That informs me I have latest drivers... I have tried to go round this, but I get flagged that the wrong driver is trying to be installed... Any other ideas?

    Not giving up, I have downloaded 3D-Analyze, but I am not sure what I am doing... I was hoping to trick the game into thinking I had a nvidia card... Lots of settings but I am not very good at this...
    I can teach kids to read if that helps? I am also good a t following instructions :)

    Gosh... I so wish to be able to play this game... It looks brilliant... But I would so like to see some of the people move...

    I have windows 7... Do I need to download that blast from the past directX... (them were the days...)

    the game is opengl, not directx
    try puting your 3d config to performance and if you find it, disable tripple buffer for opengl
    there is no way to completely get rid of the lag until developers fix it
    it's a problem with opengl and intel GPUs and opengl support,
    is going to take time

  • AnduinAnduin Member Posts: 5,745
    @ibitato Thanks... We can hope for something before Christmas...

  • RedGuardRedGuard Member Posts: 672
    Moira said:

    @RedGuard
    To help you work on your problem, we'd need to know what you've already tried and if any of it made any difference.

    @Moira This is what I tried (at least what I can remember right now):

    The Ini file alterations

    links for custom drivers and such and that GL thing from MajorGeeks.com

    Windows 95 compatibility (with the three other options underneath ticked, which was the only thing that show even a marginal difference)

    Uninstalling my current driver and updating it to the newest version

    Razer game booster

  • LoneWandererLoneWanderer Member Posts: 2
    Sigh, I have been waiting for this game for months... I, too, have Windows 7 and am having problems running the game and the videos. Gaming, as others have said, is very choppy and laggy and the introduction movie does not show at all. This is a big disappointment for me, and to think that I had even sent several e-mails to Beamdog, specifying my computer's characteristics, but this problem was never mentioned. Now, either the problem is fixed or I expect a refund. Honestly, it just hurts seeing the icon on the desktop and not be able to play...

    Callmee_John
Sign In or Register to comment.