Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!


Dark Dreams of Furiae - a new module for NWN:EE! Buy now
Attention, new and old users! Please read the new rules of conduct for the forums, and we hope you enjoy your stay!

General BGEE Customization Pre V2.0



  • JuliusBorisovJuliusBorisov Member, Administrator, Moderator, Developer Posts: 21,830
    @AsternOak582 Check if you included the line correctly. Follow this detailed recommendation by @Isaya:

  • ThelsThels Member Posts: 1,376
    2.0 changed how you need to enable Debug Mode:

    First, you need to edit "Baldur.lua", not "Baldur.ini". Actually, if you still have a Baldur.ini file, you may as well delete it.

    Second, instead of the lines included in the description, you need to add the following line. It's position doesn't matter:

    SetPrivateProfileString('Program Options','Debug Mode','1')

  • alainpoetaalainpoeta Member Posts: 1
    How can I change the frame rate?
    In baldur.ini was 'Program Options', 'Maximum Frame Rate', '45',
    in baldur.lua how does it work?

  • IsayaIsaya Member, Translator (NDA) Posts: 752
    SetPrivateProfileString('Program Options','Maximum Frame Rate','45')
    Open the file, look at the lines already present and it will become obvious. This is the same content as before, but the format is slightly different.

  • kaguanakaguana Member Posts: 1,328
    @Cuv I know you probably busy but please update your initial post here so people won't get confused please.

  • RodrianRodrian Member Posts: 426
    edited April 2016
    @Kaguana is right, the OP would really use on an update..
    Or maybe just post a new one for v2.0 (and archive this one with v1.3 title change)

    The new one also can be named: Infinity Engine EE v2.0 General Customization :wink:

  • AllenRagiaAllenRagia Member Posts: 1
    edited April 2016
    Okay. I'm getting frustrated. I have followed every instruction here and I Still cannot get cheats to work at all. please help!

    *Facepalm* Nevermind. I'm an idiot. after giving up and finally going to sleep I woke up and tried again and found out I was altering my Baldur's Gate 2 lua not my Baldur's Gate 1. *sigh* Beware the power of idiots and the problems they can cause. Many thanks for the attempts to aid me though.

    Post edited by AllenRagia on
  • ThelsThels Member Posts: 1,376
    @AllenRagia: Have you been editing baldur.ini? If you're up to version 2, simply delete your baldur.ini, edit your baldur.lua file, and add the following line:

    SetPrivateProfileString('Program Options','Debug Mode','1')

  • tls5669tls5669 Member Posts: 12
    I never could get it to stick, every time i pressed ctrl+space, it paused the game. What do i change the permissions to? Edit the file on desktop, replace file, it does the same thing, I have windows 7

  • Hughes_de_PayenHughes_de_Payen Member Posts: 7
    is there a support link for the client? i have tried everything and it just wont work.

  • Hughes_de_PayenHughes_de_Payen Member Posts: 7
    it works now damn settings would not save permisions.finaly got it right

  • ecmecm Member Posts: 1
    I wasn't sure about the second 2 lines, so this is how i entered it (it still isn't working):

    SetPrivateProfileString('Program Options', 'Debug Mode'
    SetPrivateProfileString('Program Options',CREATE TABLE options ('section string,' 'name string,' 'value string');
    SetPrivateProfileString('Program Options',INSERT INTO options ROWS ('Program Options','Debug Mode', '1',

    can someone correct me on this :'( ?


  • Mr2150Mr2150 Member Posts: 1,170
    edited May 2016

    You only need one line and it should look like this:

    SetPrivateProfileString('Program Options','Debug Mode','1')

    I'd also make sure the game is not open when you edit the file and then ensure you've saved it (save, close, reopen, check, close) to ensure it is still there...!

  • argent77argent77 Member Posts: 3,067
    You should be careful with this option and make a backup of your Baldur.lua beforehand.

    In my tests it worked correctly when starting the game the first time after making the changes. However, subsequent starts will reset the Baldur.lua completely to game defaults. It's most likely caused by the game writing the OVERRIDE lines back to the Baldur.lua in the wrong format.

    It works fine in game patch v1.3 though.

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    argent77 said:

    In my tests it worked correctly when starting the game the first time after making the changes. However, subsequent starts will reset the Baldur.lua completely to game defaults. It's most likely caused by the game writing the OVERRIDE lines back to the Baldur.lua in the wrong format.

    What line did you use? Did you use quotes or double square brackets?

  • argent77argent77 Member Posts: 3,067
    I used double square brackets, but the game writes the lines back using single quotes instead.

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    Not on my end. It writes them back using double square brackets. Curious. If you post an example of the path you used I might have more of an idea why that's happening.

    In any case, as I said, it's an unsupported feature. :-)

  • argent77argent77 Member Posts: 3,067
    edited May 2016
    I'm using the same format as in your examples:
    SetPrivateProfileString('OVERRIDES','1',[[C:\Users\argent77\Documents\Infinity Engine - Enhanced Edition\override]])
    The path doesn't matter. Actually, it does matter. Having a single quote in the path name causes the game to write the string back in the correct format.

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    I'm guessing you don't have quotes in your other paths? I should clarify that you need to use double square brackets if you have quotes in your path, else you need to use the UNIX-like path delimiter slash "/" rather than the Windows "\".

    See updated example above.

  • argent77argent77 Member Posts: 3,067
    edited May 2016
    That explains it. It works perfectly fine with slashes as pathname separators.

    Edit: It looks like user-defined override folders take precedence over all hardcoded override folders. The user-defined override folders themselves are applied in random order.

  • Troodon80Troodon80 Member, Developer Posts: 4,110
    edited May 2016
    The order should start after the last hardcoded override (install:/override). After that, they are indeed random (whatever order they are interpreted by in the LUA). If you create a new item, let's say "TESTAR01" and put it into your custom override, then make a modification to the inventory icon and place that in the install:/override, the install:/override folder should take precedence (at least it does for me).

  • FeronasFeronas Member Posts: 11
    edited June 2016
    Can someone please help, I can't get the cheats enabled, I've followed the instructions mentioned in this thread... below attached screenshot of the Baldur INI file...

    I realized that after the update I should edit the LUA file instead of the INI file... my bad sorry.

    Post edited by Feronas on
  • animecrisisanimecrisis Member Posts: 12
    How do you add daily uses to items, an example would be the ring of invisibility, or ring of human influence

  • mattymatty Member Posts: 3
    Im having chapter 9/10 neena tob problems I cant enter chapter ten. post me privately for my email. thanks alot

  • DragonKingDragonKing Member Posts: 1,884
    Ok, I did all this, but my advance time isn't working. Ctrl+ key works, but the CLUA don't seem to work anymore though.

  • ThelsThels Member Posts: 1,376
    @DragonKing: Use "C:command" rather than "CLUAConsole:command".

    Also, keep in mind this thread is for 1.x versions only, NOT for 2.x versions.

  • DragonKingDragonKing Member Posts: 1,884
    I learned that all I had to do was use the C: noe instead of typing the whole thing out.

Sign In or Register to comment.